Question

Can't browse TuneIn anymore

  • 16 January 2017
  • 7 replies
  • 175 views

I recently moved and can't browse TuneIn radio from my Play:1 anymore. Have tried factory reset etc to no avail.

Diagnostic report 7003291 submitted, any suggestions appreciated as TuneIn was one of my most used functions of Sonos. Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
what happens when you go into TuneIn inside the Sonos app?
It says "Unable to browse music" (PC controller or iPhone app). TuneIn itself works via browser or iPhone app on the same network.
Userlevel 7
Badge +20
It says "Unable to browse music" (PC controller or iPhone app). TuneIn itself works via browser or iPhone app on the same network.

Hi AlexSJW,

Please try rebooting your router and also reboot each Sonos unit. This should update the network information on your system and may help you connect. If not, send in a new diagnostic report and reply here with the confirmation number.
Tried rebooting / updating everything, still can't browse TuneIn. New diagnostic submitted: 7158092
I replied with a follow up diagnostic but checking back its not showing up in the replies - I have done it again 7163617.
Userlevel 7
Badge +20
I replied with a follow up diagnostic but checking back its not showing up in the replies - I have done it again 7163617.

It looks like your Sonos system isn't able to communicate past your router when it tries to connect to TuneIn. The connection between Sonos and TuneIn goes through port 80, try checking your router's security settings and see if it is blocking port 80 for any reason.
Hi Jeff, thanks for the reply. I assumed that the Sonos can't communicate past the router anymore, since not only TuneIn but all other music services say "Unable to browse". Port 80 is not blocked by my router (isn't this HTTP port anyway?), and I tried forwarding that port to the Sonos, but it didn't make any difference. Is there a way to change the port the Sonos is using?