Question

Can´t add music library

  • 18 October 2016
  • 9 replies
  • 366 views

Hi,
Sonos Play:5 wireless connection through Thomson router.
can´t add local music library using Desktop Sonos Controller (Windows 10). Keep getting "The computer "XXXXX" cannot be found".
Already tried this with no success https://sonos.custhelp.com/app/answers/detail/a_id/692?_ga=1.25760445.1291639924.1476652004.
Tried with both windows firewall and router firewall turned off and still the same error.
Can stream radio and soundcloud through Controller and mp3 files through windows homegroup without any issues.

Help much appreciated.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

ref: 161017-002259
Is the music library on the windows 10 PC? And is that PC wired or wireless? I used to have a Speedtouch router which are now rebadged as Thomson and my router didn't allow connections between the wired and wireless segments of the network (even though they were the same 192.168.1.x subnet), so I couldn't see my wired NAS from my wireless laptop unless I wired the laptop to the router.

Luckily it didn't affect Sonos as I had a wired Sonos device bit it made life difficult and there was no way to change the setting on the router, I ended up replacing the router and haven't had any issues of that type since.
Is the music library on the windows 10 PC? YES
PC wired or wireless? wireless connection through Thomson router.
no NAS. simple local drive mp3 non-itunes music folder.
keep geting same computer cannot be found error even with windows and router firewall turned off.
Try wiring the PC and the Sonos to the router, give the Sonos a few minutes to figure out the connection and then try adding the music library.
Badge +1
It sounds like your home network type may be set to a public network. This is somewhat common when upgrading to Windows 10 and will cause the same issue you're describing. Here are some instructions on how to check and adjust this setting.

  1. Press the Windows Key (on your keyboard) or Start button
  2. Type HomeGroup, and “HomeGroup” will be on top and selected, press Enter
  3. Select the blue link that says "Change network location"
  4. Tap/click on "Yes" when prompted with “Do you want to find PCs, devices, and content on this network, and automatically connect to devices like printers and TVs? We recommend that you do this on your home and work networks.”
  5. To confirm this setting has been set correctly, right-click on the network tray icon, then left-click "Open Network and Sharing Center" it should now display "Private network" underneath your network name instead of public

If your network type is already set to private or you change these settings and it doesn't solve the problem we’ll want a closer look at the system. Can you submit a diagnostic and reply back with a confirmation number?
Hi,
according to windows my network is already set to private.
Diagnostic 6681469.

Thanks
Diagnostic 6681469.
Can someone help me please?
Userlevel 3
Badge +2
Go into network card settings, Enable Netbios Over TCP/IP

The vid is for Windows 7 but the steps are almost identical for Win 10



IPV4, Advanced, Wins

https://www.youtube.com/watch?v=kv10Y1EIkzE
Worked like a charm SBSurfer.
Cheers mate