Can't add all album to PLAY 3 queue

  • 13 February 2017
  • 6 replies
  • 149 views

Userlevel 2
I have a ZP90 wired to my network, 2 x PLAY 1 and a single PLAY 3 connected over wi-fi. My main source of music is via my Synology NAS containing my iTunes collection which is on the same wired network as the ZP90. I have also configured Amazon Music as a source. I use the Sonos app on my iPhone, iPad and my Mac.

When using the app, i can add a full album to the end of a queue, or replace a queue with the current album, fine on the ZP90 and the 2 PLAY 1s, however it does not work on the PLAY 3. I get an error "Unable to add songs to the queue". This only happens when adding albums stored on the NAS, i do not get the error when adding an album from Amazon Music.

The error occurs on on all apps no matter which device i run the app on. I can only add a single song to the PLAY 3 queue one at a time this way, it will not accept adding a full album to the queue.

This is driving me insane as it takes forever to add music to a queue one track at a time as opposed to a full album. I've checked that there are no updates for the system, all is up to date. It only started happening in the last month or two.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +21
First thing to do is do a system reboot.

Switch off router, all Sonos kit and EVERY item linked to the network (phones, tablets, computers - no cheating)

Switch on router, wait a couple of minutes.
Switch on Bridge or Boost (If you have one of those), wait a few minutes.
Switch Sonos players back on
Switch all other devices back on.

There is a good chance this will resolve your issues