Question

Can Not Connect Playbar Speakers to Sonos Boost


I noticed a couple days back that my Sonos Playbars and Play 1 were not showing up in the Controller software.
I have done numerous things to try and connect the Playbars and Play 1 but so far have only been able to get the Play 1 connected. The Playbars will not connect. I was using a Bridge and thought that there might be an issue with it so I decided to try and connect everything to my router (ASUS) through the wireless setup. After a little bit of fuss with some software updates I manged to get my whole system working with it connected to the router in this fashion. I thought that I had things beat and that the Bridge was the problem. I went out today and bought a Boost because I want my Sonos system running on it's own wireless network and not adding more wireless traffic to my router. I set up the Boost as per the instructions and was only able to get the Play 1 to connect to it. The Playbars will not connect. I ran a Ethernet cable from one of the Playbars to the bridge and it works perfectly hardwired but I can't get it to connect wireless. I have tried all of the suggestions that I have read so far (reset the router, speakers, Boost) and even uninstalled the software from my PC (Windows 10) and reinstalled it to start a fresh install of everything. Nothing as worked to get the Playbars to connect with the Boost. I just read about changing the wireless channel and will try that tomorrow. The only other thing that I have not tried is a factory reset of the Playbars. I have read that this should be a last resort and was wondering if it's really a big deal. The Boost is brand new and should not require a factory reset.
I have read that some people have been having issues after the last couple software updates. Everything worked perfectly for the last 5 years and it seems to have started after the last couple updates.

Has anyone else run into a similar problem? I am looking for any other suggestions that would help me resolve this issue.

Thank you

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

First off, I highly doubt that it has anything to do with the updates. While it's hard to say that with 100% confidence when dealing with software, I feel fairly comfortable in saying it with 99%. But, you're still having issues, so my confidence in that doesn't help much, does it?

I think your intentions are good, using a Bridge/Boost makes good sense in terms of separating the traffic from your own wifi network onto SonosNet. I've done the same thing at my home, for exactly the same reasons.

Unfortunately, as near as I can tell from your post, you've attempted the majority of standard processes to fix the issue, other than setting up reserved IP addresses, so I'll resort to my last recommendation.

Submit a system diagnostic and post the number here, or call in to Sonos help line. That will give the techs from Sonos access to around 10 minutes of log files from your system, and perhaps have a suggestion on what other things to try. If you want to call in to talk to someone, you can find their numbers at www.sonos.com/contact

One random thought, though. When you replaced the Bridge with a Boost, did you also change the power supply? There's been infrequent issues with the power fluctuating on very old Bridge power supplies, and I'm wondering if it's possible that a flaky current might potentially be causing the issue. Doesn't seem likely, based on what I know about electrical engineering, but worth looking into, if just to rule it out.

Best of luck!
Oh, and if you think it may be the Bridge causing the problem, disconnect it completely (power and ethernet) and connect the ethernet cable to one of your speakers directly. This will help you test whether the issue is with the Bridge directly, since they're no longer a required aspect of the SonosNet network, since all speakers now have the ability to act as a root device for SonosNet.
Thanks for the response. I made sure that I changed the power supply when I hooked up the Boost. Just so I am clear on your suggestion, if I hook the Play 1 directly to the ethernet then I should try to connect the Playbars wireless. I will try this to see if it works.
I am not sure if it's the Bridge now since I bought a brand new Boost and still no luck connecting through that. What are your thoughts on a factory reset of the Playbars to see if that would help?
As long as you're only resetting the Playbar itself, and not any of your other speakers, it should be fine. Just remember, the speakers are where many of your playlists are stored, if you were to factory reset them all, you'd lose that data.

Yep, hook the ethernet cable to the Play:1, and see what happens. Make sure you unplug the Bridge, just on the off hand chance it's causing some sort of interference. Remember to give it 5 minutes or so to settle down once you've powered everything back on, you can look in settings > About My Sonos system to see what's on what (WM:1 versus WM:0)

And if none of this works, I'd heartily recommend calling in to Sonos. You can find their phone number at www.sonos.com/contact. If it ends up being a hardware issue, there's pretty much nothing that can be done on the boards about that, and you'd need to speak to them directly.
Ok...thanks. I will give that a try and if I have any luck I will report back. If not I will run a diagnostics first before trying the factory reset on the Playbars.
Airgetlam....I have everything up and running again. I decided to just leave everything for a couple weeks since I have been busy at work and today figured I would try and get things working again. The only thing that I did different was load the controller on a different computer and set everything up from that one. I am using the Boost (which I probably didn't need to buy) and all of my speakers connected without any issues. I have no idea as to what the problem was since everything connected perfectly. Thank you for your assistance. I wish I could give some insight to the problem which might helps other but like I said...I have no clue as to why it worked this time and not the other times I tried.

Thanks again.
Nothing worse than fixing a problem and not knowing why it was fixed. I'm pleased you're up and running. If you run into issues again, be sure to run that diagnostic and post the number and explanation here 🙂