Can no longer access music on MyBookLive NAS (Roam/S2)

  • 2 August 2022
  • 2 replies

I have a Roam and I use either my PC (Windows 11) or my phone (Android) to access it. 

I have my music on a WesternDigital MyBooklive (2TB) with the following path //mybooklive/public/music. It’s wired in to the router. 

For the first 9 months this all worked fine. I put the path details in the app, it indexed everything and all was good. 

Some months back it just stopped, saying that it can’t access the NAS. So I split the “music” folder thinking that it might be a size issue (despite only being 10,000 tracks) so that now I’ve got two locations with music. They are:


//mybooklive/public/music (56gb)

//mybooklive/public/roam (11gb)


The Roam/S2 app can access the 11gb “roam” folder on the NAS no problem. But it can’t access the 56gn “music” folder. This suggests it isn’t an SMB issue.


Following some research on here I’ve looked at everything using “MP3tag” and there were some entries that didn’t have ID3 tags, so I’ve deleted those and it all now looks good. But still it can’t access the “music” folder. According to Windows the size is 56.9gb, there are 9,494 files, and 1,177 folders. 

I’ve already been through live chat with Sonos support but other than rebooting the Roam and checking for SMB issues they’ve currently drawn a blank.

Any suggestions for what to do next? Thanks. 



Best answer by John B 2 August 2022, 19:27

View original

2 replies

Thank you John. I am not sure if it’s a file permissions issue, but I have done some experimenting since the posting. 

I started off adding some more music to the “Roam” folder and almost immediately it wouldn’t then re-index. 

I then created a new folder called “Sonos” and added 1gb of music to it and it wouldn’t index either.

That was two days ago. This morning I’ve gone to add that same “Sonos” folder and it has indexed absolutely fine. I’ve added some more music to it so it’s now at 3.5gb and it has re-indexed fine too. 

Finally I’ve then tried to add the original “Music” folder and it won’t index it. 

Out of curiousity I got out my old S1 Connect:Amp from the cupboard and set that up (using the different controller) and that indexes the full “Music” folder absolutely no problem. 

So for S2/Roam it feels like there a size constraint issue but also a timing issue with when the indexing happens. Frustrating. 

Is it a file permissions issue?  Has the ‘public’ status of the music folder been transferred (somehow) to the roam folder?  Might depend on how you created / renamed folders.

If all else fails could you just move the contents of music into move?