Beam - Switching from music to TV

  • 18 July 2018
  • 6 replies
  • 5742 views

I am having difficulty switching from music (Spotify) to TV (Apple TV). I have a Beam and two Sonos One speakers.

I was able to switch between input sources in the app, and it appears as if the app understands what I'm trying to do, but no music is being played. I troubleshot the issue, and the only fix I found was to unplug and replug the Beam after listening to music. However, I do not want to have unplug the Beam every time I need to switch sources.

Am I doing something wrong? Can someone help?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +26
Have you tried using the voice commands to switch from music to the TV input?

"Alexa, switch to TV."
"Alexa, switch the Beam to TV."
"Alexa, switch to TV on/in Beam."

The Sonos app shouldn't have any problem switching to the TV input either though, so you should be able to go to the Sonos app, browse, and select TV. It should switch right away.
@Ryan

Thanks. Yes I tried, but it did not work. Note: I had the Sonos One speakers previously and had already set them up for voice activation. I don't think the addition of the Beam worked. Will try resetting Alexa with all 3.
illmatic,

Try this Beam Alexa command...

“Alexa, Switch to tv on (Room Name)” ... so if your TV is in the Lounge for example it’s ... “Alexa, Switch to tv on Lounge”.

Also note, you must use the word 'on' in the instruction and not 'in the'. That is quite significant.

Also note, once you have issued the above Alexa instruction to your Beam, you will then (strangely?) find afterwards, that you can go onto use the more simple instruction, like this... 'Alexa, Switch to TV', at least until you switch off your TV then you have to revert back to using “Alexa, Switch to tv on (Room Name)”. So it appears you have to use this instruction on the first outing, every time.

I am currently trying to raise this issue with Sonos Support.

Can you kindly let me know if the above works for you please.

Thanks ...

Ken
Open the app. Select the room with the beam. Go to "Browse" (menu icon with music node) and go to the top-selection (where you see Library, On this iPhone, Apple Music etc). On this list, you will find "TV" as an option.

Press "TV" and you have your TV sound back on the Beam 🙂
Nothing works for me. It should be as easy as “Alexa play TV”. I’m seriously disappointed to the point I may return this stuff.
Nothing works for me. It should be as easy as “Alexa play TV”. I’m seriously disappointed to the point I may return this stuff.
It sounds like you are trying to turn on the TV, which is slightly different to the main discussion here. If that is the case, then you perhaps need to switch on the CEC control features on your TV for the HDMI-ARC port.