Answered

Bandwidth limitation of SonosNet 2.0

  • 7 January 2020
  • 5 replies
  • 211 views

Userlevel 4
Badge +6

I have recently replaced some older Sonos components (Zp100) with newer Amps and added a Playbar, so my system is now SonosNet 2.0. I anticipated this upgrade would solve an ongoing issue and allow me increased bandwidth for allowing Apple Lossless to be played ‘Everywhere’ ie all rooms/party mode, but I’m still unable to do this.

 

I am starting the playback from the Ethernet connected device, then adding the other rooms, but it still fails. MP3 plays fine. SonosNet supports 32 devices, but is there a lower limit than this for playing lossless formats?

icon

Best answer by Stanley_4 8 January 2020, 00:46

First, try switching to compressed audio and see if that helps. It may not but it is an easy fix.

More difficult is trying to optimize the SonosNet mesh. Having more wired devices is usually a good thing, the more wired the less wireless traffic and the more possible paths for the data to flow. Only glitch might be STP but that is easily sorted using the tips around here.

I’d start with the Network Matrix, use your IP not mine:  http://172.16.1.111:1400/support/review

Give it a look and see if you see any issues, you can search here for what the different things mean and post a legible copy of yours for other folks to comment on.

The basic wireless link has a lot of excess bandwidth if interference is low, if there is more then retransmissions and such can clog things up a bit.

You can also wait for a glitch and submit a diagnostic, contact Sonos support directly with the diagnostic number and the problem you are seeing and they can see stuff we users can’t. Some of the options on the contact page are staffed  24x7 too.

View original

5 replies

Userlevel 7
Badge +21

First, try switching to compressed audio and see if that helps. It may not but it is an easy fix.

More difficult is trying to optimize the SonosNet mesh. Having more wired devices is usually a good thing, the more wired the less wireless traffic and the more possible paths for the data to flow. Only glitch might be STP but that is easily sorted using the tips around here.

I’d start with the Network Matrix, use your IP not mine:  http://172.16.1.111:1400/support/review

Give it a look and see if you see any issues, you can search here for what the different things mean and post a legible copy of yours for other folks to comment on.

The basic wireless link has a lot of excess bandwidth if interference is low, if there is more then retransmissions and such can clog things up a bit.

You can also wait for a glitch and submit a diagnostic, contact Sonos support directly with the diagnostic number and the problem you are seeing and they can see stuff we users can’t. Some of the options on the contact page are staffed  24x7 too.

Userlevel 4
Badge +6

Thanks @Stanley_4 , I have tried a few things.

I reviewed the network Matrix, and have tried replaced the ethernet connection from a Play1 to a Boost, this has made the network Matrix slightly more green, still some yellow.

I then tried ‘party mode’ again, but only included the the rooms that were green in the Matrix, but still getting dropouts.

What I found on the left column of network matrix, where I believe the colour indicates noise/interference, there are red devices when in ‘party mode’. When playback is stopped, there is only green and yellow. Does this mean the ‘noise’ and ‘interference’ is actually being generated by the SonosNet wireless?

I did send some diagnostics to Sonos Support, they also suggested try to wire more devices, but this goes against what I was previously told, ie one wired device.

Looking here https://toolstud.io/video/audiosize.php, suggests Apple Lossless is ~800Kb/s.

Is there anyway to correlate the numbers on the Sonos Network Matrix to actual network speeds?

 

Userlevel 4
Badge +6

I connected another 2 devices to ethernet, so 3 devices in total connected, with the rest wireless.

I did have to review the STP documentation ‘tips’, enabled STP and set switch priority to ‘4096’.

Party mode now works, and just for kicks I played different Apple lossless tracks in each zone, to see how many would play simultaneously. I managed to get all zones playing without dropouts, so I think my issue is now resolved, I think adding another device just tipped the SonosNet bandwidth over its limit with one ethernet connection. 

 

Userlevel 7
Badge +20

First, try switching to compressed audio and see if that helps. It may not but it is an easy fix.

Note that the Audio Compression setting only applies to Line-In sources.

Userlevel 7
Badge +21

The Ethernet on Sonos is 100 MB and your streams are 800 KB each so there should have been plenty there. The ZP is pretty old and with the new software pushing hard against the CPU and memory limits it suffers. I think it is SonosNet v1 too which is a lot slower than the newer v2 that most newer Sonos gear supports.

Glad it is working.

Reply