Answered

Audio playback stops and skips (Problems w/ streaming AppleMusic/TuneIn, but not Line-In)

  • 17 September 2016
  • 12 replies
  • 1130 views

When streaming from Apple Music or TuneIn radio, the music will periodically pause (TuneIn radio) or skip to the next song (Apple Music).

I changed audio compression setting from uncompressed to automatic.

I've read through the support for Audio playback: https://sonos.custhelp.com/app/answers/detail/a_id/309/~/audio-playback-stops-or-skips

Steps I've already attempted to fix:
1) Check if an outage has been reported for the music service you’re using: there's no outage reported at sonos.com/support.
2) Attempt playing music from another online music service: TuneIn radio also stops/skips.
3) Check your Internet connection speed: internet connection is consistently 30Mb/s.
4) Take steps to reduce wireless interference: Standard Set-Up. 2.4GHz wifi changed to channel 6. Width set to 20 MHz. RSSI is -50 dBm. Noise is -92 dBm.
5) Contact Customer Support: here I am.

I've read through the support for reducing wireless interference: https://sonos.custhelp.com/app/answers/detail/a_id/3650/.
1) If you have a Sonos product wired into your WiFi router, separate the two devices as far as the Ethernet cable between them allows; 1 ft. (30cm) or more is ideal.
- Connect wired via ethernet to router. Separated by about 3 feet.
2) Also make sure your Sonos system and router are operating on different wireless channels: 2.4GHz wifi set channel 6. I'm not sure about the Sonos system channel.

Diagnostics: 6554489

What's the ideal solution? Should I set-up a separate network for my Sonos system? Is it Apple Music's fault? Do I just live in crap place for wireless interference?

Any assistance is appreciated. Thank you, Andrew
icon

Best answer by AndrewJ 17 September 2016, 20:21

Just happened again. Here's a the diagnostic immediately afterward: 6554514

Sonos system is channel 1 I believe, but I don't have a Boost component, just a connect and play:3.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Just happened again. Here's a the diagnostic immediately afterward: 6554514

Sonos system is channel 1 I believe, but I don't have a Boost component, just a connect and play:3.
The Sonos controller iOS app displays the following messages when it skips or stops playback:

Unable to play 'song title' - the connection to Apple Music lost
or
Unable to play 'song title' - song is not encoded correctly

Most recent diagnostics: 6554730
I have a Sonos Play 5, Connect and Bridge. For a couple of years the system was bullet proof but for the last 2 it has been totally unreliable and doesn't seem to matter whether you fix the 2.4Ghz channel or make IP address static, it keeps faultering with loss of Tune In or imported playlists from iTunes. This was exacerbated a while back by the BBC here in the uk changing its file format which took months and months to resolve. Some days I have rebooted my entire system 15 to 20 times including router and all allied Sonos components. I have a good reliable broadband connection running at around 69mb and do not experience any problems with any of my other web apps or things like WeMo or heating systems.

I have finally given up and accept that this system is inherenently unreliable for some and is certainly not suitable for domestic users who want a plug and play solution. When it works well, its good but not that good that it warrants the continuous hassle so mine is heading for eBay!
Badge
Same problem here - since the 6.4 update!
Userlevel 7
Badge +19
The Sonos controller iOS app displays the following messages when it skips or stops playback:

Unable to play 'song title' - the connection to Apple Music lost
or
Unable to play 'song title' - song is not encoded correctly

Most recent diagnostics: 6554730


In the advanced settings, please change your Sonosnet channel to 11. Also, be sure to go to Wireless Setup, Tap Next, and then Reset (Only tap Reset, don't enter your password). If this doesn't work, let us know.

Same problem here - since the 6.4 update!

Please submit diagnostics and respond with the confirmation, we will happily have a look. Thanks!
When I try and play a playlist from iTunes I get the error "cannot connect to Apple Music"
Userlevel 4
Badge +3
When I try and play a playlist from iTunes I get the error "cannot connect to Apple Music"

Hi Adrian_13, send us a diagnostic and post with the number; we'll take a look.
I share the same problem. Every music service works fine except Apple Music. Error message of "connection lost" pops up almost every time. Hope you can fix it soon. Thanks.
Userlevel 7
Badge +20
I share the same problem. Every music service works fine except Apple Music. Error message of "connection lost" pops up almost every time. Hope you can fix it soon. Thanks.

Hi KevinMa,

I'd like to see a diagnostic report from your Sonos system. Please send in a report and reply with the confirmation number.
I share the same problem. Every music service works fine except Apple Music. Error message of "connection lost" pops up almost every time. Hope you can fix it soon. Thanks.

Hi KevinMa,

I'd like to see a diagnostic report from your Sonos system. Please send in a report and reply with the confirmation number.


Hi Jeff,

I've sent a report and the confirmation number is 6810682.
Userlevel 7
Badge +20
I share the same problem. Every music service works fine except Apple Music. Error message of "connection lost" pops up almost every time. Hope you can fix it soon. Thanks.

Hi KevinMa,

I'd like to see a diagnostic report from your Sonos system. Please send in a report and reply with the confirmation number.


Hi Jeff,

I've sent a report and the confirmation number is 6810682.


I see some wireless communication errors between your Sonos units. Please try changing the wireless channel your Sonos system is using.

If your system is fully wireless this won't be an option. You can instead change the wireless channel on your router. It may also help to move any third party wireless devices you may have away from your Sonos units.
7161038. Problem about "lost connections" with Apple Music occurs again. I believe my wifi works quite well since other music services don't have the same problem.