Audio dropouts

  • 22 April 2021
  • 8 replies
  • 182 views

Until my new Roam was delivered, I connected my Marley Stir It Up turntable via Bluetooth to my Move, and experienced reliable, excellent quality audio, with no audio problems whatsoever.

Since receiving my new Roam, I have paired the Roam to the turntable, and use the Switch mode to connect to the Sonos network to pay the Bluetooth audio on the other Sonos speakers on my network (Beam, Move, and 2 x Symphonisk Lamp Speakers).

The system works exactly as expected, but at random intervals I experience audio dropouts on one or more of the Sonos speakers.  I have tested the system thoroughly using streaming media sources and do not experience any dropouts whatsoever.

The Roam is within 1m of the turntable, so I’m confident the Bluetooth is not disconnecting, and the Wifi network is excellent in this small apartment.  The problem only occurs when using the Roam to bring the Bluetooth audio source onto the Sonos network.

Has anyone else experienced this problem?


8 replies

Yeah my Roam will drop out every minute or two.. for a second or so. None of my other speakers have this problem (I have two Sonos ones and an Arc) both Roams I have do this. 

Try setting your Roam to use your routers 2.4Ghz band with a channel widths of 20MHz and set that band to use either fixed channel 1, 6 or 11 and if using SonosNet, set it’s channel 5 (or more) channels away from your chosen channel. See if that resolves your issue. 

Yeah my Roam will drop out every minute or two.. for a second or so. None of my other speakers have this problem (I have two Sonos ones and an Arc) both Roams I have do this. 

Hi Xander

Thanks kindly. I will find some time to do some more testing and send a diagnostic.

Mike

Userlevel 5
Badge +14

Hi @srcspl, as you mentioned that the Roam itself continues to play without issue, that would indicate that the Bluetooth end of the connection is working fine - we would expect to see the Roam also dropping out if the issue was with the Bluetooth connection.

When the Roam is sending the audio to the remaining speakers, however, that takes place over WiFi. This isn’t necessarily a sign of issues with the wireless network as a whole - the path taken across the system by music from streaming services (Internet > Router > Speakers) will differ from music sent to the Roam via Bluetooth (Bluetooth Source > Roam > Router > Speakers), so it’s certainly possible to have issues with one but not the other. 

There could of course be something else going on, however a diagnostic should help to clear things up a bit :)

Hi Xander

Thanks for your reply.

I would like to try to understand why you think the issue is on the WiFi side, considering the fact that I have experienced absolutely no issue whatsoever listening to online sources (Sonos Radio/Amazon Music/Audible/Spotify/Tidal/YouTube Music) on any devices, whether individually or grouped.  I only experience this issue when using the Roam as a Bluetooth input from my turntable to the Sonos network (I purchased the Roam specifically for this reason - prior to this I used a Move for audio from the turntable).

I’m happy to do the test and submit the diagnostic, but would like to try to understand the reasoning behind suspecting the WiFi.

Regards

Mike

Userlevel 5
Badge +14

Understood @srcspl, certainly sounds like the issue is on the WiFi side of things - while the wireless network in general may be strong, there are other things to be considered with Sonos. With the devices all being in close proximity, it sounds like you may be being affected by wireless interference - it may be better to create some distance between the devices.

Mind testing the system again, and then submitting a diagnostic shortly after if you continue to experience issues? If you take a note of the confirmation number, feel free to either paste it in a reply to this thread, or alternatively get in touch with our Support Team via live chat or phone call to take a closer look, and perform some live troubleshooting :)

Hi Xander

I rebooted the router and all devices on the network, and did some more testing.

Marley Stir-it-Up Turntable →  BT  → Roam

I connected the Marley turntable to the Roam via Bluetooth and played a full album with no issue.  Sound quality on the Roam was as expected.

 

Marley Stir-it-Up Turntable →  BT  → Roam  →  Sonos Network  →  Beam

I then grouped a Beam with the Roam and played the same album.  It wasn’t long before the sound on the Beam started dropping out for 1 or 2 seconds.  The sound on the Roam, however, didn’t drop.

 

All devices are connected to the wireless network, the wifi signal is very strong, all devices including the router are in close proximity.  I have not experienced any issue with the Sonos network or sound quality before the introduction of the roam (i.e: I can group all devices on the network and play from online sources without any issue whatsoever).  The problem only occurs when using the Roam as an input to the Sonos network.

Mike

 

Userlevel 5
Badge +14

Hi @srcspl, welcome to the Sonos Community!

You mentioned that you experience the audio dropouts on “one or more" Sonos speakers, does this mean that other speakers will continue to play when this happens?

If so, then I would recommend starting with a network refresh, by rebooting your router and each Sonos speaker, and then testing again to see if there’s any improvement.

Let us know how you get on :)

Reply