Audio delay on PS4/PS3

  • 20 October 2017
  • 22 replies
  • 14253 views

Hi,

My setup is this:

PS3/PS4 connected to TV via HDMI
TV connected to Playbar via Optical Out

Now, my issue is that whenever I play a shooter (BF4/Call of Duty) on either the PS3/PS4, the sound has a notable delay. I do not have this issue when viewing Netflix directly via the TV (LG OLED55C7V). Any solutions on how I can get rid of this delay?

Thanks in advance!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Badge
I read recently that LG is starting to release a new update for the 2016&2017 Oled model TV’s. I haven’t yet got the update, but am wondering if anyone else has, and if it has fixed the problem in question? Thanks!

I have an LG B7a and am still having this issue after a firmware update.
I read recently that LG is starting to release a new update for the 2016&2017 Oled model TV’s. I haven’t yet got the update, but am wondering if anyone else has, and if it has fixed the problem in question? Thanks!
Badge
Hey! Honestly I haven't really dug into this yet. It's not a super pressing issue, and I kinda hate to add more random remotes and potentially lose CEC. If/when I do try this setup, though, I'll come back here and share my experience.
Badge
I think the problem is a combination of PS4 + HDMI + going through a TV. Not sure why. I think the solution is to get an HDMI switch box, which would be set up accordingly:

1. PS4, Apple TV, other devices plugged into the switch box via HDMI
2. Switch box plugged into the TV via HDMI
3. Switch box plugged into the Playbase via optical out

Then you'd be using the switch box remote to switch between devices. These can be had for fairly cheap. I'm going to take a stab and see if it fixes the PS4 audio delay issue. I'll report back once I try this approach.


Did this work for you?
Badge
I think the problem is a combination of PS4 + HDMI + going through a TV. Not sure why. I think the solution is to get an HDMI switch box, which would be set up accordingly:

1. PS4, Apple TV, other devices plugged into the switch box via HDMI
2. Switch box plugged into the TV via HDMI
3. Switch box plugged into the Playbase via optical out

Then you'd be using the switch box remote to switch between devices. These can be had for fairly cheap. I'm going to take a stab and see if it fixes the PS4 audio delay issue. I'll report back once I try this approach.
Seeing as the guy above is having the same issue on a different tv worries me. Doesn’t seem to be an issue with a singular tv. I contacted LG about the issue again, and they informed me that this is still an ongoing issue that they are looking at fixing. No estimated time for when the new update will be available. Will give it a couple of more weeks before I contact them again. If anyone has any updates or fixes, please share. Will reply again if a fix is presented.
Badge
I finally figured out the issue. I had to set my Playstation to use the "optical" for audio out even though the HDMI is what is sending the audio. I guess it changes some delay. After I checked that, everything works fine.

I bet you're no longer getting your sound in surround at that point. To check, open the Sonos mobile app and go to Settings > About My Sonos System. Look at the "Audio In" and see if it says Dolby 5.1.

I'm having the same issue with my PS4, Playbase, and Vizio D50F-E1 TV. I've tried every setting possible on all three devices, nothing works. Yet my Apple TV has no trouble at all. This delay only happens when the PS4 is outputting Dolby 5.1 (stereo is fine).

Does anyone have any ideas on how to solve this? I even tried changing up my HDMI cable to HDMI 2.0, and that didn't work. Is there no solution other than buying extra hardware? And would it make more sense to buy an HDMI switch that I can plug all my devices into, run the HDMI out into my TV, and run the optical out into the Playbase? Or should I just get an optical/SPDIF switch, plug my TV & PS4 into that, then run the SPDIF out into the Playbase?
Badge
Has anyone gotten an update for this?
I hope that happens Richard! Been trying everything to fix the audio delay. Something not playing right between Lg, Sonos and PlayStation
Just to let everyone know. I called LG today, and explained my issue in full detail. They informed me that this is a known issue, and is a software glitch that they are currently working on fixing. The fix should come within 1-2 weeks. I asked if this is a issue with the PS4 (Dolby) settings, and they explained that this issue is with anything Dolby.
Userlevel 7
Badge +22
If there is. Onselay direct from PS4 but there is delay routing through tv it is obviously the tv with the issue.
Yeah, that is something that I will need to do soon. I have tried everything that I could possibly think of to fix the issue with no results. If I change my PS4 sound settings to linear pcm it works fine, but when I switch it to bitstream(Dolby) it has a delay. Is this possibly a PS4 issue? Or are you confident it is a tv issue? I have an lg oldec7p
Userlevel 7
Badge +22
Obviously your TV is adding a delay. You could get an HDMI switch with optical out to do the switching vs. TV.

Your saying would hope for fix soon - you would need to check with TV mfg. if a firmware update to address.
I finally finished my 5.1 surround sound set up today by getting the new sonos one. I am having the same issue unfortunately. However I have noticed when I connect the optical directly to the PS4 their is no delay and works perfectly fine. But in my situation I would like to have the optical hooked up to the TV will hdmi is connected to the PS4. This is an upsetting event due to me either having to choose no surround sound or hook the cable directly to the PS4. Hope this is fixed soon 😕
Userlevel 1
However, the latest update 8.2.2 seems to have broken my DD5.1 when using PlayStation. It comes out as stereo only no matter what I choose. I haven’t changed anything on my end. Any one else?
Userlevel 1
I finally figured out the issue. I had to set my Playstation to use the "optical" for audio out even though the HDMI is what is sending the audio. I guess it changes some delay. After I checked that, everything works fine.
Having same issue. Not the tv because works great with 5.1 and Netflix. Something happening between Sonos and ps4. I also have lgc7 any help would be appreciated!
Userlevel 1
This is happening to me as well now. In Stereo there is no delay. DD5.1 I have a substantial delay. Tv or Sonos delay does not help.
Userlevel 1
Badge
Did you ever get this resolved? I have the same issue.
Userlevel 7
Badge +21
I'd be amazed if the TV is actually "bypassing" the signal as you say. But why not try not bypassing and check the TV isn't adding it's own audio delay.
I've set the tv to bypass the audio signal, but the sound is still delayed.. currently bought a switch that should come in tomorrow, so I'm hoping that might fix it.
Userlevel 7
Badge +21
The Sonos app has an audio setting in the advanced audio for the Playbar room. Your TV will have an audio delay. Not sure about the PlayStation.

Investigate those