Asus ZenWiFi AX rotuer QoS feature doesn't work with Sonos

  • 27 January 2021
  • 34 replies
  • 11498 views

Userlevel 2

If you have one of those Asus routers which support Quality of Service (QoS) feature to prioritize different kind of traffic (Streaming, Work from Home, etc.), this may be helpful to you. When I enabled this feature I had lot of issues with connecting to various Sonos speakers, or playing music on them, or adding a new speaker to the system, etc. Once I disabled QoS feature in the router, everything worked seamlessly.

I have ASUS ZenWiFi AX6600 (XT8) router.

Naveed.Ahmad 1 year ago

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

I have firmware version ...41793 installed on both the router and satellites.  Disabling QOS resoled the issue for me. 

Fortunately, I can return my old Sonos Bridge to the recycle bin as I don’t have an ethernet port convenient to my speaker locations.

Userlevel 1
Badge

Factory reset seems to have resolved the issue for me. Thanks guys, it had been driving me insane!

This worked for me. ymmv.
Environment: 2 AX8 + AC68U (1 AX8 in router mode). QoS and AirTime Fairness not enabled, IGMP snooping enabled (default settings out of box).  Malicious Site blocking enabled.  IPS and IDP\Blocking not enabled. AX firmware(fw) at version 41793 and AC68U at 41634.  Everything was fine.  Upgrade to beta fw 41994 (due to dnsmasq vulnerabilities) and Sonos wouldnt stay connected for more than 5 sec.  Downgraded back to AX firmware(fw) at version 41793 and AC68U at 41634. Rebooted all 3 units even thought the instruction did not ask for all 3 units reboot after fw downgrade.  Asus fw downgrade by itself did not fix the issue.  Did not do factory reset. 

Resolution:

Power off all sonos and connect ethernet cable from router to 1 sonos.  Power on 1 speaker and configure speaker using Sonos app.  Change the connection from wireless to wired.  power cycle the Sonos.  Connect via app again with cable connected and change to wireless.  Leave cable connected and start a music stream.  While music is running, disconnect the ethernet cable.  Music would stop and should reconnect within 5-10 sec. If not, manually restart music stream.  Rinse and Repeat for other Sonos.  I do not have any Sonos devices hardwired to router.  Good luck. 

followup.  What stabilized the sonos setup was to bind the Sonos to one of the XT8 as i dont move the speakers.  No drops since.  Also upgraded the routers to the latest firmware 3.0.0.4.386.42095 w/o any drops.

If you have one of those Asus routers which support Quality of Service (QoS) feature to prioritize different kind of traffic (Streaming, Work from Home, etc.), this may be helpful to you. When I enabled this feature I had lot of issues with connecting to various Sonos speakers, or playing music on them, or adding a new speaker to the system, etc. Once I disabled QoS feature in the router, everything worked seamlessly.

I have ASUS ZenWiFi AX6600 (XT8) router.

THANK YOU!! I knew there was no good reason the Sonos were not working with our new XT8!! It was driving me bonkers that it worked sometimes but mostly didn’t! Problem solved IMMEDIATELY upon turning off QoS!!

Thanks @Whatswong, have anyone else (having had previous challenges w Asus XT8 firmware updates resulting in Sonos complications) now upgraded to the latest FW-release 3.0.0.4.386.42095 and seen the previous Sonos-problems being solved?

I have been trying to fix the Sonos issues with my ASUS ZenWiFi AX routers even since it broke after one of their firmware updates last year. The last stable firmware version that works is 3.0.0.4.386.25790. None of the other firmware versions work with Sonos where you can use the ASUS WiFi network to connect them all. I have 15x Sonos devices and 4x ASUS ZenWiFi routers and it seems I can only get Sonos working all together by using SonosNet. It seems to me that this is a firmware issue that’s just not fixed.

I finally have all of my Sonos units working with my ASUS ZenWiFi routers using the 2.4Ghz band. After upgrading to the latest firmware on my routers, I simply removed all of my AiMesh nodes and then added them back. It looks like there was a sync issue between the nodes which meant only certain Sonos devices would connect. This is now working flawlessly and I can stream music to all of my Sonos devices in party mode.

What worked for me with the problematic Asus mesh setups as even the latest 386_xxxx firmware for my models did not work.
 
I have 2 surround sonos setups that I had to bind to my mesh node. They did not like when I had them connecting though the main node. It is also worth mentioning that I have non-matching mesh setup (RT-AX92U for main router and RT-AX11000 for mesh node).
Firmware versions currently being run:
RT-AX92U: 3.0.0.4.386_43084-g728dd24
RT-AX11000: 3.0.0.4.386_43129-g60defb2
 
I tried everything, resetting to factory settings after a firmware update, removing and re-adding the mesh node, making sure all the recommended settings were disabled (QoS, Airtime Fairness, etc), rejoining the sonos units and nothing worked. There is something amiss with the Asus firmware for sure.