ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 84 replies
  • 18442 views

Userlevel 2
Badge

I’m posting this in hopes of saving someone else from the hours of frustration I’ve endured to resolve this issue.

From the time I set-up my Arc + Sub + Surrounds system in July with an Asus RT-AC88U router (connected to Fios Gigabit internet) it has worked without issue. I’ve used Asus Smart Connect with all settings at default. No problems with the S2 app and no problems when I upgraded to an iPhone 12, other than the loss of Trueplay support, which continues to be a problem. (HELLO Sonos! Anyone home?)

Then I recently upgraded to the RT-AX86U using same Smart Connect default settings and, initially, all seemed fine. But soon the dropped connections started. I’d reboot and the Sonos system would connect for 10-30 minutes, then lose wifi connection again. Meanwhile, all other wifi devices in my home worked just fine--the Sonos was the only problem child. 

I did all the troubleshooting I could, then called into Sonos support and spent almost 2 hours with a tech rep trying every potential solution possible, but nothing worked. (However: KUDOS to such extraordinary tech support!) He then escalated the issue to an appointment with the Senior Support Team. 

Meanwhile, I went into the router settings once again, looking for anything that might be an issue--even though I had gone through them all with the tech rep, and these were all the same settings that had worked on the AC88U. On a whim, and not expecting it to help, I turned off the QoS feature, which I have set to prioritize bandwidth for media streaming over other tasks. BINGO. That was it. Sonos system has stayed connected ever since. I can’t explain why that would be a problem--I’ve always had the QoS set that way, and with gigabit service, an AX router, a modest load of wifi clients in my apartment and no gaming, there should be bandwidth aplenty. But that was the issue and it’s finally solved. 


84 replies

Userlevel 1
Badge +1

Sick to death of these drop outs, wish I’d never bought into sonos.

I’ve followed suggestions, still have drop outs.

I’ve factory reset the router, still have problems.

I’ve submitted diagnostics - no help.

 

Is it definitely this router?  I have smartthings, hue, ring etc, everything works 100% apart from these fricking speakers.  Even the wired speakers drop out.

Hi

 

 Re the asus problem, there is new firmware available   6061    this has fixed the problem for me re sonos   also did a factory reset on my router  RT AX 82U

 

hope this helps

I’ve had the same problems on my RT-AX58U, every firmware upgrade did cause issues with my SONOS system. Because of that I have been running an older firmware version from september 2020 (version 3.0.0.4_384_9918).

I’ve tried most of the suggestions in this thread without any success...

Yesterday (2022 jan 4) my router forced me to get the latest firmware, even though I have the automatic update turned off… And of course the upgrade messed up my SONOS system. So I reverted back to my old version, and SONOS was up and running again.

But after a while the router upgraded to the newest version again, and again messed up my SONOS!

So I decided, after the upgrade to the newest firmware, to make a factory reset and setup the router from scratch. I did not reload any saved preferences.

That brought my SONOS system back again.

So far It has been working for 16 hours…

I’ll keep my fingers crossed.

Userlevel 1
Badge

Hey All,

 

Everyone that are still having issues, I called support yesterday and they have been super helpful. 

 

They helped me change something and I’m on the latest version of the firmware and have not had disconnections in the last 24 hrs. I have a RT-AX86U on 3.0.0.4.386_41535

 

 

Here is my 2.4GHz settings (I’ll try enable AX mode and Target Time to Wake later on as these were my own changes but I just need some stability right now!):

 

New house, new wifi.. I’m running two RT-AX92U.  Had serious connectivity issues with ALL of my Sonos products (they would show in the app, sometimes but could never stream to them). After reading through this whole thread I decided to fully update my routers and do a factory reset on them.  .. It worked, no other custom changes or drop downs.. just factory reset and its gold.  Hope this helps someone.

Note, I’m running - 3.0.0.4.386_43084-g728dd24

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

Issue with upgrade of Asus RT-AX86U firmware is still an issue.

Yesterday I did the router upgrade and immediately ran into severe problem with my Sonos equipment.

(I was not aware of that this upgrade was a problem for Sonos users)

Google assistant stopped working and so did TuneIn and Spotify.

Tried to put all devices in setup mode, to make a fresh installation.

But I only got intermitent acces to the Sonos equipment.

Tried also lots of changes in router, such as; QoS setting, Bandwith and channel number for 2.4GHz WiFi, turning of traffic collection etc..

Everything else connected to our home network worked without any problems.

Also all streaming services to other devices worked as expected.

Gave up and downgraded the firmware to recent version and all our Sonos equipment worked like a charm again.

 

 

I had the same problem, Sonos Arc, Sub Gen 3 and One worked fine, but would not recognize my Play 5:II, solved it by rolling back the firmware.

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

 

Not exactly correct.

Problems with Samba are often simply access errors, where once they worked.  Reported in the Sonos System Error Log, they show as:

  • “Unable to connect to: //<your samba path>”,
  • “//<your samba path> is no longer available. The device where the music files are stored may not be powered on, or the path may have changed.”
  • Unable to play '<your music file>.mp3' - unable to connect to //<your samba path>.

As Revrobbo noted, it is absolute and complete BS that someone at Sonos has not tried to replicate this problem and fixed it, given all the years of venting on this forum.

 

Userlevel 1

Try to factory reset the router after firmware update, it worked for my Asus RT-AX58U router. My Sonos Beam always disconnecting from wifi before and after firmware update until I did the factory reset thing.

Was a big fan of Sonos until this problem occurred. Asus routers are popular and highly recommended in in the consumer electronic products world. Asus routers should work with Sonos without any problem, well maybe a tweak to the router setting is OK. But that’s not the case here. So I will call Sonos tomorrow and see if they can fix this. 

a miracle.  did a ax3000’s firmware update
updated to 3.0.0.4.386_47029

connect amps working again. and other smart devices that were having connection issues.

like a switch

didn’t even do a factory reset…

 

 

 

Userlevel 2
Badge

Brufleth, I’m having good success staying connected and run my AX-86U with SmartConnect on, so I would rule out SmartConnect as the cause of the issue. I do think that setting the control channel on 2.4GHz band, as opposed to auto, might be important, but hard to know for certain. What we do know is that the 2.4GHz band can be especially problematic in terms of interference, and that the three channels which don’t overlap other channels are 1, 6 and 11. I picked 6, but all three would be worth trying. 

Fyi, I used to have QoS turned on, with media streaming as a priority, but I now keep it off. Whether that’s important is hard to know, I’m just keeping the settings that have given me the best results for keeping Sonos connected. 

Userlevel 7
Badge +22

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

Had lot of problem witth this, did clear my data and cash for Google home and sonos, then opened Google home and linked sonons again. This finally sovled my problem! 

 

Prior to this I had changed this settings. After clearing the data an cash this solved my problem.

 

Inställningar för ASUS:

På vänster sida klicka på Wireless

General/ Band 2.4GHz:

-Trådlöst läge -> Legacy
-Kanal bandbredd -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Tryck verkställ

Wireless / Wireless MAC Filter
-Enable MAC Filter-No 

Wireless/ Professional:

-Roaming assistant  --> Inaktivera
-Enable IGMP Snooping --> Aktivera
-Airtime Fairness  --> Inaktivera  på 2.4GHz och 5GHz
-Universal Beamforming/ Universal strålformning --> Inaktivera på 2.4GHz och 5GHz
Tryck verkställ

På vänster sida klicka på LAN och efter IPTV
-->Enable Multicast routing (IGMP Proxy) - Aktivera
-->Efficient Multicast Forwarding (IGMP Snooping)- Aktivera
Tryck verkställ

Starta om alla högtalare efter att dessa inställningar har gjorts/kollats för bästa resultat.

 

Mod Edit: Added English translation-

ASUS settings:

On the left side click on Wireless

General / Band 2.4GHz:

-Wireless Mode -> Legacy
-Channel bandwidth -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Press apply

Wireless / Wireless MAC Filter
-Enable MAC Filter-No

Wireless / Professional:

-Roaming assistant -> Disable
-Enable IGMP Snooping -> Enable
-Airtime Fairness -> Disable at 2.4GHz and 5GHz
-Universal Beamforming / Universal Beamforming -> Disable at 2.4GHz and 5GHz
Press apply

On the left side click on LAN and after IPTV
-> Enable Multicast routing (IGMP Proxy) - Enable
-> Efficient Multicast Forwarding (IGMP Snooping) - Enable
Press apply

Restart all speakers after these settings have been made / checked for best results.

@BrightBoyIT,

If you’re actually seeing your own Sonos devices disconnecting from your network, then you are perhaps better off posting the issue in an entirely separate thread to this one, which is mostly based around multicasting issues/settings involving the ASUS RT-AX86U. Most here seemed to have resolved there issue.

By posting your issue separately with diagnostic reports, the Staff here maybe able to take a closer look at your own particular setup and perhaps help you to resolve the matter. 

Hope that assists and hope that you manage to resolve your connection issues.

Same story, everything was great, upgraded to AX86u router, and now the Sonos system is unusable. 
 

I’ve got QoS turned off, and Airtime Fairness is Disabled on both bands, but no success. 
 

Will try calling tech support when I have a few hours to burn. 

Userlevel 2

+1. With QoS enabled, I couldn’t add a new speaker to the system, couldn’t play music on speakers, speakers keep dropping, etc. Spent lot of hours troubleshooting. My system started working seamlessly when I disabled the QoS feature.

I use Asus ZenWiFi AX6600 (XT8) router

i have disabled airtime fairness (it was by default) and disabled QoS. 

 

still no success. plugging it in did not work either and was a massive pain in my ass since i can’t get it off the stand and had to hold it up above my head to get it to power. 

 

ANY advice?

If turn off Qos does not work, try down grade firmware back to 3.0.0.4_384_9318, it works for me after 2weeks of try to fix Sonos one and Playbar because my Sonos one SL is working so the problem must be the speaker. My router is Rt-AX 86U. 

Userlevel 1
Badge

Hey @Evielwine, the only way I managed to get things working again is back to the old firmware ( Version 3.0.0.4.384.9318 ). No issues every since. Unfortunately the changes I made above only lasted a few days before things disappear again.

 

Here is the link to the Bios.

https://www.asus.com/au/Networking-IoT-Servers/WiFi-6/All-series/RT-AX86U/HelpDesk_BIOS/

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

I'm willing to try the merlin build, but I'm not holding my breath. I'll make sure I can still get the old firmware, or still have it saved, before I give it a go.

Other than the sonos issue, I can't complain about the asus firmware.  Since the sonos speakers are used all the time, that's a pretty big issue. Since we're mostly wfh, having a good reliable home network is super critical though. Maybe merlin can deliver.

...I decided to fully update my routers and do a factory reset on them.  .. It worked, no other custom changes or drop downs.. just factory reset and its gold.  Hope this helps someone.

Note, I’m running - 3.0.0.4.386_43084-g728dd24

 This is working for me, too. RT-AX86U router

installed latest firmware 3.0.0.4.386_45375

then a hard factory reset

Sonos working fine

Userlevel 2
Badge

A few things I’ll note about my AX-86U settings--not sure any of this is relevant to the performance I’m getting, but fyI--and if you want to know about any other settings, please let me know and I’ll post.

I use SmartConnect so 2.4 and 5GHz bands appear as one network name and the Asus directs traffic to the “best” band in real time. Or so they say, lol. 

Guest networking is off--not because of Sonos, I just don’t need one. 

2.4GHz control channel is set to 6. I’ve had problems with Sonos connections when control channel is set to Auto. Of course, hard to say definitively if the Auto setting IS what causes the dropped connection issues, but it “seems” to contribute to them. Since I’m having good results with 6, I’m sticking with it. 5GHz is set to auto, but not a factor since Sonos in 2.4GHz only. 

I am not in a wifi friendly environment--I live in a 250 until apartment bldg in NYC, so plenty of wifi usage around me… but this was never an issue with my AC-88U. 

Reply