ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 84 replies
  • 17579 views

Userlevel 2
Badge

I’m posting this in hopes of saving someone else from the hours of frustration I’ve endured to resolve this issue.

From the time I set-up my Arc + Sub + Surrounds system in July with an Asus RT-AC88U router (connected to Fios Gigabit internet) it has worked without issue. I’ve used Asus Smart Connect with all settings at default. No problems with the S2 app and no problems when I upgraded to an iPhone 12, other than the loss of Trueplay support, which continues to be a problem. (HELLO Sonos! Anyone home?)

Then I recently upgraded to the RT-AX86U using same Smart Connect default settings and, initially, all seemed fine. But soon the dropped connections started. I’d reboot and the Sonos system would connect for 10-30 minutes, then lose wifi connection again. Meanwhile, all other wifi devices in my home worked just fine--the Sonos was the only problem child. 

I did all the troubleshooting I could, then called into Sonos support and spent almost 2 hours with a tech rep trying every potential solution possible, but nothing worked. (However: KUDOS to such extraordinary tech support!) He then escalated the issue to an appointment with the Senior Support Team. 

Meanwhile, I went into the router settings once again, looking for anything that might be an issue--even though I had gone through them all with the tech rep, and these were all the same settings that had worked on the AC88U. On a whim, and not expecting it to help, I turned off the QoS feature, which I have set to prioritize bandwidth for media streaming over other tasks. BINGO. That was it. Sonos system has stayed connected ever since. I can’t explain why that would be a problem--I’ve always had the QoS set that way, and with gigabit service, an AX router, a modest load of wifi clients in my apartment and no gaming, there should be bandwidth aplenty. But that was the issue and it’s finally solved. 


84 replies

Hi

 

 Re the asus problem, there is new firmware available   6061    this has fixed the problem for me re sonos   also did a factory reset on my router  RT AX 82U

 

hope this helps

a miracle.  did a ax3000’s firmware update
updated to 3.0.0.4.386_47029

connect amps working again. and other smart devices that were having connection issues.

like a switch

didn’t even do a factory reset…

 

 

 

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

Userlevel 7
Badge +22

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

After so much time, I have finally made it work. After all the tips here in the thread and nothing has really works to 100% for me.
I downloaded a free version of Wifi Analyzer on my old Android phone and scanned through my apartment and channel 6 (2.4GHz) was the least crowded so I tuned in to it.

It has been working almost flawless since, only some split second drop out and its nothing that bothers me and rarely happens. 

Airplay 2, Spotify connect and Sonos all works.

 

 

 

IPTV multicast routing is enabled.

Asus AX68U Merlin 386.5 (have not try 386.5_2) Factory reset and no restore from backup.

We had this same problem. We rolled our firmware back to:

3.0.0.4.386_47029

2022/01/05

I'm getting extremely sick of this. It's been ongoing for years now, and it's always blamed on Asus. I have exactly no issues with any other of the 20 other devices connected to my Asus network except bloody Sonos. I'm almost at the point of throwing it all out despite the sunk costs. This needs to be fixed, enough is enough. Go and buy some Asus routers and trial them in house Sonos r&d and fix the damn problem. 

 

It is unlikely any of the ”20 other devices” on your network need to communicate with each other, and that is the feature that Asus seem unable to make work reliably (per this thread and others). And that is also a critical requirement for Sonos devices. Please, just get another router.

 

Not exactly correct.

Problems with Samba are often simply access errors, where once they worked.  Reported in the Sonos System Error Log, they show as:

  • “Unable to connect to: //<your samba path>”,
  • “//<your samba path> is no longer available. The device where the music files are stored may not be powered on, or the path may have changed.”
  • Unable to play '<your music file>.mp3' - unable to connect to //<your samba path>.

As Revrobbo noted, it is absolute and complete BS that someone at Sonos has not tried to replicate this problem and fixed it, given all the years of venting on this forum.

 

Are there any iOS users here? I tried two days connect Sonos to my new Asus rt-ax86u with Android, no success. Tried my wife's IPhone for Sonos network update and success right away! All speakers found immediately.

Router is with newest firmware and airtime fairness off, QoS off.

Userlevel 7
Badge +22

Are there any iOS users here? I tried two days connect Sonos to my new Asus rt-ax86u with Android, no success. Tried my wife's IPhone for Sonos network update and success right away! All speakers found immediately.

Router is with newest firmware and airtime fairness off, QoS off.

Your phone is probably connecting on 2.4GHz and your wife’s on 5GHz (or vice versa). These routers are infamous for messing up broadcasts between radio frequencies. Please, choose a different router.

Reply