ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 85 replies
  • 19210 views

Userlevel 2
Badge

I’m posting this in hopes of saving someone else from the hours of frustration I’ve endured to resolve this issue.

From the time I set-up my Arc + Sub + Surrounds system in July with an Asus RT-AC88U router (connected to Fios Gigabit internet) it has worked without issue. I’ve used Asus Smart Connect with all settings at default. No problems with the S2 app and no problems when I upgraded to an iPhone 12, other than the loss of Trueplay support, which continues to be a problem. (HELLO Sonos! Anyone home?)

Then I recently upgraded to the RT-AX86U using same Smart Connect default settings and, initially, all seemed fine. But soon the dropped connections started. I’d reboot and the Sonos system would connect for 10-30 minutes, then lose wifi connection again. Meanwhile, all other wifi devices in my home worked just fine--the Sonos was the only problem child. 

I did all the troubleshooting I could, then called into Sonos support and spent almost 2 hours with a tech rep trying every potential solution possible, but nothing worked. (However: KUDOS to such extraordinary tech support!) He then escalated the issue to an appointment with the Senior Support Team. 

Meanwhile, I went into the router settings once again, looking for anything that might be an issue--even though I had gone through them all with the tech rep, and these were all the same settings that had worked on the AC88U. On a whim, and not expecting it to help, I turned off the QoS feature, which I have set to prioritize bandwidth for media streaming over other tasks. BINGO. That was it. Sonos system has stayed connected ever since. I can’t explain why that would be a problem--I’ve always had the QoS set that way, and with gigabit service, an AX router, a modest load of wifi clients in my apartment and no gaming, there should be bandwidth aplenty. But that was the issue and it’s finally solved. 


85 replies

Userlevel 1
Badge +1

Sick to death of these drop outs, wish I’d never bought into sonos.

I’ve followed suggestions, still have drop outs.

I’ve factory reset the router, still have problems.

I’ve submitted diagnostics - no help.

 

Is it definitely this router?  I have smartthings, hue, ring etc, everything works 100% apart from these fricking speakers.  Even the wired speakers drop out.

Userlevel 7
Badge +18

Hi @simondo 

I’m afraid just submitting diagnostics does nothing to prompt anyone to help you - we’re not notified. They’re to be used in an on-going troubleshooting session.

I’ve had a look now however. I can’t see any wired speakers reporting audio dropouts, but I can see that the large group involving Living Room is struggling, which appears to be due to multicast flooding (or looping) on your network. I recommend checking your router’s settings for an option called IGMP Snooping (or Filtering) and turning it on.

 

 

Userlevel 1
Badge +1

Thanks for your response, unfortunately it is already turned on.

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

It’s often because SSDP Multicasting isn’t quite working correctly on the local network… this (hopefully) explains the issue for you in simple terms:

http://www.steves-internet-guide.com/introduction-multicasting/

I agree, but only to a point.  4 years ago, the industry started patching against WiFi authentication vulnerabilities like KRACKS, and started enforcing more than a short list of security keys being used to cycle encryption.  Since then, Sonos has been fraught with issues on WiFi drop-offs on Gen 5 and Gen 6, as the devices themselves are completely losing their connections to the network.  You can see this in the log files of the router, as it shows the disconnects occur in real time.  It has to do with the 4way handshake, and the way the device handles them.  If it was just a multicast issue, we wouldn’t be seeing the devices completely disconnect.

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

It’s often because SSDP Multicasting isn’t working correctly on the local network… this (hopefully) explains the issue for you in simple terms:

http://www.steves-internet-guide.com/introduction-multicasting/

 

This exact same thing happened when WiFi Gen 5 (AC) released, and we’re seeing the latest iteration of that occurring now.  Sonos forums are absolutely packed with threads based on it.

I maintain my original statement.  If all the other manufacturers have gotten this figured out, then Sonos needs to get their proverbial butts in gear to address it as well.

@BrightBoyIT,

If you’re actually seeing your own Sonos devices disconnecting from your network, then you are perhaps better off posting the issue in an entirely separate thread to this one, which is mostly based around multicasting issues/settings involving the ASUS RT-AX86U. Most here seemed to have resolved there issue.

By posting your issue separately with diagnostic reports, the Staff here maybe able to take a closer look at your own particular setup and perhaps help you to resolve the matter. 

Hope that assists and hope that you manage to resolve your connection issues.

Hey All,

 

Everyone that are still having issues, I called support yesterday and they have been super helpful. 

 

They helped me change something and I’m on the latest version of the firmware and have not had disconnections in the last 24 hrs. I have a RT-AX86U on 3.0.0.4.386_41535

 

 

Here is my 2.4GHz settings (I’ll try enable AX mode and Target Time to Wake later on as these were my own changes but I just need some stability right now!):

 

I don’t the changes I did mean, but I followed this and it worked with the latest firmware.

Could be coincidence, though. I got them all to connect earlier without these changes, but then I moved my wifi and reconnected it differently. I then lost my Sonos one speaker, but maintained two of my Play 1s and Sonos Arc Surround (Arc+2 Play 1s+Subwoofer).

Tried resetting the Sonos One, plugging it through Ethernet and then disconnecting, rebooted everything a million times. 

This seemed to work. Thanks!

Hi,

For those who are having issues, just to share that my current router firmware version 3.0.0.4.386_42840 seems to work fine now, I don’t have connectivity issues and my Sonos is working well.

I used to have issues about 4 months ago and recently noticed the change.

Do give it a try and see if it help.

Badge

Has anyone tried the newest version (3.0.0.4.386.44130) yet?

Would be great to be able to confirm if it’s working reliably for Sonos since it seems like the RT-AX86U is very finicky w/ Sonos with certain firmware versions. Currently still all the way back on 3.0.0.4.384_9318 since I know it’s reliable.

New house, new wifi.. I’m running two RT-AX92U.  Had serious connectivity issues with ALL of my Sonos products (they would show in the app, sometimes but could never stream to them). After reading through this whole thread I decided to fully update my routers and do a factory reset on them.  .. It worked, no other custom changes or drop downs.. just factory reset and its gold.  Hope this helps someone.

Note, I’m running - 3.0.0.4.386_43084-g728dd24

This issue just cropped up for me! I have a Sonos beam, sub, and Pay 1 speakers downstairs, and a sub and two Play 1 speakers upstairs. Well the the system no longer recognizes any of the Sonos speakers upstairs. Downstairs speakers are fine. 

Have had an ASUS RT-AX86U router for several months with no problem. Using this firmware:

Firmware version 3.0.0.4.386_45375

Can anyone help? Thanks! 

 

 

I think Asus AX router has compatibility issues with Sonos and Airplay 2.
Before I had a Asus AC68U with no issue, rock solid.

Two months ago I bought a Asus AX68U and it has been a headache to get it to work with Sonos (Ikea Symfonisk) and Airplay 2 speakers.
I have made all the recommended settings on the router I could find on the net. It is more stable but still loses connection from day to day.

 

Using latest Merlin 386.3_2, factory reset.

Was a big fan of Sonos until this problem occurred. Asus routers are popular and highly recommended in in the consumer electronic products world. Asus routers should work with Sonos without any problem, well maybe a tweak to the router setting is OK. But that’s not the case here. So I will call Sonos tomorrow and see if they can fix this. 

And why should Asus routers handle the LAN any differently than any other brand router out there? Why are we seeing this issue only with Asus, and not any other company’s routers?

Userlevel 7
Badge +22

 

Was a big fan of Sonos until this problem occurred. Asus routers are popular and highly recommended in in the consumer electronic products world. Asus routers should work with Sonos without any problem, well maybe a tweak to the router setting is OK. But that’s not the case here. So I will call Sonos tomorrow and see if they can fix this. 

This is 100% an ASUS problem to fix. Sonos require a functional local network, and the newer firmware on these routers do not provide that. I don’t think you’ll find many Sonos users recommending their routers these days.

This issue just cropped up for me! I have a Sonos beam, sub, and Pay 1 speakers downstairs, and a sub and two Play 1 speakers upstairs. Well the the system no longer recognizes any of the Sonos speakers upstairs. Downstairs speakers are fine. 

Have had an ASUS RT-AX86U router for several months with no problem. Using this firmware:

Firmware version 3.0.0.4.386_45375

Can anyone help? Thanks! 

 

I’m on the same Firmware version 3.0.0.4.386_45375 using RT-AX82U and no longer able to setup my Sonos wirelessly. I have tried a couple of Asus settings mentioned here in the forum but still getting issues (as per screen shot), only way setup works for me is via ethernet cable but once ethernet cable is unplugged, it’ll drop out from the network again. Most likely, will have to rollback to older firmware.

Any luck on yours?

 

 

I had the same problem, Sonos Arc, Sub Gen 3 and One worked fine, but would not recognize my Play 5:II, solved it by rolling back the firmware.

...I decided to fully update my routers and do a factory reset on them.  .. It worked, no other custom changes or drop downs.. just factory reset and its gold.  Hope this helps someone.

Note, I’m running - 3.0.0.4.386_43084-g728dd24

 This is working for me, too. RT-AX86U router

installed latest firmware 3.0.0.4.386_45375

then a hard factory reset

Sonos working fine

Started having the issues after the latest firmware update on RT-AX82U. No system nor speakers detected and connecting directly via Ethernet didn’t help. Rolled back firmware to earlier release (July 2021) and system weren’t grayed out anymore and was able to add speakers via Ethernet but only for a minute. Now dropouts and not able to detect speakers is none stop. 

I called the tech support and after few try’s and two hours  of testing, they suggested I purchase the Boost to resolve these issues. Anyone has experience with using the Boost with latest firmware to resolve theses issues?

This issue just cropped up for me! I have a Sonos beam, sub, and Pay 1 speakers downstairs, and a sub and two Play 1 speakers upstairs. Well the the system no longer recognizes any of the Sonos speakers upstairs. Downstairs speakers are fine. 

Have had an ASUS RT-AX86U router for several months with no problem. Using this firmware:

Firmware version 3.0.0.4.386_45375

Can anyone help? Thanks! 

 

I’m on the same Firmware version 3.0.0.4.386_45375 using RT-AX82U and no longer able to setup my Sonos wirelessly. I have tried a couple of Asus settings mentioned here in the forum but still getting issues (as per screen shot), only way setup works for me is via ethernet cable but once ethernet cable is unplugged, it’ll drop out from the network again. Most likely, will have to rollback to older firmware.

Any luck on yours?

 

 

 

I have recently updated to Asus, and wasnt sure if this was a Sonos thing or a Asus thing.  I have tried all the settings mentioned, but seem to be having issues with (and only with) my Play:1 devices, which I have 3 of.  My Roam, Beam, Arc’s and Play One devices are showing.  

 

As you mentioned in this post, if I connect via ethernet, they appear.  If I do a factory reset on the Play:1, it does pick this up in the app wirelessly, but it takes forever at the stage of adding it to the network.  Once added, it says to reboot the device, but doing that still doesnt bring it into the app.

 

If I check connected devices on the router, the Play:1 device does show as online, but the sonos app doesnt seem to have a clue that it exists.

 

I have tried pretty much everything, but the 3x Play:1 devices I own, are all missing when wireless.  They arent anywhere near wired points, and the reason I have sonos is to remove the need for cables being everywhere.

 

Has anyone got any further with this, as lost my surround sound now, as I use 2 of these as LS and RS with the Arc.  If I connect them with Ethernet, I can re-add them, but as soon as the ethernet is unplugged, it says it cant see the device.

 

I have AsusWIFI AX Firmware 3.0.0.4.386_45934 and have tried all the suggestions above.  Thanks in advance.

This week my Beam would not connect to my Asus RT-AX88U router.

I have previously tried the enable then disable Airtime Fairness trick on both 2,4 GHz and 5 GHz, but my Beam would still not connect to my router.

What did help was changing the following option under Wirless → Professional, under 2,4 GHz radio. My Modulation Scheme was set to “Up to MCS 11 (NitroQAM/1024-QAM)”, I selected instead “Up to MCS 9 (TurboQAM/256-QAM)”.

Power cycled all my Sonos gear (Beam, Sub and 2 x One), and they connected back to the router and rejoined my surround setup.

Userlevel 7
Badge +22

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

Since you’re recommending -- how are Sonos systems with Mikrotik routers?

And FWIW, many people have already made what could be considered significant investments ($$) in their Asus routers, and changing up is impractical.  Asus-Merlin is still a thriving community, so it would be behoove many to stay on that platform.

I’ve had the same problems on my RT-AX58U, every firmware upgrade did cause issues with my SONOS system. Because of that I have been running an older firmware version from september 2020 (version 3.0.0.4_384_9918).

I’ve tried most of the suggestions in this thread without any success...

Yesterday (2022 jan 4) my router forced me to get the latest firmware, even though I have the automatic update turned off… And of course the upgrade messed up my SONOS system. So I reverted back to my old version, and SONOS was up and running again.

But after a while the router upgraded to the newest version again, and again messed up my SONOS!

So I decided, after the upgrade to the newest firmware, to make a factory reset and setup the router from scratch. I did not reload any saved preferences.

That brought my SONOS system back again.

So far It has been working for 16 hours…

I’ll keep my fingers crossed.

Reply