ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 85 replies
  • 19197 views


Show first post

85 replies

Badge

Besides, disabing the Guest Networks and turning off 802.11ax/ Wi-Fi 6 modes for both 2.4Ghz and 5Ghz, I also have the following:

SmartConnect disabled

QOS disabled

Airtime Fairness disabled

Universal Beamforming enabled - some people have said to disable this, but I’m not sure.  Disabling didn’t seem to do anything.

Control Channel set to Auto

With these settings, my Sonos devices stay connected.  Do any of you have the Guest networks enabled?  I will try this weekend to enable the Guest Networks and Wi-Fi 6 and set the channel to 6 and see if it works.

Userlevel 5
Badge +16

Hi everyone. Thank you for your patience in this. It will be helpful to submit a diagnostic report on the Sonos app after a few minutes when the issue happens and reach out to Sonos Support, as we can take a closer look and discuss it with all of you individually in real-time. 

I suggest contacting our phone team, for they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.

 

If you have any other questions or concerns, feel free to reach out.

Userlevel 2
Badge

I can confirm that I have had almost constant connection to Sonos for over 2 months now with the following enabled:

SmartConnect

WiFi 6

So I would cross these off the list of settings that might be causing problems. 

Userlevel 1
Badge

I never thought this would solve it for me, but it did, once I disabled QOS, straight away both disconnection issues stopped (i finally managed to register my Sonos Beam) and google assistant worked again! Hopefully It’ll stay this way.

Hi, 

 

I have upgraded my router to RT-AX86U too and was having a lot of problems. 

  1. Sonos disappeared / cannot be found randomly
  2. Lost control on music playback, unable to pause/skip, then it lead to point 1
  3. Reboot usually bring back online but same problem repeat 

My setup: Asus RT-AX86U as main router, 2 x AIMesh nodes using RT-AX92U.

After trying everything listed here - QoS turned off, and Airtime Fairness is Disabled, it seems to bring back the streaming playback capability. However, when I performed TruePlay tuning, it kept having errors stating Speaker problem”.

Anyone of you having same problem? 

Seems like Asus RT-AX86U with AIMesh doesn’t really work well with Sonos.

Hey @Evielwine, the only way I managed to get things working again is back to the old firmware ( Version 3.0.0.4.384.9318 ). No issues every since. Unfortunately the changes I made above only lasted a few days before things disappear again.

 

Here is the link to the Bios.

https://www.asus.com/au/Networking-IoT-Servers/WiFi-6/All-series/RT-AX86U/HelpDesk_BIOS/

Thank you @altyz, I purchased this router mainly because of the AIMesh function, I really don’t feel like downgrading firmware where all other things are working well except Sonos… I guess as interim every time when I want to use Sonos, I just have to reboot first… :(

Userlevel 7
Badge +22

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

I had been trying to solve this issue for a few weeks, applied most of the suggested setting changes suggested with mixed success. The factory reset was the solution

 I have had 2 weeks of no drop outs on Sonos 1,3 and 5. 

The QoS was disabled by the factory reset, leave it that way

My other settings of note on the 2.4 GHZ Wireless: 

wiFi 6 mode enabled

Bandwidth 40MHz

Channel 1 (sonos ch 6)

 

 

 

Badge

I have the AX86U, using the latest firmware 3.0.0.4.386.42095. For me to get things to work with my Sonos speakers, I have to turn off the guest network and the 802.11ax / Wi-Fi 6 mode for both 2.4 and 5 ghz.  I’ve been working with Asus since the 3.0.0.4.386.41535 version broke Sonos to try and get this fixed.  They can’t seem to figure it out.

Userlevel 2
Badge

darkelf, I’m not sure that what works for the Arc will necessarily work for the Beam, but Merlin is easy to install. Here’s what I do on a Mac, which may/may not be the same if you have a PC. First, download the latest release firmware here, which is version 386.2.0 : https://sourceforge.net/projects/asuswrt-merlin/files/RT-AX86U/Release/  You’ll end up with a folder that contains four files. 

Next, login to your Asus router. At the top center of the Network Map screen you see first upon login, click on the firmware version number you currently have. That takes you to the firmware upgrade page. About mid-page, you’ll see Manual firmware update, and click on “Upload” next to it. That will allow you to navigate to the folder you downloaded. Click on it to open to the four files. Then click on the file that begins with the router model in the file name, then click on Choose for Upload. That’s it. Then wait until the upload is finished and you’re good to go. 

 

Reply