ASUS RT-AX86U & SONOS CONNECTION ISSUE SOLVED!

  • 12 December 2020
  • 85 replies
  • 19211 views


Show first post

85 replies

Badge

Has anyone tried the newest version (3.0.0.4.386.44130) yet?

Would be great to be able to confirm if it’s working reliably for Sonos since it seems like the RT-AX86U is very finicky w/ Sonos with certain firmware versions. Currently still all the way back on 3.0.0.4.384_9318 since I know it’s reliable.

Hi,

For those who are having issues, just to share that my current router firmware version 3.0.0.4.386_42840 seems to work fine now, I don’t have connectivity issues and my Sonos is working well.

I used to have issues about 4 months ago and recently noticed the change.

Do give it a try and see if it help.

Hey All,

 

Everyone that are still having issues, I called support yesterday and they have been super helpful. 

 

They helped me change something and I’m on the latest version of the firmware and have not had disconnections in the last 24 hrs. I have a RT-AX86U on 3.0.0.4.386_41535

 

 

Here is my 2.4GHz settings (I’ll try enable AX mode and Target Time to Wake later on as these were my own changes but I just need some stability right now!):

 

I don’t the changes I did mean, but I followed this and it worked with the latest firmware.

Could be coincidence, though. I got them all to connect earlier without these changes, but then I moved my wifi and reconnected it differently. I then lost my Sonos one speaker, but maintained two of my Play 1s and Sonos Arc Surround (Arc+2 Play 1s+Subwoofer).

Tried resetting the Sonos One, plugging it through Ethernet and then disconnecting, rebooted everything a million times. 

This seemed to work. Thanks!

@BrightBoyIT,

If you’re actually seeing your own Sonos devices disconnecting from your network, then you are perhaps better off posting the issue in an entirely separate thread to this one, which is mostly based around multicasting issues/settings involving the ASUS RT-AX86U. Most here seemed to have resolved there issue.

By posting your issue separately with diagnostic reports, the Staff here maybe able to take a closer look at your own particular setup and perhaps help you to resolve the matter. 

Hope that assists and hope that you manage to resolve your connection issues.

I agree, but only to a point.  4 years ago, the industry started patching against WiFi authentication vulnerabilities like KRACKS, and started enforcing more than a short list of security keys being used to cycle encryption.  Since then, Sonos has been fraught with issues on WiFi drop-offs on Gen 5 and Gen 6, as the devices themselves are completely losing their connections to the network.  You can see this in the log files of the router, as it shows the disconnects occur in real time.  It has to do with the 4way handshake, and the way the device handles them.  If it was just a multicast issue, we wouldn’t be seeing the devices completely disconnect.

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

It’s often because SSDP Multicasting isn’t working correctly on the local network… this (hopefully) explains the issue for you in simple terms:

http://www.steves-internet-guide.com/introduction-multicasting/

 

This exact same thing happened when WiFi Gen 5 (AC) released, and we’re seeing the latest iteration of that occurring now.  Sonos forums are absolutely packed with threads based on it.

I maintain my original statement.  If all the other manufacturers have gotten this figured out, then Sonos needs to get their proverbial butts in gear to address it as well.

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

It’s often because SSDP Multicasting isn’t quite working correctly on the local network… this (hopefully) explains the issue for you in simple terms:

http://www.steves-internet-guide.com/introduction-multicasting/

When everything else connects just fine, the one defining detail here is the Sonos firmware.  If every set of speakers, including One, One SL, Move, etc. all fail, but every other smart speaker from JBL, Google, Amazon, Yamaha, etc. all connect without issue?  What’s left?  You guys.

Sonos, you have got to get your firmware up to date (and kept up to date with the latest fixes for wifi vulnerabilities and security standards.  I’ve moved most of my clients away from your products already due to the lack of support that Sonos gives to modern wifi security and industry standards.  

These same issues occur on most WiFi Gen 6/6e routers, not just Asus.  You tell people to upload their diagnostics data then tell them (much) later that you don’t even read them.  It’s smoking mirrors, and it’s gotten old.  If you want business and consumer customers, you’re going to have to figure this out.  Because even the cheap Chinese knockoffs on AliExpress are killing you in this very detail.

Just my 2 cents, prove me wrong.

Userlevel 1
Badge +1

Thanks for your response, unfortunately it is already turned on.

Userlevel 7
Badge +18

Hi @simondo 

I’m afraid just submitting diagnostics does nothing to prompt anyone to help you - we’re not notified. They’re to be used in an on-going troubleshooting session.

I’ve had a look now however. I can’t see any wired speakers reporting audio dropouts, but I can see that the large group involving Living Room is struggling, which appears to be due to multicast flooding (or looping) on your network. I recommend checking your router’s settings for an option called IGMP Snooping (or Filtering) and turning it on.

 

 

Userlevel 1
Badge +1

Sick to death of these drop outs, wish I’d never bought into sonos.

I’ve followed suggestions, still have drop outs.

I’ve factory reset the router, still have problems.

I’ve submitted diagnostics - no help.

 

Is it definitely this router?  I have smartthings, hue, ring etc, everything works 100% apart from these fricking speakers.  Even the wired speakers drop out.

I had been trying to solve this issue for a few weeks, applied most of the suggested setting changes suggested with mixed success. The factory reset was the solution

 I have had 2 weeks of no drop outs on Sonos 1,3 and 5. 

The QoS was disabled by the factory reset, leave it that way

My other settings of note on the 2.4 GHZ Wireless: 

wiFi 6 mode enabled

Bandwidth 40MHz

Channel 1 (sonos ch 6)

 

 

 

Can you confirm router and firmware version please? Thanks

I had been trying to solve this issue for a few weeks, applied most of the suggested setting changes suggested with mixed success. The factory reset was the solution

 I have had 2 weeks of no drop outs on Sonos 1,3 and 5. 

The QoS was disabled by the factory reset, leave it that way

My other settings of note on the 2.4 GHZ Wireless: 

wiFi 6 mode enabled

Bandwidth 40MHz

Channel 1 (sonos ch 6)

 

 

 

No update yet on my RT-AX82U, last one was Feb and still has the issue! Downgrading to November update fixes the issue.

Userlevel 7
Badge +18

It does seem that a factory reset is required on some Asus routers after a firmware update is installed.

Thanks, everyone, for sharing!

hi all, thank you all who contributed constructively here. I too have a Asus router AX88U and had dropped connections with my beam + sub + 2 SL Ones. it happens whenever i turn on my guest network. Even after i deactivate the guest network, the sonos will go missing. Never understood why. I tried all the solutions suggested here excluding rolling back the firmware. Nothing has really worked. But i tried to update my firmware to 

Version 3.0.0.4.386.42819

2021/04/29 

after the firmware update, i did a factory restore of my router.

I also deleted all my sonos speakers and re add them. 

So far so good. I have not tried turning on the guest network as i am tired of all these troubleshooting and my family have been complaining that i keep bringing down the internet/speakers to troubleshoot. haha. FINGERS crossed!

Userlevel 2
Badge

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

 

 

After doing a factory reset on the latest Asus firmware, I have had no dropped connections since the reset last Saturday (4/10).

That is great news, darkelf!

Badge

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

 

 

After doing a factory reset on the latest Asus firmware, I have had no dropped connections since the reset last Saturday (4/10).

Userlevel 7
Badge +18

Hi @MrJohansson 

Thanks for sharing that!

Had lot of problem witth this, did clear my data and cash for Google home and sonos, then opened Google home and linked sonons again. This finally sovled my problem! 

 

Prior to this I had changed this settings. After clearing the data an cash this solved my problem.

 

Inställningar för ASUS:

På vänster sida klicka på Wireless

General/ Band 2.4GHz:

-Trådlöst läge -> Legacy
-Kanal bandbredd -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Tryck verkställ

Wireless / Wireless MAC Filter
-Enable MAC Filter-No 

Wireless/ Professional:

-Roaming assistant  --> Inaktivera
-Enable IGMP Snooping --> Aktivera
-Airtime Fairness  --> Inaktivera  på 2.4GHz och 5GHz
-Universal Beamforming/ Universal strålformning --> Inaktivera på 2.4GHz och 5GHz
Tryck verkställ

På vänster sida klicka på LAN och efter IPTV
-->Enable Multicast routing (IGMP Proxy) - Aktivera
-->Efficient Multicast Forwarding (IGMP Snooping)- Aktivera
Tryck verkställ

Starta om alla högtalare efter att dessa inställningar har gjorts/kollats för bästa resultat.

 

Mod Edit: Added English translation-

ASUS settings:

On the left side click on Wireless

General / Band 2.4GHz:

-Wireless Mode -> Legacy
-Channel bandwidth -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Press apply

Wireless / Wireless MAC Filter
-Enable MAC Filter-No

Wireless / Professional:

-Roaming assistant -> Disable
-Enable IGMP Snooping -> Enable
-Airtime Fairness -> Disable at 2.4GHz and 5GHz
-Universal Beamforming / Universal Beamforming -> Disable at 2.4GHz and 5GHz
Press apply

On the left side click on LAN and after IPTV
-> Enable Multicast routing (IGMP Proxy) - Enable
-> Efficient Multicast Forwarding (IGMP Snooping) - Enable
Press apply

Restart all speakers after these settings have been made / checked for best results.

Userlevel 2
Badge

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

If you have not done so already, have you considered reserving the Sonos IP addresses in the routers  DHCP reservation table?
 

Also, maybe try a different ‘fixed’ non-overlapping 2.4Ghz WiFi channel set to a channel-width of 20MHz, with any SonosNet channel (if using) set at least 5 channels away from the chosen 2.4Ghz channel. 
 

See if that perhaps eliminates your intermittent audio/device dropout issues.

Ken, if I had any idea of how to reserve IP addresses in the DHC reservation table, I’d give that a try! And honestly, it shouldn’t be this hard for Sonos owners. It is the ONLY wifi device I have that gives me problems. 

Besides, disabing the Guest Networks and turning off 802.11ax/ Wi-Fi 6 modes for both 2.4Ghz and 5Ghz, I also have the following:

SmartConnect disabled

QOS disabled

Airtime Fairness disabled

Universal Beamforming enabled - some people have said to disable this, but I’m not sure.  Disabling didn’t seem to do anything.

Control Channel set to Auto

With these settings, my Sonos devices stay connected.  Do any of you have the Guest networks enabled?  I will try this weekend to enable the Guest Networks and Wi-Fi 6 and set the channel to 6 and see if it works.

Damn, so you literally can’t use your router at this point. Sonos is so buggy I’m thinking of replacing it at this point. It should just work. The router reports it’s connected, there’s no reason it should disconnect.

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

If you have not done so already, have you considered reserving the Sonos IP addresses in the routers  DHCP reservation table?
 

Also, maybe try a different ‘fixed’ non-overlapping 2.4Ghz WiFi channel set to a channel-width of 20MHz, with any SonosNet channel (if using) set at least 5 channels away from the chosen 2.4Ghz channel. 
 

See if that perhaps eliminates your intermittent audio/device dropout issues.

Userlevel 2
Badge

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

 

 

Similar issues here, but changing the before mentioned settings didn't help. Sonos devices kept disappearing and when they were listed they couldn't connect to the radio stations. I solved it by changing the authentication method in my router from WPA2/WPA3-Personal to WPA/WPA2-Personal.

It used to work fine until I upgraded to the latest firmware 3.0.0.4.386.42095 with the WPA2/WPA3 setting as WPA2 should be supported.

Badge

So before installing Merlin, I thought I would do what some other threads recently said fixed their Sonos devices, which was to upgrade to the latest firmware and then do a factory reset. 

I did a factory reset yesterday afternoon (already had latest firmware) and so far almost 24 hours and no disconnects.  Will keep you updated.

Reply