ASUS RT-AC88U

  • 4 September 2016
  • 62 replies
  • 24033 views

Userlevel 3
I recently bought a new wifi router/access point an ASUS RT-AC88U

Once I switched over to it I found that I had sporadic access to my Sonos speakers (Play 3, Playbar + Sub).
Sometimes I could connect to the speakers, sometimes I couldn't. When I could connect I'd sometimes be able to see all the rooms and other times only 1.

I played with a bunch of wifi settings and finally tracked down the culprit.
Wireless menu >> Professional Tab >> Airtime Fairness
This setting is enabled by default. When I disabled it my access to my Sonos was restored to it's former fully functioning glory.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

OMG!!!! Thank you to OP, after more than half a year of hair-pulling frustration and off-the-wall ranting at the dark arts of wifi this was the one thing that finally did the trick. Sonos should pay you a commission; I was on the verge of giving up and moving to a different - and non-Sonos - brand.

Just remember to fix both bands, as already mentioned by others… :sunglasses:  

Thank you so much. Wasted a couple of days on this. Genuinely interested to find out how you discovered it was that setting in the first place.

And should add my Beam had been working fine up until about a week ago, but then Alexa stopped working on it and came across this issue only when I reset the Beam and tried to set it up again. No issues with configuring it when I first installed it last November, same RT-AC88U router.

Good god. Thank you. Was getting ready to return my Sonos but this thread saved me. 

I have set the Airtime fairness and cannot still get my speakers to connect. I have two Sonos One and two Play1 speakers. 

I tried the Sonos Boost but the Boost could not connect even hard wired into the router.  Ideas????

To fix Sonos issues with intermittent availability or connection to Apple AirPlay on ASUS’ standard/recent router firmware, whether using single or multiple ASUS routers in AIMesh or AP mode:

Wireless / Professional from the Settings web menu in the router admin.

Then:

  1. Disable Airtime Fairness
  2. Enable IGMP snooping

Then switch to your other router wireless bands (2.4Ghz, 5GHz-1, and potentially 5GHz-2 depending on your router model) and repeat.  

Airtime Fairness definitely interferes with the signaling Sonos uses to communicate and to connect with Apple Airplay 2 Audio.  Reports vary on IGMP but it seemed to help with my setup.

I am also having issues with ASUS RT-AC68U router not recognizing Sonos Connect Amps correctly all the time (not displaying on the network map when I log into the router). They are wired directly to the router. Similarly my wife and i do not see all of the systems on our phones or will see different systems each time.  I have disabled Airtime Fairness on both bands which is the Sonos advised fix for this router. I have read that putting the ConnectAmps on a switch before the router may help and will try.

However in case that does not work...is there a known prior firmware that may work (currently have 3.0.0.4.386_40558). Thanks for any help.

If I understand Sonos systems correctly, they send out IGMP multicast signals which need to make it to your iOS devices to have Airplay see them.  So turn on IGMP snooping on your wireless settings (in Asus, under the Professional tab in the Wireless menu if I recall correctly.  Might need to reboot.

I’ve had no problems with a Sonos ONE once I switched to direct-to-router wiring.

Asus just issued 4.386 as a major update to AiMesh; .384 is probably more stable at present.  

Thank you for time spent workng on this. My router (RT-AC88U) have worked flawlessly with my Sonos stuff for two years, until last week that is. Intermittent connection, not finding speakers etc. Tried “everything” even a factory reset for all devices and the cumbersome work of setting it all up again. It was almost not possible. But with all stuff connected the problem persisted. Played one speaker sometimes, did not find the others at other times and so forth. Extremely annoying. Tried Sonos support but they never answered the hotline (1,5 hours in waiting line) Browsed a lot but stumbled across your tips today. Changed the airtime fairness setting and 1 minute later everything was working perfectly! 

 

I have been fighting with my Sonos One SL speakers on an Asus RT-AC88U router for way too many hours. Yes this looks very promising.

New to Sonos...was having a very frustrating experience until I discovered this post. Thanks for sharing! Everything worked great after this router setting change. 

This Worked.. Thank a lot for amazing resolution.. after a lot of troubleshooting this saved the day

thanks, its working for me at the moment. hopefully it fixed. thanks team...