Asus Router issues with Sonos

  • 4 November 2017
  • 27 replies
  • 12556 views

Userlevel 2
If you are having trouble hooking up to your speakers and you have an Asus router, eg AC 3100, you have to check out
Wireless menu >> Professional Tab >> Airtime Fairness. Disable this setting and all should be fine

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

27 replies

OMG, I just found this on another forum and it solved all my issues. Confirming that this fix also works for the RT-AC5300 model.
Userlevel 1
Badge
It didn’t solve my problems. I think there is more issues with the Sonos app itself / connectamps and their resilience with networks in general.
This also works for the RT-AC88U - Thank you it solved everything - I hope.
I can't thank you enough for figuring this out. After having Sonos throughout my house for over 6 years, this past year has been a nightmare since I added the Asus router. I tried every scenario dozens of times, wasting countless hours. Sonos tech support was useless on this issue. Their advice was to go out and get a new Bridge, or boost, as that was probably the issue. I knew it was not, since my problems started the day I installed router. Just couldn't get it figured out.

The only think I would add here, is that before you change the router setting unplug all of your Sonos equipment. Add each component back one at a time. Amazingly, they all come back. 😳
Badge
Disabling airtime fairness on 2.4gHz channel did it. Thanks jmrod!
Had occasional audio dropouts on playbase 5.1 kit when watching Netflix on Xbox One and with SKY+ HD. Optical audio pass through from Sony tv. Disabling Airtime Fairness on ASUS RT-AC3200 2.4GHz seems to have solved the problem. Thank you untidy, it was driving me nuts, you are a god!
Anyone else having trouble having their phone see the sonos network
This worked for me as well when I replaced my ASUS RT-AC66R with the AC3100. Thanks for the tip!
When I try to do this it then says that other settings will auto change:
After configuring the settings in AiDisk Wizard, refer to the information below to access the disk:
DDNS is not enable yet. You can enable it in WAN / DDNS when people need to access FTP via the domain name from WAN.
LAN FTP address: ftp://AN ADDRESS
For advanced file-sharing configuration. Click here
Warning: The AiDisk had been set. If you set the AiDisk again, the previous account/password and access permission will be reset. To add more account, Select here to edit the account profile.
If you cannot use ASUS DDNS services, please go to http://iplookup.asus.com/nslookup.php to reach your internet IP address to use this service.
Terms of Use Notice
When I try to do this it then says that other settings will auto change:
After configuring the settings in AiDisk Wizard, refer to the information below to access the disk:
DDNS is not enable yet. You can enable it in WAN / DDNS when people need to access FTP via the domain name from WAN.
LAN FTP address: ftp://AN ADDRESS
For advanced file-sharing configuration. Click here
Warning: The AiDisk had been set. If you set the AiDisk again, the previous account/password and access permission will be reset. To add more account, Select here to edit the account profile.
If you cannot use ASUS DDNS services, please go to http://iplookup.asus.com/nslookup.php to reach your internet IP address to use this service.
Terms of Use Notice
Should I make the change???
What has this to do with Sonos?
What has this to do with Sonos? The change that is being suggested above in this thread, states to make this change - i was wondering if anyone else had this instruction. No worries if not I'll go elsewhere
Userlevel 7
Badge +21
This change?

Wireless menu >> Professional Tab >> Airtime Fairness. Disable this setting and all should be fine

Try it, you may find other devices also work better with it set to off.
I have an ASUS RT-AC66U router that does not have an option for airtime fairness. My sonos has worked find for four years so current connect problems are new. Has anyone resolved the issue with a Asus Router that does not have airtime fairness
Wow, this thing bugged me for a very long time. I had to install a hacked version of firmware to get it working. This solved my problem. Thanks man! My question is, how did you find this fix. There are over 100 setting in the system.
Userlevel 7
Badge +21
I saw it mentioned as being problematical on Ubiquity gear, in their forums. Since I got mom a Sonos and gave her my old Asus router I decided to see if it was an issue for her and turned it off to avoid issues.
Userlevel 1
Badge
Asus AC-3100: disabling airtime fairness and disabling IGMP snooping does not fix my 2 chronic issues: ie music dropped by the connectAmps and rooms randomly going offline (undetectable by the app)

I have lan lines and fixed ip for my multi-amp house. Are there other Asus router settings that I should look at?
Userlevel 7
Badge +21
If you have set static/reserved IPs for the Sonos gear the next place I'd look is your Network Matrix and see if any connections are bad or if there are any noise issues at your Sonos device locations.

Wouldn't hurt to submit a diagnostic and post the number here too so Sonos can add suggestions based on your system internals.
Userlevel 1
Badge
diagnostic: 714896278 it should capture the room going offline as well as music dropping repeatedly
Userlevel 1
Badge
I don’t think it’s a physical issue. Cords are all new. I don’t have noise issues
Holy freaking shit, I pulled my hair out for 2 days before I found this thread. Thank you so much for sharing. All of the problems in my life have been solved by it.
After being frustrated for months with my Asus RT-AC5300, this fixed problems with my setup.
I spent several hours one night troubleshooting my Sonos system - I have a play 1, play 5, and connect amp. I did factory resets, wireless and wired connections, and tried different areas in the house... nothing worked. The best I could do is connect to one speaker at a time but it would never connect to the others. I came across this post... I have a ASUS RT-AC5300 router and disabled the Airtime Fairness option in each wireless profile and it fixed the problem. Thanks for sharing this solution, my system is up and running again!
Thank you so much for this. Everything was packed up and on its way out the door back to Best Buy.
You saved my life. Was working on this for hours until I found this thread. Airtime Fairness disabled and boom setup connected right away.