Answered

Arc, TV Autoplay function problem


Badge +1
  • Contributor I
  • 9 replies

Hello everyone đź‘‹

I am having a problem with my new Sonos Arc soundbar. Is it possible, as with the Playbar, that the sound of the TV does not automatically switch to the Arc?

I have deactivated the "Auto-play TV" function but that does not change anything, the sound goes directly to the bar.

This function worked very well on the Playbar.

Thanking you in advance.

icon

Best answer by Corry P 10 June 2021, 12:37

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Userlevel 7
Badge +17

Hi @ThiV 

Welcome to the Sonos Community!

You’ll want to have the Autoplay function turned on,

Due to the difference in how the Playbar and Arc connect to the TV, you may need to change some settings on the TV. Do you get any TV audio at all from the Arc if you select the TV input from the Sonos app? If you don’t, you’ll probably just need to turn your TV’s version of CEC on. Different manufacturers use different terms. Samsung call it AnyNet+, Sony call it Viera Link. Google will tell you if you search for CEC and the name of the manufacturer, along with how to turn it on.

Unplugging both the TV and Arc from power for about 30 seconds may also get them communicating again.

Please also make sure you are using the designated HDMI-ARC port on the TV for the Arc.

If this doesn’t help, please reply with info on your TV and what does and doesn’t work on the Arc. Thanks.

 

Badge +1

Hello @Corry P and thank you for your answer.

In fact it's the other way around, I would like the automatic play function not to be activated when you turn on the TV.

This option works fine on the Playbar, but not on the Arc.

Userlevel 7

If you want to use your TV speakers rather than the Arc, turn off CEC in your TV settings.

Badge +1

Hello @GuitarSuperstar and thank you for reply,

I tried last night by removing this function (Viera Link), but in this case it completely deactivates the soundbar, it becomes unreachable.

(TV Panasonic TX-P55VT3OE)

Userlevel 7
Badge +17

Hi @ThiV 

Hello @Corry P and thank you for your answer.

In fact it's the other way around, I would like the automatic play function not to be activated when you turn on the TV.

This option works fine on the Playbar, but not on the Arc.

Ah - sorry for the misunderstanding. Autoplay issues are generally the other way round.

Yes - turning Autoplay off should prevent the Arc from stopping music playback and start playing TV audio when you switch on your TV. If this isn’t functioning as expected, please unplug the Arc and TV from power for about 30 seconds.

If that doesn’t help, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Badge +1

Thank you for your new message.

I will try this manipulation tonight.

I'll keep you informed.

Userlevel 7

Hello @GuitarSuperstar and thank you for reply,

I tried last night by removing this function (Viera Link), but in this case it completely deactivates the soundbar, it becomes unreachable.

(TV Panasonic TX-P55VT3OE)

Yes, turning off VIERA Link will stop the TV audio from playing out of the Arc so you can use your TV speakers. When you want to use the Arc for TV audio again, you have to turn VIERA Link back on.

Badge +1

….

Yes - turning Autoplay off should prevent the Arc from stopping music playback and start playing TV audio when you switch on your TV. If this isn’t functioning as expected, please unplug the Arc and TV from power for about 30 seconds.

….

 Good evening,

Following yesterday's message, I tried the operation which consists of unplugging the Arc and the TV for 30 seconds, it doesn't change anything, disabling "TV Autoplay" still doesn't work.

I still tried other manipulations, without result, the sound of the TV goes directly to the Arc even if we do not want it.

Userlevel 7

@ThiV What exactly are you wanting to audio to do when you turn the TV on? Do you want the audio to play out of the TV speakers?

Badge +1

Yes that's exactly it, I don't want the soundbar to be activated unnecessarily to watch news or a program that does not require going through the Arc.

Userlevel 7

Your only option is to manually turn off VIERA Link, or in the VIERA Link menu on your TV, change Speaker Selection to TV instead of Home Cinema.

Badge +1

Your only option is to manually turn off VIERA Link, or in the VIERA Link menu on your TV, change Speaker Selection to TV instead of Home Cinema.

Thank you for your answers.

The solution to deactivate Viera Link on the TV is really not practical, moreover it also deactivates the automatic functions of my Blueray player.

The other solution which consists in modifying the selection of hp on the TV does not work, the sound is automatically returned to the sound bar after a few seconds.

Userlevel 7

Those are pretty much your only options other than disconnecting the Arc’s HDMI cable from the TV.

Badge +1

Thank you for this new answer.

I don't think that an HDMI cable and port is designed to be mated and uncoupled multiple times, moreover it is really impractical.

I noticed above all that the function of deactivating the "Auto-play TV" mode, which was perfect on the Playbar, does not work on the Arc, a sound bar which still costs € 899 each!

It's a bit disappointing.

Userlevel 7
Badge +17

Hi @ThiV 

Your TV has a setting to turn TV speakers on or off. If this is set to On, it doesn’t matter what you do with the Arc or it’s settings - you’ll get TV sound from the TV speakers and not from the Arc.

I’m not sure why the Arc is still switching over when the AutoPlay function is turned off, but if this was working, you wouldn’t then get the TV speakers playing without the TV being told to use them in it’s settings.

I suspect that with your Playbar, both TV and Playbar were playing at the same time and you couldn’t hear it from the TV speakers as the Playbar was louder. You could use the optical adaptor that came with the Arc to go back to how it was with the Playbar, but you’d lose the option of playing LPCM or Atmos audio. This works because the optical link is one-way-only, and the TV has no way of telling if a device is using the link, so it’s on all the time, regardless of the TV speakers being selected (although this may vary from TV to TV).

The real problem here is that no-one who makes TVs or Soundbars expects people to want to use the inferior TV speakers once they own a soundbar (you did spend €899 on it, after all). As the TV now knows you have a soundbar (unlike with the Playbar via optical), it’s only allowing either the TV speakers or the Arc to play TV audio.

Badge +1

Hello everyone,

I tried again this weekend several manipulations, my problem remains unresolved, the deactivation of the "TV Autoplay" mode does not work, nor the fact of forcing the diffusion of the sound on the speakers of the TV.

I just have to wait for a hypothetical update from Sonos, or if not to put a switch system on the HDMI cable so as not to use the sound bar when I don't want to.

Case to follow...

Userlevel 7
Badge +17

Hi @ThiV 

In regards to the AutoPlay setting not doing what it’s supposed to do, I recommend you get in touch with our technical support team.

Badge +1
Hello @Corry P,Thanks for the advice, I will try this solution when I have a moment to contact phone support.