App Freezing


Badge
Hi all. My app keeps freezing on my iPhones (one an X, one an 8) and my iPad. The controller works fine on my laptop (working wirelessly). Everything is updated; and I did a system reset as well. The issue is this: if I open the app and start using it it works fine; if I switch to a different app (or even just go to the phone or iPad home screen) for even one second, when I return to the Sonos app it will play for one second and freeze. Any ideas? I submitted a diagnostic: 1966087381.

21 replies

I've got the same issue as of today with Android on mobile devices. I've tried a reinstall to no avail; running 9.0.1. Switching apps, going to homescreen or doing anything else freezes the app.
Badge
Well sorry to hear that but glad it’s not just me. I’ve been going crazy.
Same problem here. It seems to have started with the update that allows Airplay 2.
Userlevel 1
Yup. 9.0.1 (Otherwise known as the AirPlay2 release) freezes on the Android consistently. A restart allows me to execute a few commands but another freeze happens pretty soon afterwards. #TestMuch?
The problem has gone away. It may be because I updated the controller on my MacBook Pro although I don’t know how this could affect my phone and IPad.
I have the exact same problem. On the IPhone 6s. I have tried reinstalling the app and resetting my phone but issue remains
Same issue here. Have to force quit and restart any time I want to adjust the volume more than once.
Same issue here since last update. Hangs and crashes on my samsung galaxy note 8 and iPhone 6s, 7, and X. Here's my last diagnostic submission code from a few minutes ago. 1330134914
I get exactly the same as the above posts.... it’s driving me nuts. Any solution(s) yet?

I also get track skipping too when playing from a playlist on my phone but it doesn’t do it when playing one track at a time??
Same problem here for both my husband and myself. Both of us have an iPhone X. Hey Sonos - are you doing anything about this???
Odd, I'm using 9.1 on a iPhone Xs and not having any problem.

Any chance you could submit a system diagnostic and post the number here, the next time you have to reboot after a freeze? It would probably be useful for Sonos to find the issue if they had more data as to why it is freezing.

As a note, using the open bracket "s" close bracket turns on the strikethrough.... :)
iOS 12 it continues on....v9.1 of the app. Did this on iOS 11 as well. No difference there. Diags submitted last night but I need to do it again to grab the number. Really bizarre stuff.
Still not happening for me. Did you submit the diagnostic that I mentioned in the previous post to yours? If so, you should post the number here, and let Sonos know what it is they're looking for in the diagnostic. If you don't post the number, or call in, they don't look at it, generally speaking.

The other thing I'd try is twofold. 1) Try a simple power cycle of the speakers themselves. On the offhand chance there's some lingering misuse of memory on the computer in each one, a reboot would clear that. 2) Try deleting the app from the device running iOS 12, and then power cycle it as well, before downloading and installing a fresh copy of the controller.
I am talking to Sonos about it.

Like I said, I did a diag send, as did the OP. I don’t have the number as I didn’t grab it at the time so I need to do another one. I need to sit and test it as well. Reality is it is happening to a lot of folks clearly. Maybe it’s just slow and it’s interference. Not sure.

It’s not just an issue at iOS 12 as it happened on 11 as well.
Glad you're talking to them already. Please keep us posted, this does appear, extremely rarely, and it would be nice to know what resolved it for you.
Badge
Have discussed with Sonos and Sonos engineers multiple times and they can't figure it out. Have tried everything.
Often, in situation like this, there can be more than one issue causing the symptom. Some can be easier than others to rectify, and what's happening to one person may not be the same issue as what's happening to you, it just appears so. And frankly, even it it does turn out to be the same thing causing it, a second (or third, or X) data point provided to the Sonos engineers would be perhaps useful. I've had my fair share of engineers tell me "I can't reproduce this 'bug', so I can't fix it". The more data that they get on the issue, the better are the chances of them figuring out what might be happening.
Badge
Understood. Have spoken to them many times and we've reproduced the issue many times and have sent them a ton of data. They've been extremely nice and patient but so far no luck. And tons of other people are dealing with this, and it all started two updates ago.
Try a power cycle of your Router
pjvent777 wrote:

Understood. Have spoken to them many times and we've reproduced the issue many times and have sent them a ton of data. They've been extremely nice and patient but so far no luck. And tons of other people are dealing with this, and it all started two updates ago.



Yep, exactly. I just hadn't had the time to mess with it - customers call... :) . And tech is what I do, so I totally get the issue of not being able to reproduce the issue. I work with vendors in support situations all the time and really do get that.
My SONOS system is unusable with these constant freezes. This has been going on for long enough - SONOS please fix this

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings