An error occurred while adding tracks to the queue (1002)

  • 1 February 2014
  • 64 replies
  • 12260 views

I have a mac and keep getting this error even though I setup Sonos in the prescribed way: "An error occurred while adding tracks to the queue (1002)"

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

64 replies

Userlevel 7
Badge +26
Hi. I am having a problem with this as well. Coming up with error 1002. This is while using apple music. I try to "play all" from my songs and get the error. It is a lot of songs that I want to randomly play from but would like to resolve the problem if possible. I have submitted a diagnostics - 5484356. Thanks

I see that you have your PLAYBAR wired to the network, do you have trouble using a controller to add all of the tracks to just that unit on its own? Does the same error come up for each of your controllers?

The 1002 error is basically a generic timeout saying things took too long. Naturally, larger playlists or song groupings take longer to add to a queue than shorter ones, so network latency can be a big factor when it comes to adding them. In the interest of improving your network setup, I'd recommend changing the wireless channel on Sonos to the different channels, leaving the system on each one for a good 10 minutes worth to test. The diagnostic showed Sonos and your router on the same channel at the time it was taken, this can cause some slowdowns.

Thanks
Badge
Hi Ryan

Thanks for replying. All controllers don't work when trying to use any speaker. I have changed one channel to 1 and the other channel to 11. Still no change. Could it be because the number of songs is about 5000? Thanks
Userlevel 7
Badge +26
That is a large amount of tracks to be sure but it still should be doable. I'd recommend giving us a call and working with a technician live at this point. They'll take a closer look at the network and give you a hand determining the best way to optimize the setup, that should help with this issue.
I'm getting the same error as well as 2 zones dropping out on me.
Could someone take a look at the diagnostic I submitted?
5517395

thanks.
Userlevel 7
Badge +20
Hi, anthonycferrara. I have had a look at the diagnostic you have submitted. It would appear that two of your zones still have some of the credentials of one of your Wireless Access Points in them. Are the zones that are dropping off Kitchen and Master Bedroom, by any chance? We need to remove the credentials of your network from these two devices. In any case, I would recommend getting in touch by telephone so that we can advise in realtime. Please be advised you may be asked to temporarily disconnect any additional access points other than your main router.
Hi, anthonycferrara. I have had a look at the diagnostic you have submitted. It would appear that two of your zones still have some of the credentials of one of your Wireless Access Points in them. Are the zones that are dropping off Kitchen and Master Bedroom, by any chance? We need to remove the credentials of your network from these two devices. In any case, I would recommend getting in touch by telephone so that we can advise in realtime. Please be advised you may be asked to temporarily disconnect any additional access points other than your main router.

thanks. the zones giving me problems are patio and bedroom.
I'll try to call later today. thanks again.
Badge
Hi - I've just submitted a diagnostic with the confirmation number 6873177. I am getting the 1002 error when trying to load all of my Spotify tracks (approximately 5200). This is a recent but consistant occurance. I can load all of my music on my local hard drive (~14,700 tracks), and all of my Amazon music (~500 tracks), but Spotify consistenly gives me the error. Initially, it would give me the error but work on the 2nd try, but even that stopped in the last few days.

I have removed and re-added my spotify account to my controller, and adding a single album from Spotify works fine. This happens from both my iPhone and my Windows 10 machine. It happens when I select "play all" or "shuffle" for all tracks.

On the Win 10 controller, I can select the first song, scroll all the way to the bottom and control-select the last song and drag all ~5200 songs to the queue. That seems to work, but it's painfully slow and not possible to do from the iPhone. I control my Sonos system 95% of the time from my iPhone.

Thanks for your help.

Mike
I am having, and have had for months now, the same error message. I've looked through the forums, and the solutions have gone over my head. Radio works fine, as does Apple Music streaming. It won't play my music, though.
Hi Dubious1977

Could you submit a Diagnostic and post the number so we can see what's going on. When you say it won't play my music, what is the source of that "music" are you referring to "my Music" within Apple Music within Sonos?

Many thanks
Hi Matt,

My diagnostic number is 7314682. Yes, it is my own music through Apple Music. It tends to be the larger playlists.

Thanks
Dave
Hi Dubious1977

Could you go to "settings" within the Sonos application and then go to advanced settings and select "wireless setup" select next and then then on the next page, don't put in any wireless password, but you should see a "reset" button, could you then press this. This will remove the Wifi credentials from your players ( as they don't need them because you have the bridge wired to your network).

Having these wifi credentials in the players can cause problems.

Then a couple of questions :

Do you have an individual Apple Music account or are you part of a Family account subscription .

Do you have iTunes setup on a computer and synchronized with your apple Music account ( icloud Music Library)? If so if you look at the playlists in iTunes do you see any greyed out tracks that have the status "iCloud waiting"

In terms of the contents of the playlists, do they contain a mixture of uploaded, purchased and downloaded ( made available offline streaming tracks) or are they of one type.

Many thanks
Hi Matt. I tried that, no joy. It is an individual account, and my iCloud music account is set up on my computer, though it is on an external Hard drive. There are a small number of greyed out tracks.

Cheers
Dave
Badge
I am having this same problem with my playlists imported from iTunes, but on a PC. There was a recent iTunes update; wondering if that has messed up something.
Badge
And this morning, my problem had cleared up; opened Sonos, it re-indexed my music library, then played everything as normal! Must have been some type of bug with the updates, either its own or iTunes'.