An error occurred while adding tracks to the queue (1002)


I have a mac and keep getting this error even though I setup Sonos in the prescribed way: "An error occurred while adding tracks to the queue (1002)"

65 replies

I have the same issue, but in addition, it was worked seemlessly before, but now it is having issues.
Badge
I am having the same issue.  My Sonos worked well for many months and yesterday it started cutting out, all controllers are crashing, it will work briefly then cuts out.
Userlevel 7
Badge +25
Hello everyone,

That error message indicates connection or network latency. You could also be experiencing wireless interference on the system there causing things to have connection issues.

Do you have any trouble playing other music sources of music other than your computer's music library? 

I'd recommend starting with changing the wireless channel on your Sonos system. It's best if you can check with that channel is on your router, and make sure there are 5 widths between the two.

If you're still having trouble can you please submit a diagnostic from your system and reply back with your confirmation number?

Cheers.
My brother is having this issue with zp100s I got for him. They are hardwired however and he's using a Mac as well. I changed the channel to be opposite sides of spectrum 1 and 11. But does this matter if they're wired?
Have the same problem. I have found if I have two or more devices 'linked' and trying to control the music both get the errors and stop working. I closed both both and made sure they were no longer running in the background restarted sonos on one, my ipad, seems the iPhone is buggier, and got the controller/music playing again
Have the same issue and have had since we brought the Sonos. So temperamental works one day and then throws up this ridiculous error message the next. Cannot count the number of times software has been reinstalled and buttons pushed to "find" the system. Totally fed up. Probably the worst 500 quid we have ever spent! Would not recommend to a friend under ANY circumstances.
Userlevel 7
Badge +25
Have the same issue and have had since we brought the Sonos. So temperamental works one day and then throws up this ridiculous error message the next. Cannot count the number of times software has been reinstalled and buttons pushed to "find" the system. Totally fed up. Probably the worst 500 quid we have ever spent! Would not recommend to a friend under ANY circumstances.
Hi Steve,

Intermittent issues like that can usually be resolved after a bit of network optimization. I'd recommend giving us a call and working with a technician live. They'll be able to assist finding any interference or network latency causing you trouble.
I am getting the same error. I cant replace the queue of songs when using Spotify. I havent been able to queue up new songs in over two weeks! Very frustrating.
Hello everyone,

That error message indicates connection or network latency. You could also be experiencing wireless interference on the system there causing things to have connection issues.

Do you have any trouble playing other music sources of music other than your computer's music library? 

I'd recommend starting with changing the wireless channel on your Sonos system. It's best if you can check with that channel is on your router, and make sure there are 5 widths between the two.

If you're still having trouble can you please submit a diagnostic from your system and reply back with your confirmation number?

Cheers.

I disconnected all other wireless devices, but that didnt work. I changed the wireless channel, but that didnt work. I tried to submit a diagnostic report, but it wouldnt even let me do that.
same issue for me. worked ok this morning. now isn't. have rebooted. have changed channel. have ungrouped. have bought wireless booster. have torn my hair out and waned to throw controller across the room.  diagnostic report 3830585
Userlevel 7
Badge +25
same issue for me. worked ok this morning. now isn't. have rebooted. have changed channel. have ungrouped. have bought wireless booster. have torn my hair out and waned to throw controller across the room.  
Hi Sam,

Before you get to all of your hair, it looks like your system is getting a lot of wireless interference on the channel you're on. You said you've changed channels, which ones have you tried?

If your BRIDGE is on top of the router, please make sure to separate them by a foot or two. Also, you'll want to check your router's wireless channel. Sonos can be on 1, 6 or 11, make sure your router is on one of the other 2.

Do you have any other wireless devices in the area such as a cordless phone?

The wireless booster will only be extending the wireless for your home network, but please make sure that device doesn't have the same wireless channel as Sonos as well. 

Do you only have trouble playing music from your iPhone or other sources too? The booster should help the iPhone's connection.

If you constantly have trouble, it might be best to give us a call on our Customer Care Line.

Thanks
My girl and I have the same issue. It seems every day, (the first and sometimes second attempt) I get the error when trying to add tracks (or an album) from "this mobile device" to the queue... We are both running the newest Android on our Galaxy Note 3's. 
Userlevel 2
I have the same issue, however I'm using the system cabled and NOT over wireless. I'm at the end of my tether with the thing. Every time I go to use it I have to reboot the unit before it works. 
Userlevel 7
Badge +25
I have the same issue, however I'm using the system cabled and NOT over wireless. I'm at the end of my tether with the thing. Every time I go to use it I have to reboot the unit before it works. 
We'd be happy to help take a look at a diagnostic from the system there. Where is the source of your music library? Is that wired to the network or wireless?

Can you please submit a diagnostic from your system and reply back with your confirmation number?

Thanks
I have the same issue, however I'm using the system cabled and NOT over wireless. I'm at the end of my tether with the thing. Every time I go to use it I have to reboot the unit before it works. 
I have submitted my system's diagnostic.
Your confirmation number is: 4177934.
Userlevel 7
Badge +25
I have the same issue, however I'm using the system cabled and NOT over wireless. I'm at the end of my tether with the thing. Every time I go to use it I have to reboot the unit before it works. 
Hi Enrique,

Thanks for that diagnostic. It seems the system is trying to reach a computer named MediaServer but your player is getting the wrong IP address for it. I'd recommend starting with rebooting your router and then your Sonos components to refresh the network information.

You're also getting troubling amount of wireless interference, but in your environment, I think your Sonos is on the best wireless channel it could be on currently.

Let us know how it goes after the restart please.

Thanks
same error just started on my Macbook Air after subscribing to Spotify but on streaming from there only, Sonos plays my music on my WD cloud drive connected to my router without problem, I can also play music stored on my iphone on my Sonos system but again not via spotify (iphone app )
Userlevel 7
Badge +25
same error just started on my Macbook Air after subscribing to Spotify but on streaming from there only, Sonos plays my music on my WD cloud drive connected to my router without problem, I can also play music stored on my iphone on my Sonos system but again not via spotify (iphone app )


Hi Steve,

Streaming from Spotify makes use of both your Internet connection speed and the stability of the wireless locally. If you're having no trouble with wireless streaming from your local library, than this is likely being caused by something on the internet side of things. Spotify streams pretty high quality content which can have trouble on network connections that are having issues.

To start with, we'll want to take a look at your network and Sonos system there. Can you please submit a diagnostic and reply back with your confirmation number?

It'd also be good for you to run a speed test and a ping test on your network to see what quality of an internet connection you're getting it.

Thanks
same error just started on my Macbook Air after subscribing to Spotify but on streaming from there only, Sonos plays my music on my WD cloud drive connected to my router without problem, I can also play music stored on my iphone on my Sonos system but again not via spotify (iphone app )


I have the same issue, worked fine for months and will now not pick up my itunes library on imac.  Submitted diagnostic under 4211874.  Have also checked all the recommendations above. 
Userlevel 7
Badge +25
same error just started on my Macbook Air after subscribing to Spotify but on streaming from there only, Sonos plays my music on my WD cloud drive connected to my router without problem, I can also play music stored on my iphone on my Sonos system but again not via spotify (iphone app )


Thanks for the diagnostic Alex. Your BRIDGE is getting hit with a lot of wireless interference causing the system to have a lot off communication issues. Can you start with changing your Sonos wireless channel? If you're able to change your router's wireless it's best to spread the two channels out as far as possible.

Also, if the BRIDGE is sitting directly on or next to the router, try to get a couple feet distance.

Let us know how it goes.
Userlevel 2
Just switched ISP from Virgin to BT in the UK. Now the SONOS system is totally unpredictable. It will play then stop, lose Napster/Rhapsody. Currently it will play local server based music but nothing streamed. Diagnostic reference is: 4233212 
Many thanks, Adam
Userlevel 2
Sonos worked with the internet music but it would not connect to the PC.  I received the "...1002" error and and another error about connecting to the "Music" folder on the PC.  I navigated to Kaspersky antivirus software firewall network settings and changed my home router from "Public network" to "Local network".  Fixed problem.
Userlevel 7
Badge +25
Thanks for that diagnostic, it looks like 3 of your players are looking for the wrong router on the network to get a network connection from. If you replace your router you need to make sure to reboot every one of your Sonos players.

If you're still having trouble, we'll need a bit more of a network layout there. Did you leave the old router from Virgin on the network somewhere? Is it powered up still and also assigning address? Any other routers or network switches there?

Thanks
Userlevel 7
Badge +25
Sonos worked with the internet music but it would not connect to the PC.  I received the "...1002" error and and another error about connecting to the "Music" folder on the PC.  I navigated to Kaspersky antivirus software firewall network settings and changed my home router from "Public network" to "Local network".  Fixed problem.
Great to hear Steven. Let us know if we can help with anything else.
Interestingly, I experience this frequently as well, but only when adding tracks to the Queue from a very large playlist that I have. I don't seem to experience this with smaller playlists… Is there some sort of maximum playlist size that can be added to the queue?

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings