Answered

An error occurred while adding tracks to the queue (1002)

  • 11 January 2014
  • 79 replies
  • 66068 views

I keep getting this error all the time and nothing has changed in my system. Why is this happening?
icon

Best answer by Keith N 6 March 2018, 20:59

Hello everyone. Thanks for posting about this. The team is actively working on an issue where adding >500 tracks to the queue will cause a 1002 error when adding tracks to the queue. While the team works on this, the only workaround is to use smaller playlists or selections to add to the queue.

If the 1002 error appears without adding items to the queue, it is likely due to something regarding connectivity and interference. Please create a new topic and submit a diagnostic report. Any of the Sonos Staff, myself included, will be happy to take a closer look and advise on next steps.

Once we get more information about this, I will update this topic. Thanks for your patience.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

79 replies

Userlevel 1
I have the same issue, how was this resolved?

If you are using a firewall, try to find and disable it for Sonos.

If you are using an Antivirus program, disable it and test if it works, if not then its a problem with your network, search Homegroup in Control Panel, find the setting: Change Homegroup settings then the setting: Change advanced sharing settings. Go to All Networks tab, under Media Streaming, choose media streaming options, under show devices, change it to All Networks. Check if anything is not allowed, if so, allow it.

Finally, both of the above does not work if you use strict firewall antivirus programs such as Kaspersky, which I use. For this (I'm using the 2015 version), go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing you from playing it. If all of these don't work, just disable the firewall option entirely.
I have the error 1002 all of the time! It has been going on for over a year now. Support doesn't help at all. This is a known issue and I never had this problem before until over a year ago. My settings are all correct. My internet is not the problem either. Now my library is useless about 95% of the time! This is so aggravating! Useless piece of crap! I will never recommend Sonos, ever! I wish that I could get my money back, seriously!
Userlevel 1
Badge
The team is actively working on an issue ...


"The team" is grossly incompetent. It has always been the case, and always will be the case, that trying to add a large number of songs to the queue will encounter at least one error. Rather than adding the songs that are successfully found, Sonos cancels the entire operation if there is any error. How stupid do you have to be not to realize that this is the wrong approach to error handling?
Userlevel 4
Badge +3
Hi, I'm having problems with the controller on my mac book, it won't let me do anything i keep getting (error 1002) for everything; updating music library, adding tracks to queue, ect. My diagnostic number is: 6627777. I have checked that no firewall is blocking it, but still no luck. Please may I have some help, Thanks!

Hi there, welcome to the community. The error on the diagnostic we're seeing does usually indicate a firewall is present, so please double check that, just to be sure. We have an article on firewalls here. The other thing I can see is that the BT Hub is not returning the correct IP address of the computer. This can happen when there is a discrepancy with the name your Mac is known by on the network. Have a look at this artice. It's a little dated, as we prefer not to share via SMB these days, but the rest still applies. Follow the instructions about renaming the Mac, and change it to something nice and simple, such as 'HarryMac'.

Restart the Mac and also the BT router, and try to add the share again.
I get the same. I've tried every piece of advice for resolving but no success. Diagnostic number 6766053. Frustrated
I have the same issue, how was this resolved?

If you are using a firewall, try to find and disable it for Sonos.

If you are using an Antivirus program, disable it and test if it works, if not then its a problem with your network, search Homegroup in Control Panel, find the setting: Change Homegroup settings then the setting: Change advanced sharing settings. Go to All Networks tab, under Media Streaming, choose media streaming options, under show devices, change it to All Networks. Check if anything is not allowed, if so, allow it.

Finally, both of the above does not work if you use strict firewall antivirus programs such as Kaspersky, which I use. For this (I'm using the 2015 version), go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing you from playing it. If all of these don't work, just disable the firewall option entirely.


Thank you, allowed the Local Services (TCP) - worked straight away. Why do Sonos not point this out?
Having same issue. 8359454 is my diagnostic number. Sonos, please fix these issues that starts coming to your system!!!
Im also having the issue whereby Im trying to shuffle songs from My Music on Apple music. I get the 1002 error - disagnostic number 8433873
[quote=rachanddavew]Hi there. Please can you help? As many above i am receiving the error code 1002

Regarding the error code 1002, Sonos sucks! People have been asking about this for years now and you still get the runaround. Just fix the damn thing and put it in an update. It’s your responsibility as a company to make sure your products work not ours as the consumer.
I have the same issue, how was this resolved?
Userlevel 6
Badge +3
Okay glad, (well in a way) that some other people are having troubles too. I have attached via ethernet my Bridge a Playbar in my living room. Also in the living room is my Sub and 2x Play3's as surrounds that use the bridge Wifi. These are all working well and no problems.

About 15ft from my router (latest version Apple AirPort Extreme that sits right next to my Sonos Bridge in the living room) I have a Play3 using Wifi.
I also have a Play5 (1st Gen) on the same floor about 30ft from the Sonos Bridge and my Apple AirPort Extreme.
Upstairs in my bedroom I have 2 Play1's in a stereo pair. Again this is really not that far away from my Sonos Bridge and the AirPort as they are directly above.

Since Friday I have been having so may difficulties with my system. Everything in the living room (the PlayBar, SUB and 2x Play3 surrounds seem to be working fine. However every other Sonos device in the house is constantly going down and dropping connection. I have powered down my FiOS router (this is in the basement and does not have Wifi configured but has an ethernet to my Apple AirPort, it is my DNS) my Airport and every Sonos device in the house. I then went and turned on my FiOS router, then the AirPort. Once these were up I then connected my Sonos Bridge waited for this to connect then did the rest of the Sonos equipment one by one. Only the Living Room gear will maintain a connection.

I have tried over and over to reconnect each of the other devices, sometimes they will connect and show in the Sonos devices but after a short time they disconnect and don't show anymore. Sometimes they will be there and I try and play some music and I get an error 1001 saying it could not add the music and the device vanishes from the list of devices.

I am a pretty tech savvy type of person. I have tried the 3 different channels on my Sonos settings, I have reconfigured my wireless network to use different channels away from the Sonos channels. I have checked the other wireless signals in my area and have made sure they are not interfering with the Sonos channels. So I am at my wits end, and I have submitted a diagnostic report the confirmation number is: 5471418.


I have reviewed your diagnostic. Do to the issue the best would be to contact us by phone. A Sonos technical worker will be able to remotely connect to your system and check both your Sonos and network.
Let us know how it goes.
I have the same issue, how was this resolved?

If you are using a firewall, try to find and disable it for Sonos.

If you are using an Antivirus program, disable it and test if it works, if not then its a problem with your network, search Homegroup in Control Panel, find the setting: Change Homegroup settings then the setting: Change advanced sharing settings. Go to All Networks tab, under Media Streaming, choose media streaming options, under show devices, change it to All Networks. Check if anything is not allowed, if so, allow it.

Finally, both of the above does not work if you use strict firewall antivirus programs such as Kaspersky, which I use. For this (I'm using the 2015 version), go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing you from playing it. If all of these don't work, just disable the firewall option entirely.


Spot on. I followed the above steps and wow, problem solve. Thanks you
I'm having this issue as well, but only if I want to shuffle my entire music library in Apple Music. I don't have a large collection - around 8,000 songs, but every time I hit shuffle all from my mobile device, I get the error. It works fine from my Mac. I'm iOS10 and have 6.4.1 for iPhone.
Userlevel 7
Badge +20
Can I just clarify one thing with you, when you add all 8000 tracks to the queue, then shuffle, it presents error 1002? Can you also please submit a diagnostic and respond here with the confirmation number? Thank you.
Badge
Hi. I am having exactly the sam problem as Kenailes with roughly the same number tracks to add to shuffle from my Apple Music. I have submitted a diagnostic 6563719. I would be grateful for your help.
Userlevel 7
Badge +20
Sure, no problem. Thanks for the diagnostic, it would appear that there is interference present on your system. Can you try changing your router's channel to 11, or 1? One of these should remedy the fault. Also, please ensure that your devices are 1-2 feet away from anything else electronic or wireless enabled. This could also be causing the interference.
I also having similar issues. Have two speakers
Diagnostic #6566808
Reboots wifi HT mode on and off, changing channels, turning off one and moving the other closer to the wifi AP
Other apps using shares can see the computer fine.
Signal says excellent.
Good through put on file xfers.
can play songs from other computers that connect to a share.
Nothing is as close as 1-2 feet from AP but not further from than 20-50 ft.
Badge
Hi Edward R. I have changed the router from channel 11 to channel 1 and it still doesn't work. Any more advice??
Can I just clarify one thing with you, when you add all 8000 tracks to the queue, then shuffle, it presents error 1002? Can you also please submit a diagnostic and respond here with the confirmation number? Thank you.


Edward, diagnostics ID is 6600993. And yes, you are correct with one clarification. I don't even add all tracks to the queue I just hit shuffle all, and it spins for awhile, and then gives me error 1002. today it is occurring on both my MacBook as well as my iPhone 6s+ running iOS 10 and the latest Sonos software and firmware.
Userlevel 7
Badge +20
I also having similar issues. Have two speakers
Diagnostic #6566808
Reboots wifi HT mode on and off, changing channels, turning off one and moving the other closer to the wifi AP
Other apps using shares can see the computer fine.
Signal says excellent.
Good through put on file xfers.
can play songs from other computers that connect to a share.
Nothing is as close as 1-2 feet from AP but not further from than 20-50 ft.


The diagnostics suggested there might be a firewall blocking the sharing from taking place. Also, please ensure that you are on a "Private" and not "Public" network within the network and sharing centre. Can you check this and report back?

Hi Edward R. I have changed the router from channel 11 to channel 1 and it still doesn't work. Any more advice??

Sure, can you please submit a fresh diagnostic so I can best advise? Thank you!

Edward, diagnostics ID is 6600993. And yes, you are correct with one clarification. I don't even add all tracks to the queue I just hit shuffle all, and it spins for awhile, and then gives me error 1002. today it is occurring on both my MacBook as well as my iPhone 6s+ running iOS 10 and the latest Sonos software and firmware.

Thanks for getting back to me. I think the problem might be being caused by network congestion. You could try changing your router's channel. Not only are we reliant on a solid connection between Sonos and your router but your Mac needs to have a strong, reliable connection to the router as well. Is the Mac cabled or wireless? If it is cabled, you may wish to wire a Sonos component to the router as a test. Please let me know your thoughts. Thanks!
Hi, I'm having problems with the controller on my mac book, it won't let me do anything i keep getting (error 1002) for everything; updating music library, adding tracks to queue, ect. My diagnostic number is: 6627777. I have checked that no firewall is blocking it, but still no luck. Please may I have some help, Thanks!
also error 1002. freshly setup play 1 only 2 feet from my airport extreme. windows 10 pc wired connection and latest sonos app on iOS 10.0.2.

followed firewall help page and still no difference.

diagnostic submitted - 6630614
also error 1002. freshly setup play 1 only 2 feet from my airport extreme. windows 10 pc wired connection and latest sonos app on iOS 10.0.2.

followed firewall help page and still no difference.

diagnostic submitted - 6630614


EDIT:

it seems i can easily play anything i search for on Apple Music just not the contents of my own library. this is a pain when trying to play my playlists.
Userlevel 4
Badge +3
Hi gg89_, welcome to the community. We've seen some other people with similar issues over the past few days. You can join in the conversation here. Try the steps outlined in that post to remove the service, toggle the iCloud setting, and add Apple Music back in. This has helped for some people, but not everyone. If you continue to get the problem, reply there with a new diagnostic number.
Hi gg89_, welcome to the community. We've seen some other people with similar issues over the past few days. You can join in the conversation here. Try the steps outlined in that post to remove the service, toggle the iCloud setting, and add Apple Music back in. This has helped for some people, but not everyone. If you continue to get the problem, reply there with a new diagnostic number.

reluctantly did this as it resulted in me losing ALL my downloaded music and I am still having the same issue.

Your confirmation number is: 6632513.