Answered

An error occurred while adding songs to the queue (701)

  • 30 November 2017
  • 70 replies
  • 69719 views

Userlevel 1
I can't play all my songs an error says "An error occurred while adding songs to the queue (701)" How do i fix it?
icon

Best answer by Keith N 3 April 2018, 22:15

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

70 replies

Have you tried connecting the PLAY:3 to your router with an ethernet cable? That might allow you to update it, along with submitting a diagnostic.
Userlevel 7
Badge +20
Thanks for following up, Adam. I would recommend following Bruce's advice and failing that, I think it might be best that you get in touch with our support team via telephone. This way they can walk you through some troubleshooting steps to get back up and running.
Having experienced the same issue with just one play:3 connected directly to the router (boost and all other Sonos unplugged) I will have to contact the support team via phone.
Interesting. Would you be so kind as to post back here with the solution, so that others who are having a similar issue can learn from your experience? While I don't have an issue, I would be interested in understanding how it can be resolved.

Thanks!
I am also receiving error 701. This happens when I try to play Spotify songs. On the Sonos app, I go to Browse > Spotify > Your Music > Songs > Shuffle All. I have a few thousand songs. When I play a playlist this doesn't happen. I have two Sonos 1 speakers. I have a diagnostic number: 327504241
SOLVED (for me anyway). I recently started having this same issue. I would get the error 701 - could not be added to queue. This only happened on Amazon and iTunes music. I have two playbar, sub, and surround systems. Both systems had the 701 issue.

I tried a factory reset on one system- no luck. I removed the music services and added them back - no luck. I removed my Philips hue (because I saw a post that it created interference) - no luck. Could not support diagnostic through app. Removed app, reinstalled it - no luck. Finally, on a complete whim I plugged an ethernet cable from the playbar on one system into a wireless access point that is next to it. At first that system completely disappeared from my Sonos app, then suddenly reappeared. I tried the Amazon and iTunes and they miraculously worked - on BOTH systems. Go figure.

I guess the lesson here, is continue to think of every possible scenario and when you are finally in complete desperation try the most illogical solution you can think of. It makes no sense, unless the fact the wireless access point was providing interference. But if that is true, why all of a sudden did it stop working after six months? Like I said, illogical but solved.
Userlevel 7
Badge +19
Hello everyone. Thanks for keeping the conversation going. In most cases, a 701 error points to a general connectivity problem. Normally, this will take a bit of troubleshooting regarding the network configuration and how Sonos is integrated. Submitting a diagnostic report can be helpful for the moderators to take a quick look and advise on next steps.

Alternatively, if you are looking for a more immediate method of troubleshooting, I'd recommend giving our support technicians a call to troubleshoot this in real time. They can set up a remote session and get a closer look at how data is being routed along the network.
System worked fine for 4 years then all of a sudden 3 months ago, I started having all sorts of problems, Eventually had to reboot modem wifi daily to get sonos to work, then about a week ago, our iPhone's just cannot find sonos at all. I can still find it on my imac, but I can't play any music because sonos on my imac won't connect to Pandora or any other streaming service, despite my deleting them and re-adding them multiple times. Getting error 701, etc. I bought a boost and plugged that in directly to ethernet cable and reconnected my sonos speakers through that in case it was wireless interference. I replaced my modem in case that was getting flaky. Still not connecting. So frustrated! Prior to that, NOTHING changed in the system to make it go from great to not working except sonos software updates. Can't even submit a diagnostic, because sonos on my imac says it can't submit one, "try again later". Wifi is working fine. I can connect to internet just fine. All my other wireless products are working just fine. SOnos is an expensive paperweight. Sonos, what did you do to mess this up so bad?!?!?!? My system was working perfectly! Now I'm ready to throw it all in the trash & use bluetooth speakers.
Same here I cannot even play files from my drives- My music wont add to que I get error 701 or I get Queue is full when there is nothing in the queue I was an early adopter for many years this Sonos was reliable now I cant even play a single song- useless paperweights and speakers.
I also have error 701. My diagnostic was sent under ID 1442836576
Userlevel 7
Badge +19
Hi, everyone! If you are having problems with this, please submit a diagnostic report and I will be happy to take a closer look. Be sure to reply with the confirmation number it gives at the end. Thanks!

Hello there, boernard. Thanks for posting and welcome to the Community. According to the diagnostic report you submitted, it seems that the PLAY:1 is having a hard time receiving a wireless signal from the network. The report only shows a few moments of data. If you plug the PLAY:1 into the router using an Ethernet cable, do the issues persist?
Don’t know if this helps but I was having this problem and I updated my music library and that fixed it. Hope this helps
Hey there,

I just started having this issue with all of our Sonos systems. Having read this thread, I submitted diagnostics (1502828547) and would really like some help.

This is only occurring with Amazon Music, which is really the only service we use. I have removed the service, reinstalled the app on my phone and restarted the main router - no dice.

Assistance please!!

Many thanks, D!!
Yesterday experienced for the fist time the inability to play any songs from my NAS, couldn't add anything to the queue. Followed the standard practice of shutting everything off (power off at wall) being the Bridge + 2 x Play3 and 2 x Play5. This morning my Sonos is now displaying the 'Unable to add songs to the Queue'. When I tried to add an entire album via the Play All, drop down, 'Add to end of queue' it displays the 'Unable to add songs to the Queue'. But I can add the same songs to the queue individually and they play. After a bit more stuffing about, it appears to be only related to adding albums. For info, works OK from a music service. PS, it still annoyingly skips songs in the queue when it works. H
I had the same issue with amazon playlist. I found a workaround for now. I simply “downloaded” the amazon playlist to a Sonos playlist and no issues. Furthermore, Sonos is a speaker company with very good commercial grade sound and convenience, they are not a technology company.
I get a 701 when trying to add songs to a queue or playlist, but if I play the song now from my music library it plays to the system. Diagnostic info # 1111582 thank you!
Badge
I’m also getting this error 701 & cannot play any music on my NAS
I'm very sorry to say this but I'm seriously thinking on returning my Sonos ONE because I can't find the solution to the Error 701. It works fine with TuneIn but it doesn't when I try to reproduce a theme from y NAS (QNAP). It has happened suddenly because just after configuring the device (after unpacking it) this morning it worked pretty well. It even reproduce my music when it is controlled with a different DLNA controller (HIFI Cast). So I understand that it is a sw error inside the Sonos because it was not fixed when I reinstall the Sonos app.
Hi everyone. New Sonos user that had the same issue but found a workaround. Whenever I used Spotify or Napster I would get the error "An error occurred while adding songs to Queue (701)". Pandora worked fine. Please note I was doing a completely WIRELESS set up when getting this error. Everything worked fine over Airplay 2 but not with the Sonos App which would push that error.

The 1st workaround was to plug in one of the 4 Sonos One's I had directly to my router. That fixed the problem immediately. However, I didn't want to have a Sonos One in the room where my router was and today I picked up a Sonos Boost and plugged that in. The Boost had the same effect so now I could move that other speaker somewhere else wirelessly.

I know not ideal but if your problem can be solved by plugging a unit into the router (hard wired via ethernet) and it fixes it you know you have the option to add a boost.

I am running a Pace Wifi router from AT&T Uverse but I use a Netgear X4S in AP mode for my wireless. I guess there are some known issues with the Pace wifi router...

Hope that helps some of you all!
Badge
I've been looking at ways to stream WAV's stored on my PC via the Sonos desktop controller. The way I wanted to make this happen easily was from the controller itself, i.e. Select Music Source > Windows Media > Folders. However, whenever I try this, I too get the dreaded error 701 (which brought me to this thread) and the track/s can't be added to the queue. If I try the same with an MP3 however, it works perfectly. Go figure! I've messed around with VLC and apps such as 'Stream What You Hear' but VLC isn't that straightforward and with SWYH it didn't sound that great.

I have now simply settled on right clicking the WAV/WAVs I wish to play in my folders and in my case, selecting "cast to device > Sonos Connect". If you want to add a bunch of files such as a whole album, just "select all" and do the same thing. This brings up the small 'Cast To Device' window. When you have all the files there that you wish to hear, just press the play button at the bottom of the window. Then go to the Sonos Controller and you will see that 'Line-In' is now playing as the current 'room'. You can then use the controller to add any other rooms to the 'Line-In' group. For those who don't have a Connect or Amp, I've just tried casting to an individual speaker and this works too. However, if you are running a stereo pairs/5.1 set up in multiple rooms, I guess you need a Sonos Connect or Amp.

In my case I only wanted this functionality so that I can to play music that I have stored on my PC which is not available in Amazon Music Unlimited (the service I use). I did upload all of my own music to Amazon Music but they have recently pulled that service, hence my desire to play from the PC.

Back to the 701 error and being able to play MP3's but not Wav's via the controller, I have no clue! Regardless, I hope this helps some folks out there.