Amazon Music Unlimited Stations Won't Play


Badge
I'm having a problem with Amazon music unlimited, specifically that I can't start any of the stations, everything else, songs, playlists, albums etc.. are fine.

I just get an error message and see this in the logs.

Thursday, May 17, 2018 - 6:36 AM Greenwich Mean Time : Dublin, London
Requested operation failed. Please try again.


I've submitted a diagnostic - 934645539

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

I have exactly the same problem.
I've been getting the error on and off for several days but now it seems I can't play anything via amazon
Badge
I've finally found the fairly well hidden option for submitting a support request and have done so.

Will reply back this thread if I get an update.
You need to either post the number here, or call in to Sonos with the number. I don’t believe they respond to submissions without context.
Or, I could scroll up and see that you have. My apologies.

The weekend coverage on the boards tends to be sparse, at times, and the phones are only manned M-F. You may want to try the 24/7 twitter support option, and I think they have a FaceBook messenger support 24/7 as well.
Have you had an update on this @abfielder?

I am having the same issue with Amazon Stations. Playlists etc are fine but stations fail with the error:

"Requested operation failed. Please try again."

I have also submitted diagnostics with the ID: 650362538

John
I am having this issue as well. Any ideas on what is causing it!??
Same issue here. It was fine until 22:00 / 23:00 last night.
Diagnostics submitted - ID: 1805358809
Im also having the exact same thing happen to me.

Have submitted a diagnostics report: 94788445
Hi all. I am having the same issue and it seemed to start about the same time as the first post (about 2 weeks ago). Sonos say it may be a weak wifi connection BUT everything else on Amazon works fine (artists, bands, playlists etc) it is just the stations that don't. Interestingly the stations functionality works perfectly from the Echo Dot using the same wifi connection. The issue seems to be the Sonos Controller on Android that was working fine but now doesn't. I have submitted diagnostics to SONOS but haven't heard back yet. Case #: 00077557. The fact that all the posts regarding the issue have started very recently points to a glitch with a software update perhaps?

Same issue for me on my iPhone and iPad. No amount of rebooting, resetting is making a difference ?
Good news I think..... Sonos techical dept say they are aware of the problem with specific Amazon Accounts. I have supplied my Amazon account name (but not password obviously!) and they say they are sorting it. Still not working as of yet but I am cautiously optimistic. Will update when the issue is resolved.
Hi All. I think it is a thumbs up for SONOS as it seems to be sorted. Didn't hear from them as yet but I can now play stations again despite the same error message popping up occasionally and briefly. Anyone else got the STATION functionality back?
Agreed, thumbs up to Sonos for sorting this. 😃