All speakers except the wired one have dropped from the system



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Badge
I just checked again - 2.4GHz wi-fi is completely disabled, which means it's odd there is interference. Sonos should have the network all by itself. I just toggled through all available channels in Sonos, no change. I'm at a loss.....
Badge
I remembered I have a Wi-Fi extender that's used as an access point, hidden behind the TV. In order to find the culprit, I unplugged the thing - I did another diagnostics 7426499. Could you check on the interference, is there a change for the better, by any chance? (two of my Play1's are unplugged, just fyi, but all others are online - for now)
Remove the wifi credentials so the components will only be able to communicate through the wired player.

Sonos > Preferences > Advanced Settings > Wireless Setup > next > next > Reset
Badge
OK, just reset the wireless setup.
Badge
Still the same: speakers get lots, re-adding them yields confusing things like mixed-up room names, and paired speakers are labeled, for instance, "Living Room (L+?+SUB)". All the changes I did to my Wi-Fi setup (IP reservation, removal of all 2.4GHz devices, even throttling down the 5GHz radio) yielded no change whatsoever. I'm kinda glad this is happening to me and not, for example, my parents, because the nice thing about Sonos is that you *don't* have to deal with this sort of stuff, I thought. Try explaining IP reservation to someone who is not a nerd.... ;)
I really wish we could get to the bottom of this. It *used* to work, until some sort of thing got into the brains of those devices.
Userlevel 4
Badge +3
Hi there, on your last diagnostic we can see some evidence of multicast flooding. This means that another device on the network is sending data addressed to everything at the same time. This data gets to the wired PLAY:5 which then is forced to broadcast it to all Sonos players (as they are part of the network as well) even though the data itself is irrelevant to Sonos. If the PLAY:5 is wired to an un-managed switch such as a 4-port or 8-port, please connect it instead directly to the router. If it's already connected to the router or possibly a managed switch, please enable 'IGMP Snooping' on that.
Badge
Sonos is connected directly to the router. I do have IPTV though. I enabled IGMP snooping, and it has been working fine for about six hours now (to be fair, it was working earlier this morning, too, but who knows how long that would have lasted). I'll keep testing and will be posting progress. Thanks for the good advice!
Badge
It's been working fine since a day and a half, so it's safe to say it has been fixed. Not sure what exactly fixed it, but IGMP snooping definitely helped (my IPTV at home might flood the devices, apparently). Also, reserving Its was not a bad idea, i'd wager. Anyway, learned a few things along the way - thanks for everyone's help!
Badge +1
Glad to hear that the system is running again. Don't hesitate to reach out if you notice any new symptoms or have any questions.