Alexa controls Sonos just fine, but Sonos system not showing up in app

  • 12 April 2021
  • 1 reply
  • 13 views

Hello,

I have a Sonos Beam hooked up to my TV. I also like to play music on it using Alexa or Airplay from my iPhone. But lately, I’ve had a strange issue where the Sonos randomly stops showing up in the AirPlay menu, and the Sonos app on my phone can’t find the system either. However, the system is still completely working and connected to the Internet, as I can play music with Alexa just fine. So it’s not a matter of the system losing its internet connection; it’s just that my phone can’t seem to find it anymore.

Last time this happened, completely restarting all my devices and my router solved the issue. (Restarting the phone, on its own, doesn’t help.) However, it’s happened a couple more times since then and I really don’t want to have to go through the hassle of restarting everything every few days, so I’d like to get to the bottom of what’s actually causing this. I assume it’s something to do with my router, but I haven’t actually changed any settings on my router in months, so I’m not sure how that could be the issue.

Any thoughts? Thanks!


1 reply

Userlevel 7

 Check your router’s admin page for updates? That may be the issue. if not you may be experiencing WiFi inference. In that case try changing the channel of your Sonos.

Another option is to wire a speaker to your router to establish the SonosNet to isolate Sonos from your home WiFi. If wiring a speaker is not convenient you might purchase the Sonos Boot module to connect it to your router to setup the SonosNet

Reply