Answered

Album tracks out of order

  • 15 November 2017
  • 7 replies
  • 792 views

Userlevel 2
Badge
I have one album where I initially scanned in the last track to Sonos first, and then later scanned the entire album. The result is that the track order that appears in Sonos is out of order: track 12 appears first, then 1, 2, 3, .... The track field is correct. I've tried deleting the entire album from my library, rescanning Sonos to remove the album, then re-adding the entire album again, but the track order is the same. If I tell Sonos to play the album, it starts with the last track.
icon

Best answer by Stuart_W 15 November 2017, 17:29

Make sure the Album name is EXACTLY the same on all those tracks. Make sure that each of those tracks has the # of tracks (ie 12) filled in. You can make those changes in iTunes
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Badge
is this from iTunes, if yes i had the same problem and can try to help
Userlevel 7
Badge +21
Make sure the Album name is EXACTLY the same on all those tracks. Make sure that each of those tracks has the # of tracks (ie 12) filled in. You can make those changes in iTunes
Userlevel 2
Badge
I'll check. They were originally imported with itunes but I don't think I still have the music library. I'll import them to itunes to check those fields.
Badge
what i did to resolve the issue with incorrect order was delete complete album and then hide the album from iTunes ,manage sonos and then unhide album with iTunes in acount settings and then re download the full album this worked for me with 6 previous albums what was not in order
Userlevel 2
Badge
Stuart_W you were on to something. The Album name and # of tracks were fine, but the last track did not have the "Album _ of _" field filled in. I set it to "1 of 1" like the rest of the tracks, and now it's in the correct order. Thanks!
Never mind. I had a problem but I I figured it out...
Perhaps if you were to share both the issue, and your resolution, it might help others who happen upon this thread?