Answered

AirPlay: unable to connect Sonos One

  • 14 November 2021
  • 7 replies
  • 175 views

Hello,

I have recently bought Sonos One speaker (Sonos OS: S2; Version 13.3) and successfully set it up. I can play music for example from Sonos Radio or Spotify and everything works as expected.

But when trying to use AirPlay on different devices (iPhone XR / iPhone 6s / Mac Air) although I am able to see Sonos speakers in the list of available, I keep constantly receiving “Unable to connect to Sonos One” message.

I have already gone through various suggested in this case steps found here in Sonos community (Reset, Restart, etc) but all of them don’t work for me. 

Could you please help?

icon

Best answer by controlav 15 November 2021, 22:30

View original

7 replies

Userlevel 7

Have you tried unplugging the One from power for a couple of minutes and rebooting your router and phone?

Yes, I tried this. It did not work out...

Userlevel 7

If you move the speaker to a different location, does it make a difference? What model router are you using?

Moving speaker to a different location doesn’t bring anything. The router model I am using is FRITZ!Box 7520.

Userlevel 7
Badge +22

You sure its a One and not a Play:1? They look similar, but the Play:1 cannot do AirPlay.

Userlevel 7
Badge +22

Fritzbox looks network-challenged regarding multicast. See https://fvdm.com/code/tweak-fritzbox-for-airplay-across-ethernet-and-wifi

Userlevel 3
Badge +5

That’s a good idea and i hope it works.  But wouldn’t the multicast dropped packets cause the *mDNS* to fail too -- yet discovery worked (selecting the output device) -- just the streaming part failed?  Who knows, maybe there are exceptions (like DNS!) to dropping Ethernet<->Wi-Fi multicast packets, so definitely worth a try.  Another resource to read: https://weberblog.net/apple-airplay-capture/ -- the author just happens to also use the AVM FRITZ!Box router, but doesn’t seem to be having that trouble.

For the elimination of confusion, even though this is an unlikely novice error, *and* it fixes itself eventually: Note that there is some time-out on AirPlay streams.  For example, if you are playing from the iTunes or Music application on a Mac, and you press pause, then pick up your iPhone and start the Spotify app playing via AirPlay, you will get the “Unable to connect” message until the Mac times out or you choose a different AirPlay destination.  (Vice versa is also true, but one sometimes gets no error message on the Mac, just nothing happens!?!  This lockout is most annoying when using Apple’s “iTunes Remote” app on the iPhone, because it all *feels* like you’re doing everything on the same device, even though you aren’t.)

Reply