Answered

Airplay stops working on my sonos roam after one or 2 seconds

  • 9 October 2021
  • 3 replies
  • 31 views

I bought a Sonos Roam. When I start playing via Airplay the speaker is mute after one or 2 seconds. Then it doesn't work. The issue occurs when I stream from iPhone, iPad or Mac mini. My router is Linksys E3200. 

When I stream from iPhone or iPad to Apple TV everything is fine, but I cannot stream to Sonos speaker. 

All operating systems and Sonos firmware are up to date. I can play via Bluetooth but I would prefer airplay, which is more convenient to use. 

Any suggestions or tips?

Mike

icon

Best answer by Airgetlam 9 October 2021, 18:36

View original

3 replies

Honestly, I’d try a power down reboot of all devices….the Sonos, the router, and the iOS devices. If that didn’t fix it, I’d start looking for potential sources of  wifi interference , although that has a much less chance of being the issue here. 

At the end of the day, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it. With the caveat, of course, that as you’re trying to use AirPlay 2, there’s much less of the signal path involved in the Sonos world, so what they’ll be able to ‘see’ will be substantially less. 

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Thank you for your tips Bruce.

Setting routers 2,4GHz channel to 6 (instead “Auto”) seems to have solved the issue. I will monitor this for few more days. 

Mike

Having Sonos (and AirPlay 2) constantly chasing the “latest” wifi channel is never good. :)

Reply