Answered

Airplay password prompt

  • 26 October 2021
  • 8 replies
  • 138 views

Hi guys, after installing my new Apple TV and adding my Hue lights to my Apple Homekit (via the new Apple TV) I get a password promt when I try to Airplay music via Spotify to my Sonos system. 
 

I’ve checked the homekit settings; password’s off. 
 

I have 1 Beam and 2 One SL’s. What to do?

icon

Best answer by AjTrek1 27 October 2021, 02:54

View original

8 replies

Userlevel 7

Hi @Ihsotas 

Make sure “require password” is turned off in the HomeKit app on your iPhone at:

Home (icon) > Home Settings > Speakers & TV’s > Require Password > Slider is Grey (Off)

Make sure “require password” is turned off on your AppleTV at:

Settings > Airplay and HomeKit > Allow Access > Require Password > Off

If the above doesn’t work you’ll have to reset the offending Sonos speaker.

Seems odd, as there’s no place in the Sonos software that allows you to “require a password to function”. As AjTrek1 suggests, it’s likely to be a restriction imposed in the “Apple” ecosystem, and has nothing to do with the Sonos ecosystem at all. 

Edit: forgot to quote

Hi @Ihsotas 

Make sure “require password” is turned off in the HomeKit app on your iPhone at:

Home (icon) > Home Settings > Speakers & TV’s > Require Password > Slider is Grey (Off)

Make sure “require password” is turned off on your AppleTV at:

Settings > Airplay and HomeKit > Allow Access > Require Password > Off

If the above doesn’t work you’ll have to reset the offending Sonos speaker.

Thank you! Unfortunately this didn’t work, both were turned off. 
 

Regarding the reset. My living room setup has 2 One SL’s and 1 Beam. Which one to reset? Or all of them?

Userlevel 7

Hi @Ihsotas 

Make sure “require password” is turned off in the HomeKit app on your iPhone at:

Home (icon) > Home Settings > Speakers & TV’s > Require Password > Slider is Grey (Off)

Make sure “require password” is turned off on your AppleTV at:

Settings > Airplay and HomeKit > Allow Access > Require Password > Off

If the above doesn’t work you’ll have to reset the offending Sonos speaker.

Thank you! Unfortunately this didn’t work, both were turned off. 
 

Regarding the reset. My living room setup has 2 One SL’s and 1 Beam. Which one to reset? Or all of them?

You only need to reset the speaker that is requesting the Airplay2 password/code. 

Hi @Ihsotas 

Make sure “require password” is turned off in the HomeKit app on your iPhone at:

Home (icon) > Home Settings > Speakers & TV’s > Require Password > Slider is Grey (Off)

Make sure “require password” is turned off on your AppleTV at:

Settings > Airplay and HomeKit > Allow Access > Require Password > Off

If the above doesn’t work you’ll have to reset the offending Sonos speaker.

Thank you! Unfortunately this didn’t work, both were turned off. 
 

Regarding the reset. My living room setup has 2 One SL’s and 1 Beam. Which one to reset? Or all of them?

You only need to reset the speaker that is requesting the Airplay2 password/code. 

I don’t know tbh. They are all connected in ‘living room’ and that’s where I stream to. They all start playing. 

Userlevel 7

Sounds like you have the Beam and One’s setup as a home theater. The One’s I assume are used as surrounds?

If that is the case I suggest you first remove the One’s as surrounds in the Sonos app (for the room in question) and then disconnect the Beam from your TV.  Reset the Beam There should be no need to reset the One’s. After the reset setup the Beam to your TV and then add the One’s as surrounds. 

Sounds like you have the Beam and One’s setup as a home theater. The One’s I assume are used as surrounds?

If that is the case I suggest you first remove the One’s as surrounds in the Sonos app (for the room in question) and then disconnect the Beam from your TV.  Reset the Beam There should be no need to reset the One’s. After the reset setup the Beam to your TV and then add the One’s as surrounds. 

Update: did the reset thing like you explained. It worked! Thanks! 

Reply