Answered

Airplay Feature asks for onscreen code?



Show first post

43 replies

How do you add your sonos in the home app. Home doesn’t detect the beam. Is there some number somewhere?

Open the Apple Home app and tap "+" or Add Accessory.
Choose “Don’t Have a Code or Can’t Scan?”
Tap the speaker you want to add.
Pick the same room name used in the Sonos app.

https://support.sonos.com/s/article/1230?language=en
There was no number, and I can’t remember what I did to get it to appear, but it didn’t appear first time round. Most probably I switched everything off and on again.
Great it works but having 2 iPhone Become a requirement 😉
@mrrolly,

Me too... you have to be very very close of the sonos device. Not as close as when you try to connect with Bluetooth.... no very very close. iPhone kyte on the bar
Hi guys, hope you will be able to help. I never set any password for airplay, it just happened and I have no idea what to do. I tried resting home app, Sonos but it didn't help. I can't airplay from Apple TV or iPhone to Sonos speakers at all. Before I didn't have any problems at all. In home app it shows that all devices on same network will have speaker access. Any idea what to do ?
Do a factory reset of the speaker then add that speaker again like it’s a brand new speaker to you. That’s what worked for me.
It helped, thank you a lot
Userlevel 1
Badge
I don't get prompted for passwords using Airply2 from my iPad or iPhone but I'm unable to connect to the speakers using Air Parrot 2. It asks for a password. I even tried setting up a password using HOME but then when I enter the password in Air Parrot, it crashes. Has anyone gotten Airplay 2 streaming to work using a Windows PC as a source?
Userlevel 1
I hope this helps others. After a long bout of resetting, plugging in the sonos directly to routers etc. It seems that the password I was being prompted for was the one I set on my Apple TV on the same network. I entered that password and I was able to connect to the Sonos with no other issues.
Is airdrop switched on?

Just had the same issue arise and tried the help on this thread. In the end turned out airdrop wasn’t on. Once it was then Airplay worked.
Is there a verified fix for this issue yet?

I spent over an hour on the phone with Sonos support, Apple support, and my employer's technical support to no avail. I am not permitted to disable the "AirPlay outgoing requests pairing password enforced" restriction in Device Management.

Is there a way the Sonos app can tell us what the password is the the speaker is supposedly displaying "onscreen"?

This is a big disappointment with my new purchase.
[...] This is a big disappointment with my new purchase.
That's the downside of using a corporate phone for private purposes. Sonos/Apple are not allowed to circumvent restrictions determined by your employer.
To note, I figured out a solution that worked for me. I booted up my “old” iPhone, which was previously set up as my primary Home app source prior to getting the XS. From there, I deleted the Device Management that was still on that device, did a hard restart, and then added the Sonos speaker to my Home app there. I then turned my old phone off, did a restart of my current phone, and opened the Home app. The Sonos speaker is there and I am now able to airplay without issue.
Badge
For those of you who do have a business phone and a second device, there might be a way around the password. I believe if the Apple 'Home' was set up by the person with the restricted phone, the speakers will ask for a password. I used my girlfriend's phone (different Apple ID) to create a second 'Home' to which we could easily add the speakers. Then, in the Home settings in the top left, I could 'allow speaker access' for everyone in the network. If you enable the password, the code you see is what your other (business) phone is asking for. Once this was connected, I turned the password off again. I feel it takes slightly longer to connect, but works!

EDIT: So basically, if a person with a non-restricted device sets up the home, the person with the work phone can simply join and speakers can be added.


This worked me for me! Thank you, was pulling my hair out!!!! :0)
Not sure why the topic is marked solved. If I have an iPhone that is managed by my employer (which I do) and has the setting "'AirPlay outgoing requests pairing password enforced'" activated, then I haven't found a solution yet - not in this topic nor elsewhere.
One way to SOLVE the problem is for Sonos to implement functionality into the app for the Airplay2 capable devices by which an Airplay password can be set by the user. With that set, it can be entered when the prompt for the onscreen password appears, and Airplay streaming becomes possible. This is what Apple does/did e.g. with their Airport devices: As soon as I entered an Airplay password for an Airport Express, I was able to connect my "company-rigged" iPhone and stream via Airplay. Because Sonos doesn't offer the functionality to set an Airplay password, the "workaround" is not usable with Sonos.
Are Sonos working on this?
Will Sonos ever fix this? It's been over a year from the post and they've done nothing to solve it. Since it's many of us having this problem they should do something other than asking to give them a call.

I AM UPSET that the stupid speaker can't work.
I don't have a company managed phone, so don't even suggest that solution.
Okey i found a workaround. I added the sonos with my iPad that do not have restrictions as it is private.

Now the are added to my home. By enable password on speakers in the home app. The use the code from your device that is under management. The you have paired them and you should be able to airplay to sonos.

I disabled the password code again and it still works.


Yep, this works! so happy I found this post. Just to elaborate, here is what you do:

  1. Get or borrow a normal iphone or ipad (not managed by work)
  2. Download the apple “Home” App
  3. Connect to each sonos device using the home app.
  4. In the settings for that device (within the home app), turn on passcode and set it to something memorable.
  5. Now get your iphone or ipad (managed by work), launch the sonos app.
  6. Play some audio to each speaker and enter the new passcode when prompted.
  7. Now switch back to the other phone, in the home app turn passcode off for the devices.

At that point your work managed phone/ipad will remember your sonos speaker and no longer prompt you for a passcode…

Echoing others comments to sonos… Native support for passcodes should be enabled as an option. Its not realistic to continue to tell users to have thier work change thier backend policy. Plus it seems that many customers are asking for the option to password protect thier audio system for common sense reasons… get you s*** together sonos!

None of the devices being used have restrictions (business or otherwise), never had device management  installed on any of the iOS units yet magically after the Apple TV updates to v13 we are getting prompted for an AirPlay password for 2 of the 3 sonos speaker groups from any device trying to play to them. Everything was working fine before this password issue!  Note: only one sonos group is connected to the Apple TV. Second note: by group I mean a stereo pair or 5.1 setup  

- Verified the Home app speaker/tv password is not enabled on the Apple TV nor any of the iOS devices.

- Rebooted all devices

- Removed on of the sonos groups from Home app and tried to add it back. Can’t now without this mysterious password. 
 

Others mention resetting a sonos speaker. Well, I can’t believe this is required as this is pretty difficult for what we have with the groups and all. That would mean resetting an entire 5.1 setup plus IR controls after all the work dialing it in. Same for the stereo setups to a lesser degree. Thought here: what about allowing us to backup our configuration to the sonos cloud for easy restore!! 
 

Anyway, this clearly points to a deficiency in sonos’ implementation of airplay and after a year or so of customer complaints we would hope an official response / procedure / software fix would exist. 
 

sonos, if you’re monitoring these threads please respond with help. 

Reply