Answered

Airplay Feature asks for onscreen code?


Just updated to V9. Tried running Netflix and other apps then clicking Airplay, Select my Sonos One, then prompted for an onscreen code. Not sure where to get this as I’m not Airplaying to a TV where this is normally displayed. Can anyone assist please?
icon

Best answer by sluncefo 12 July 2018, 15:58

Aimee711p wrote:

I kept getting prompted for an Airplay Code. This is only happening on my iPhone not my iPad. Both are running 11.4.1.



Hi, Aimee711p, was your iPhone issued by an employer's IT dept? (That's the situation with me.) I wonder if these settings are the same for both your iPad and iPhone:

Settings > General > Device Management > Device Manager > Restrictions > "AirPlay outgoing requests pairing password enforced"

View original

29 replies

Userlevel 7
Badge +3
Hi Tonestar, if you're seeing this message it'd be best to give us a call on our support line. We're looking into this to get some more details on what's causing this message to come up.

Thanks!
I have this same problem. It was working fine, but then I renamed the room and it started asking for a code
Help! I’m unable to connect to my Sonos one speaker using airplay 2. I kept getting prompted for an Airplay Code. This is only happening on my iPhone not my iPad. Both are running 11.4.1. I’ve uninstalled the Sonos app and reinstalled it and restarted my iPhone multiple times. Still get the airplay code prompt. Any ideas on what else to do?
Hi, Tonestar and JKFisher... I'm curious if you see the following restriction when you go to Settings > General > Device Management > Device Manager > Restrictions > "AirPlay outgoing requests pairing password enforced" (if you're on an iOS device).

I have a work-issued phone and tried to stream from iTunes/Airplay 2 to my Sonos One and had the same issue. Wondering if this could be the culprit.
Hi, I think this an issue in the Home app. Try going to Home App>tap Home in bottom left corner>tap house icon in upper left>Scroll down to allow speaker access>Change require password setting
I’m in the same boat - I’ve never had any other issues connecting to Airplay devices - any help would be greatly appreciated!
Aimee711p wrote:

I kept getting prompted for an Airplay Code. This is only happening on my iPhone not my iPad. Both are running 11.4.1.



Hi, Aimee711p, was your iPhone issued by an employer's IT dept? (That's the situation with me.) I wonder if these settings are the same for both your iPad and iPhone:

Settings > General > Device Management > Device Manager > Restrictions > "AirPlay outgoing requests pairing password enforced"
sluncefo wrote:

Aimee711p wrote:

I kept getting prompted for an Airplay Code. This is only happening on my iPhone not my iPad. Both are running 11.4.1.



Hi, Aimee711p, was your iPhone issued by an employer's IT dept? (That's the situation with me.) I wonder if these settings are the same for both your iPad and iPhone:

Settings > General > Device Management > Device Manager > Restrictions > "AirPlay outgoing requests pairing password enforced"



Hi sluncefo - my device wasn’t issued by my organization but our official email app that will be retired shortly DOES have a Mobile Device Managment profile installed. I uninstalled it earlier this morning to test and sure enough the airplay code message disappeared. For me this did the trick - thank you for sharing!
I have the same problem. My iPhone has also the mentioned restriction "Airplay outgoing requests pairing password enforced". Would be interesting to know if all users with a company device have this problem (seems so...)
I just got my first Sonos once it finally supported AirPlay 2, and while I was setting it up, I saw this same screen. I just pressed OK, then selected the Sonos as a speaker again, and it worked.
I just updated the app and am trying to get AirPlay to work. When I select my Play:3 though I keep getting a message to enter the AirPlay code (4 digit number). I tried this on both a company-issued phone as well as a private phone and both but both produce the same result.
Userlevel 7
Badge +3
We're looking into this one those steps above seem to be doing the trick where we've seen this issue. Tunnie, if you're still getting a code request, please check again that you have 'AirPlay outgoing requests pairing password enforced' toggle setting disabled? This setting is usually part of a Device Management (MDM) profile that is added to and configured on iPhones and iPads. Again, this is accessible by going to Settings > General > Device Management > Profile Name. It's generally used on iOS devices that are part of a corporate environment.

Disabling just that setting in the profile should allow you to use AirPlay to the Sonos player without a password prompt.

Let us how it goes.
I’m having the same issue. Only one speaker in the house isn’t asking for Airplay password. I don’t have a business based iPhone.
I test the use of Airparrot 2.7.5 64-bit on a Windows 10 PC to play music through Airplay.
In this way I am also asked to enter a password.

Badge
Ryan S wrote:

Hi Tonestar, if you're seeing this message it'd be best to give us a call on our support line. We're looking into this to get some more details on what's causing this message to come up.

Thanks!



Ryan do you still need more information?
Same issue attempted to use airparrot and airfoil and both are asking for password
For those of you who do have a business phone and a second device, there might be a way around the password. I believe if the Apple 'Home' was set up by the person with the restricted phone, the speakers will ask for a password. I used my girlfriend's phone (different Apple ID) to create a second 'Home' to which we could easily add the speakers. Then, in the Home settings in the top left, I could 'allow speaker access' for everyone in the network. If you enable the password, the code you see is what your other (business) phone is asking for. Once this was connected, I turned the password off again. I feel it takes slightly longer to connect, but works!

EDIT: So basically, if a person with a non-restricted device sets up the home, the person with the work phone can simply join and speakers can be added.
Badge
I got it to work just using the same Apple ID on a device without management profile on. But it seems still to have issues airplay from a device under management. - So if you create a new home you can airplay from the device with restrictions on?
Badge
Okey i found a workaround. I added the sonos with my iPad that do not have restrictions as it is private.

Now the are added to my home. By enable password on speakers in the home app. The use the code from your device that is under management. The you have paired them and you should be able to airplay to sonos.

I disabled the password code again and it still works.
cmachiels wrote:

I test the use of Airparrot 2.7.5 64-bit on a Windows 10 PC to play music through Airplay.
In this way I am also asked to enter a password.



I have the same problem connecting from my PC using AirParrot 2. I raised a ticket with the vendor and they are still trying to figure out the problem. They think it’s with Sonos.
One2sojourn wrote:

cmachiels wrote:

I test the use of Airparrot 2.7.5 64-bit on a Windows 10 PC to play music through Airplay.
In this way I am also asked to enter a password.



I have the same problem connecting from my PC using AirParrot 2. I raised a ticket with the vendor and they are still trying to figure out the problem. They think it’s with Sonos.



+1 with the same problem using AirParrot2.
Keezppc wrote:

Hi, I think this an issue in the Home app. Try going to Home App>tap Home in bottom left corner>tap house icon in upper left>Scroll down to allow speaker access>Change require password setting

This worked for me - I added the sonos to the app and it worked
Hello,
Is there an official solution for that issue. Of course my it department doesn’t care of my sonos Beam ;).

Need to get the password. Through tv or other device.

Please.
I fixed this by adding the sonos to the desktop in the home app on my iPad/iPhone
How do you add your sonos in the home app. Home doesn’t detect the beam. Is there some number somewhere?

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings