Answered

Adding second Symfonisk bookshelf to existing SonosNet created from another Symfonisk

  • 15 February 2021
  • 12 replies
  • 114 views

Badge +1

Hello everyone and thanks for reading.

I had a Symfonisk bookshelf and always had problem using it under wifi because my router can’t handle very well traffic from one band to another (I have the 2.4Ghz and 5Ghz network separated and when I try to airplay from a device on 5Ghz network it won't work, but works better when the device is on the 2.4Ghz as the speaker). I managed to fix it by wiring the speaker to the router with the ethernet cable and everything works flawlessly. 

Now I’ve bought another Symfonisk speaker to be used in the kid’s room, and I want to add it to the SonosNet created by the first Symfonisk unit. I can see that the first speaker is on that network because in the About my system is reported as wm0.

The problem is that when I try to add the second speaker it prompt me to add the wifi credential, and after the process is complete the speaker use that network instead of the SonosNet (in the about section is reported as wm1). I’ve tried several times, I’ve waited all night and check the next morning but it’s still on the wifi. I’ve tried to reset the speaker and re-add it several times with no difference. 

If I plug the speaker on the same router with the ethernet cable it disappear from the system, and can’t be no longer accessible unless I reset it and add it again as new.

If I try to add it while on ethernet the process find it during the setup but at the end it says that needs to be rebooted to show on My System tab because it might not appear. Rebooting, disconnecting from ethernet never made it show. The only solution is to reset it and re-add it with wifi.

Am I doing something wrong? What else can I try?

 

Thanks in advance for your support and for having the patience of reading such a long post.

Simone

icon

Best answer by Xander P 16 February 2021, 12:16

Understood @macshodan, mind letting us know the make/model of router you’re using?

Are there any wireless extenders or mesh devices in use? Depending on the network hardware, there may be some changes required on the settings.

For more in depth troubleshooting, you’re always welcome to reach out to the Support Team via either chat or telephone - they’ll be able to take diagnostics of the system to take a closer look.

View original

12 replies

Badge +1

Update:

Last night I’ve tried again to address the issue, but still can’t get the second speaker to connect to SonosNet. 

I’ve removed the power cord from the first speaker, the one connected to the router with ethernet cable, and set up the second one connecting it with another ethernet cable to the router. The Add Speaker process went on smoothly, and the Sonos App showed my new speaker in the System tab, confirming it was in SonosNet mode (wm0). 

Then I’ve reconnected the power cord to the first speaker, which was still connected with the ethernet cable to the router. The Sonos App couldn’t see the speaker, while Airplay could, and steaming was working fine from my Mac or my iPhone both connected to the 5Ghz wifi network. But, the speaker was nowhere to be seen in the Sonos App.

As soon as I removed the ethernet cable from the second speaker, the first one showed in the Sonos App, and the second one switched to wifi (wm1). While on this setup I could still play music over airplay from the iPhone or the Mac while both system still on 5Ghz network. My other devices though, the AppleTV 4K and the iPad Pro 1st Gen can’t airplay to the second speaker while being on the 5Ghz wifi :(

I’ve then moved the second speaker to the kid’s room, where is supposed to be, on the first floor, waited few hours, but it’s still connected to the wifi network and not to the SonosNet. I still can airplay from the iPhone and the Mac while on 5Ghz wifi, but can’t from the other devices unless I manually switch them to be on the 2.4Ghz :(

How come the second speaker can’t connect to the SonosNet?

While testing various setup I’ve also tried to disconnect the ethernet cable from the first speaker and see if it will use the SonosNet created from the second one, but again that speaker would use the wifi.

Userlevel 4
Badge +11

Hi @macshodan, thanks for reaching out to the Sonos Community!

It almost sounds like you’ve set up two separate systems, however taking a look at your account shows both Symfonisk speakers set up as a single system. 

There are a few reasons that the second speaker may not be connecting to SonosNet - are there any other wireless devices very close to the wired speaker? How far are the wired and wireless speaker from each-other?

It may also help to cycle between the different SonosNet channels, by going to Settings > System > Network > SonosNet Channel, and cycling between channels 1, 6, and 11 - I’d recommend waiting a minute or so between each channel change.

Badge +1

Hi @Xander P , thanks for your reply!

Well, the first speaker is in the living room media cabinet, with the TV, the AppleTV, the PS4, the SkyBox and the Nintendo Switch. All those equipment are using an ethernet connection, except from the the Nintendo Switch and the AppleTV. 

The second speaker location is upstairs in the kid’s room, but during the various setup attempt I've placed in the living room, so I could try to attach it to the router. 

I’ve tried to change the SonosNet channels as well as the Wifi 2.4Ghz channels, now the SonosNet is on channel 11 while the Wifi in on Channel 2. 

The most strangest thing is that when I try to use the ethernet on both devices simultaneously the second one is never seen by the Sonos app 😩

I’ve spent at least 4 hours in the last two days trying different configurations and setup processes… :(

Userlevel 4
Badge +11

Understood @macshodan, mind letting us know the make/model of router you’re using?

Are there any wireless extenders or mesh devices in use? Depending on the network hardware, there may be some changes required on the settings.

For more in depth troubleshooting, you’re always welcome to reach out to the Support Team via either chat or telephone - they’ll be able to take diagnostics of the system to take a closer look.

Badge +1

@Xander P sure of course. I have the router provided by my ISP Fatsweb Italia. It’s called Fastgate, but I if recall correctly it’s a Technicolor. It’s not a mesh router, it’s a simple one, I’ve only separated the 2.4 and 5ghz network, mostly because the 2.4ghz is way slower.

Thanks for your suggestion, I’ll try to contact the support directly with the link you’ve provided as soon as I’m home.

 

Badge +1

@Xander P, some updates. I’ve changed the ISP and they’ve sent me a new router. This one has mesh capabilities and much better wifi handling. 

I’ve added again my speakers to the new network, the living room one is still wired to the router while the kid’s room one is on wireless connection. Still can’t use the SonosNet on the kid’s room speaker, but now the streaming is working reliably from all my devices to both speakers, even simultaneously.

I guess I’m gonna live with it until I have to add another speaker! :)

Userlevel 4
Badge +11

Hi @macshodan, thanks for the update, glad you’ve got everything working!

Sounds like the two speakers may be too far apart for the SonosNet connection to work, still strange that you weren’t able to get them both showing up in the app when they were both connected via Ethernet though (some models of router can have problems with this however, specifically Virgin Media Superhub 3s).

It may also help (though it sounds like you’ve already tried this) to slowly cycle through the available SonosNet channels in case each speaker is looking for SonosNet on a different channel.

If range is the issue, however, then when/if you do decide to add more Sonos devices to your system, that should help get the second speaker in to range :)

Badge +1

Hi @Xander P, well honestly I haven’t tried to connect them both to the new router… I was too thinking it  could be a router problem. 

The strange thing about the range problem is that I tried to set them both on the same room, during the many tries with the old router, and even then the second speaker never picked up the Sonos net. 

Maybe it’s something with the Symfonisk implementation not being able to create a proper SonosNet?

@macshodan . In the settings for the wired speaker is a setting for 'enable WiFi' or 'disable WiFi '. What do you have this set to?

It should be enabled (because it actually enables or disables SonosNet).

Badge +1

@macshodan . In the settings for the wired speaker is a setting for 'enable WiFi' or 'disable WiFi '. What do you have this set to?

It should be enabled (because it actually enables or disables SonosNet).

🤔 I don’t recall to have seen such setting. I remember seeing a global setting for the all System, to enable or disable wi-fi… but I might be mistaken. As soon as I. got back home I’m going to check it. 

Thanks for the heads @John B 

@macshodan . In the settings for the wired speaker is a setting for 'enable WiFi' or 'disable WiFi '. What do you have this set to?

It should be enabled (because it actually enables or disables SonosNet).

🤔 I don’t recall to have seen such setting. I remember seeing a global setting for the all System, to enable or disable wi-fi… but I might be mistaken. As soon as I. got back home I’m going to check it. 

Thanks for the heads @John B 

These are two different settings.  The global one is about whether your system can connect to your WiFi because it has the SSID and password.  The one I am referring to is set for each speaker in that speaker’s settings, and basically turns off  the wireless radio on the device.  This is set to ‘enable’ by default, so you would have had to consciously disable it.  If you haven’t done so then this is not the issue, but you might as well check it.  If you go into the speaker’s settings, you will see a Name section then a Products section.  Tap the word ‘Symphonisk’ immediately below the Products heading to access the setting.

Badge +1

@macshodan . In the settings for the wired speaker is a setting for 'enable WiFi' or 'disable WiFi '. What do you have this set to?

It should be enabled (because it actually enables or disables SonosNet).

🤔 I don’t recall to have seen such setting. I remember seeing a global setting for the all System, to enable or disable wi-fi… but I might be mistaken. As soon as I. got back home I’m going to check it. 

Thanks for the heads @John B 

These are two different settings.  The global one is about whether your system can connect to your WiFi because it has the SSID and password.  The one I am referring to is set for each speaker in that speaker’s settings, and basically turns off  the wireless radio on the device.  This is set to ‘enable’ by default, so you would have had to consciously disable it.  If you haven’t done so then this is not the issue, but you might as well check it.  If you go into the speaker’s settings, you will see a Name section then a Products section.  Tap the word ‘Symphonisk’ immediately below the Products heading to access the setting.

Thanks! I’m going to check it as soon as I got home! Might have disable it when I only had the first speaker because there was some problem with the old router, and completely forgot about it! :)  

Reply