Adding music folder. Access to the shared folder is denied


I haven't had a problem accessing my shared folder for 3 years and then 2 days ago it stopped recognizing it. I've been on the fourms and tried several things -reinstalling controller, firewall setting, folder permissions, sign in as administrator, remove user account and nothing has worked. I'm using windows 7 and the music folder is on the laptop that the Sonos controller is installed on. Any help would be appreciated.

11 replies

You may want to submit a system diagnostic within 10 minutes of replicating this issue, and contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
thanks. Just ran a diagnostic. I'll contact sonos.
Hope they can help. Might be worth posting back here what solution they come up with, as it may inform others who come looking later on.
Did this get resolved? I"m having the same issue.
Userlevel 7
Badge +20
You might want to contact Sonos with the number provided after running a diagnostic and see what they have to say. You can post it here and Sonos folks will eventually reply if they don't miss your post at the end of this old topic. If you want a faster response twitter and facebook are both available, the phones are an option too but hold times can be long so I save that for when none of the other methods will work for my problem.
I had the same problem after upgrading my controller on Windows 7. In the past, it was always a little flaky although it did work, but this last version has rendered the connection to my Linux armhf processor useless. I know Linux and Windows and this NAS connection simply doesn't work anymore, good,bad or indifferent. I can access normally, via a Linux share. After looking at the same issue others are having and with no resolution in sight I have decided there are a couple of ways to go. They are: 1) copy the music from your Linux NAS back to your Windows platform using WinSCP or similar; pretty simple. Then you can use the Sonos controller on Windows, or 2) don't use the Sonos Controller on Windows, but Plex. My Sonos bars are set up to be accessed via my AV setup which includes my TV, Blue Ray, Apple TV. I access my music and videos through Apple TV to Plex. It's pretty cool in that I not only get the music throughout the house, but can use the default Samsung 55" default screen saver or set up my own slide show. Like all of you, I was also frustrated, but took a long deep breath and asked myself what are my immediate alternatives: Resolution found. I hope this helps some of you, if not all of you.
Userlevel 7
Badge +20
There is no problem sharing music to Sonos from Linux over Samba as long as SMB v1 is enabled.
cal_in_carmel-by-the-sea wrote:

I had the same problem after upgrading my controller on Windows 7. In the past, it was always a little flaky although it did work, but this last version has rendered the connection to my Linux armhf processor useless. I know Linux and Windows and this NAS connection simply doesn't work anymore, good,bad or indifferent. I can access normally, via a Linux share. After looking at the same issue others are having and with no resolution in sight I have decided there are a couple of ways to go. They are: 1) copy the music from your Linux NAS back to your Windows platform using WinSCP or similar; pretty simple. Then you can use the Sonos controller on Windows, or 2) don't use the Sonos Controller on Windows, but Plex. My Sonos bars are set up to be accessed via my AV setup which includes my TV, Blue Ray, Apple TV. I access my music and videos through Apple TV to Plex. It's pretty cool in that I not only get the music throughout the house, but can use the default Samsung 55" default screen saver or set up my own slide show. Like all of you, I was also frustrated, but took a long deep breath and asked myself what are my immediate alternatives: Resolution found. I hope this helps some of you, if not all of you.

Update: use this link

https://linuxconfig.org/how-to-configure-samba-server-share-on-debian-9-stretch-linux

to follow instructions, then make sure these adjustments are made in the [Share] section: comment out valid users = ????
add public = yes
add guest ok = yes

save, exit and restart samba. Good luck, now you have two methods to access your NAS.
Userlevel 7
Badge +20
I'm not seeing the instructions for enabling SMB v1 there, Sonos requires v1 to connect.
Did not on my setup. My board is a Beagleboard-X15, armhf processor, 200gb microSD running Debian Stretch, 4tb Samsung USB, samba version 4.5.12-Debian. If v1 is connected, then it must be installed automatically. That never was an issue for me.

Thanks in advance.

Regards.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings