Adding 2nd zone to currently playing zone shuts off my stereo after updating to v9.3 ???!?

  • 16 October 2018
  • 6 replies
  • 114 views

For context: I have v9.3 (current)
Sonos Bridge
Sonos connect (connected to my Onkyo stereo) - called "Living Room"
Sonos 3 speaker - called "Bedroom"
Logitech Harmony Ultimate universal remote to control all my stuff (software up to date)

Issue: after updating to v9.3 recently, when I start music using "Living Room" and then add zone "Bedroom" to the music playing it shuts down my stereo. How is it doing that???
Workaround: if I start "Bedroom" first with music, then add "Living Room" second, then it all works fine, as expected.

Any clues on what's going on? This just started after the recent update. This is strange.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

To the best of my knowledge, there is no 9.3, unless you're talking about some sort of beta build? If so, that shouldn't be talked about here in the public forum.

What method are you using to add the zone "Bedroom"? Are you using the Logitech, or a Sonos controller somewhere? I'd certainly agree that it shouldn't be doing this.

If you're using the Logitech, it may be that you need to do an "update" to it. I've found that on mine, an occasional "update" does a world of good to the remote. I guess they call it a resync in the Harmony world.

There's nothing in the transmission of music from the CONNECT to your stereo via the RCA jacks that could/should be shutting down the stereo at all, so I'm guessing that it's a setting in the Harmony that needs to be checked.
Thanks for the response @Airgetlam.
My bad, it's version 9.2. not 9.3.

The harmony remote was up to date and the issues still occurs. Given this issue affects the stereo receiver, then it has to be something weird with the Logitech Harmony remote and I'll hit them up for answers. Was just curious if anyone here has seen this issue given how popular the logitech universal remotes are. l
Userlevel 2
Badge
To the best of my knowledge, there is no 9.3, unless you're talking about some sort of beta build? If so, that shouldn't be talked about here in the public forum.

What method are you using to add the zone "Bedroom"? Are you using the Logitech, or a Sonos controller somewhere? I'd certainly agree that it shouldn't be doing this.

If you're using the Logitech, it may be that you need to do an "update" to it. I've found that on mine, an occasional "update" does a world of good to the remote. I guess they call it a resync in the Harmony world.

There's nothing in the transmission of music from the CONNECT to your stereo via the RCA jacks that could/should be shutting down the stereo at all, so I'm guessing that it's a setting in the Harmony that needs to be checked.


I am experiencing exactly same problem.
I have CONNECT:AMP as well as CONNECT, set up as 2 different zones, then Logitech Harmony for controlling SONOS as well as receiver that powers CONNECT.

Everytime I add my CONNECT:AMP into the group where my CONNECT is currently playing, this shuts down the receiver connected to my CONNECT and effectively turns off the music there.
It is totally weird but happens very regularly.
Please note the zone grouping is triggered from the Sonos Controller and not from the Harmony, so clearly, I would not expect any other music components to be impacted by that, only the Sonos ones.
Userlevel 7
Badge +21
I don't have Harmony and don't know a ton about it, but it sounds like there is some sort of automation in place that is misinterpreting the Connect:amp added to the group as the a trigger to turn off the receiver. Do you have the receiver set to turn on automatically, and switch to the Connect input, when the Connect begins playing music? Also, are you using a receiver that's a part of the 'Works with Sonos' program?
Userlevel 2
Badge
I don't have Harmony and don't know a ton about it, but it sounds like there is some sort of automation in place that is misinterpreting the Connect:amp added to the group as the a trigger to turn off the receiver. Do you have the receiver set to turn on automatically, and switch to the Connect input, when the Connect begins playing music? Also, are you using a receiver that's a part of the 'Works with Sonos' program?

I don't have any such set up that I know off.
I have Harmony set up where turning on activity in Harmony turns on the receiver as well as starts playing Sonos connected to it. So when I operate activities via Harmony, components turn on/off as required.
But as mentioned above, the issues happen when I don't touch Harmony at all.

Receiver does not shut down when I turn off its sources (and certainly not when they turn on!), whether it is the TV or Sonos or other devices that are connected to the receiver, so I would be very surprised if it just did this on its own when one of its sources (Connect) turns itself on.

I think I will need to try to delete the Harmony activity connected to the Connect component and see if afterwards anything weird still happens. Although I don't believe Harmony has any detection capabilities like this.

Failing that, I will need to submit a support request for investigation.
Userlevel 2
Badge
Actually, I realised that I was using wrong model numbering.
I have the original ZP100 and ZP80 instead of Connect:AMP and Connect. I don't know if it matters as I think it was just naming change...