Add Music Folder


  • Contributor I
  • 3 replies

I get a message that sonos can’t connect to my Mac. Spent a couple of hours with Sonos support who told me to contact Apple. Spent a couple of hours with Apple support who told me to contact Sonos.

 

Found loads of threads of similar problems, no solutions…has anyone ever actually solved this issue or does everyone just give up and use Spotify?


10 replies

Userlevel 7

Can you post more details? Have you been able to connect to your music library on your Mac before? What MacOS are you using? 

Also, are you running any virus protection software, like for instance, Sophos?

You’ll need to set your Mac to use SMBv1. This is messy. Since I’m not a Mac user. I cannot offer a concise procedure to do this.

connection to old Mac was fine. Trouble began when i moved to a new Mac. Currently using BigSur.

Evidently the old Mac was setup to allow SMBv1. The new Mac might also be fussier about passwords.

...does that mean everyone in the world using BigSur is having the same issue? You’d think Sonos would want to fix this, rather than having however many people faffing about with settings. Plug and play, my backside….

Likely, this is the case. The older SONOS units cannot be updated to resolve this issue. The units that support the SONOS S2 system might be updated at some point, but we do not know if or when.

I don’t have any hard data, but the feeling that I have is that most people are using online music services, not a local library.

I’m using a local library stored on a NAS (Network Attached Storage) drive. In my case the SMBv1 issue was resolved with a single click. I’m using Synology. Not all NAS drives are this docile. I prefer to store my music on a NAS drive, rather than a computer because I can shut down the computer and the music continues to play. I’m also impatient and playing music slows the computer somewhat.

Windows 10 users have a similar issue.

Userlevel 7
Badge +17

Hi @hw73 

Welcome to the Sonos Community!

I recommend you make sure your new Mac’s network name is 16 characters long or less, contains letters, and is different from the name of your old Mac:

https://support.apple.com/en-gb/guide/mac-help/mchlp2322/mac

Reboot the Mac afterwards.

If you haven’t removed the old share path from your Sonos system, please do so, then add the new share via the Sonos app on your new Mac.

It may also help to ensure that the shared folder and all it’s sub-folders have read/write access permissions for “Everyone”:

https://support.apple.com/en-gb/guide/mac-help/mchlp1203/11.0/mac/11.0

An uninstall and reinstall of the Sonos app on your Mac may help if none of the steps above do. Please remove the following files/folders before reinstalling:

  • /Applications/Sonos
  • ~/Library/Application Support/Sonos
  • ~/Library/Preferences/com.sonos.macController.plist (don’t worry if you don’t find this one - I’ve never once found this file)
  • /Users/Shared/Sonos/Shares.plist

“~” denotes your user home folder on the drive.

Finally, it may help to disable File Sharing entirely on your Mac to force an HTTP share:

  1. On your Mac, choose Apple menu   > System Preferences, then click Sharing.

  2. Deselect the File Sharing tickbox.

  3. Add the share in the Sonos app

If you can relay any error messages or codes given if any of these steps don’t help, I’ll be happy to help further.

 

Hi

Progress of sorts! I had tried most of these before. The one thing I almost definitely hadn’t tried was deleting:

~/Library/Preferences/com.sonos.macController.plist

I did this (and re-did the other steps) and I can now at least add a music folder. However, when I try to update my music library the Sonos Controller crashes! I do have a big-ish library, so I tried it on a second smaller folder but same problem?

Userlevel 7
Badge +17

Hi @hw73 

Thanks for trying those steps.

The notes on your existing case mention that you were trying to share the music library from a USB drive connected to the Mac - is this still the case? If so, please follow these steps:

  • Open System Preferences on your Mac.
  • Click on Security > Privacy.
  • Under the Privacy tab, click on Full Disk Access.
  • Check the box next to Sonos Library Server.
  • Open the Sonos app.
  • Update your music library by going to Manage > Update Music Library Now (or add the share if it hasn’t yet added successfully)

Also, how big is the library? If it is over 65,000 songs, you’ll need install Plex Media Server on the Mac and let that index the music, then add Plex as a service to Sonos.

I hope this helps.

Reply