Answered

Why my ERA 100 just can't detect my 5G WIFI?

  • 26 December 2023
  • 17 replies
  • 550 views

My router is LINKSYS WRT1900ACS. It broadcasts 2.4G and 5G in different SSID. But the 5G SSID never shows up in the ERA 100 WIFI connection list. My ERA 100 works well with 2.4G, but it can't detect my 5G WIFI, and can't get connected by manually input.

My other devices, ipad, computer detects and works well with my 5G WIFI.

icon

Best answer by Stanley_4 27 December 2023, 05:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

What type of 5Ghz signal? Does it conform with the Sonos Network Requirements ?

Important to note, there is a difference between 5G and 5Ghz. 

What type of 5Ghz signal? Does it conform with the Sonos Network Requirements ?

I think it conforms.

In the router settings, the 5GHz band has many options: 802.11a only, 802.11ac only, 802.11a/n only, Mixed(default).

I leave it as Mixed(default).

ERA 100 is my only device can’t find the 5G WIFI.

Userlevel 7
Badge +19

Does the network name use any special characters that Sonos won’t recognise?

Does the network name use any special characters that Sonos won’t recognise?

No, I only use normal letters in SSID and password.

Userlevel 7
Badge +22

What channel is your 5 GHz network on? Try changing it to something in the 36-64 range as a test.

What channel is your 5 GHz network on? Try changing it to something in the 36-64 range as a test.

OMG, thank u so much!

Changing the channel from "Auto" to "64 - 5320MHz", solves my problem. The 5G SSID shows up and works well with my ERA 100 now. Though I don't know why channel setting is so important to SONOS. I've never changed it before.

I don't know why channel setting is so important to SONOS. 

It isn’t. My system’s currently working on channel 112 (5560 MHz).

Maybe your router is a bit quirky.

Userlevel 7
Badge +23

I don't know why channel setting is so important to SONOS. 

It isn’t. My system’s currently working on channel 112 (5560 MHz).

Maybe your router is a bit quirky.

Allowed Wifi frequencies vary by location, so maybe the OPs router is set for one country and the Sonos gear for another? Or maybe it is trying 6GHz? OP doesn’t list their location.

Userlevel 7
Badge +22

5 GHz can be tricky with the optional DFS (weather radar) channels being out of your control if a radar is seen.

The channels allowed in each country also impacts 2.4 GHz.

Might just have been removing the Auto channel switching, that can confuse some devices.

I often recommend going back to the original 5 and 2.4 GHz channels to see if that works. If it does then try others knowing your hardware is working properly at the oldest channel settings.

I don't know why channel setting is so important to SONOS. 

It isn’t. My system’s currently working on channel 112 (5560 MHz).

Maybe your router is a bit quirky.

Allowed Wifi frequencies vary by location, so maybe the OPs router is set for one country and the Sonos gear for another? Or maybe it is trying 6GHz? OP doesn’t list their location.

The OP’s router is dual band. My point was that Sonos gear works on DFS channels without issue. It’s conceivable that the router held back from transmitting, beyond the statutory scanning period at startup.

Userlevel 7
Badge +22

For a bit of info on why DFS channels shouldn’t be your first choice, particularly when adding new devices this has some good information. Once working, and if the channels are clear in your area there is no reason to avoid them.

https://wifinc.net/dfs-channels-and-why-to-avoid-them-even-though-you-say-you-cannot/

What is a DFS channel? These channels share the spectrum with Weather Radar and Radar systems. For the FCC and IEEE to approve the use of these channels in WIFI, a mechanism had to be in place where these channels could co-exist. A mechanism called DFS (Dynamic Frequency Selection) was created to have the WIFI devices listen for radar events and either stop using the channels or automatically move off these channels. When RRM/ARM is used, and an AP hears a radar event it must pick a new channel and inform its clients to move to this new channel. If RRM/ARM is not used, then AP after hearing a radar event must stop transmitting for 30 minutes. (much more there)

My ASUS AX mesh chooses 160MHz DFS channels by itself.

My understanding from an article I came across online a while ago, is that these are the DFS channels we are allowed to use at Home and that there are some slight differences for US & Canada…

  • 52-64, 100-144 in the US
  • 52-64, 100-116, 132-144 in Canada
  • 52 to 64, 100 to 112 and 132 to 140 Rest of the world
Userlevel 7
Badge +22

A lot of defaults are set to give pretty results when being tested by folks doing reviews, bigger numbers are the highest priority. I tend to go for maximum stability when starting out and only bump things up if I need the speed (I don’t yet) and things still work well.

The article isn’t about Sonos but very similar low-latency, delay intolerant voice streaming gear and makes some interesting points I thought might apply here.

Since I don’t use the DFS channels I haven’t looked into what Sonos does when a DFS channel has to be vacated due to a radar being detected. If I can’t find a usable non-DFS channel I’ll probably have to look into that but I’d rather not.

Userlevel 7
Badge +22

Channels for 5 GHz by country. The 2.4 channels are earlier on the same page.

https://infogalactic.com/info/List_of_WLAN_channels#5.C2.A0GHz_.28802.11a.2Fh.2Fj.2Fn.2Fac.29.5B17.5D

My understanding from an article I came across online a while ago, is that these are the DFS channels we are allowed to use at Home and that there are some slight differences for US & Canada…

  • 52-64, 100-144 in the US
  • 52-64, 100-116, 132-144 in Canada
  • 52 to 64, 100 to 112 and 132 to 140 Rest of the world

UK: 52-64, 100-144, plus 149-173 but those are short range/low power only