Play:3 won't connect to wifi

  • 14 May 2024
  • 4 replies

So with the new update, I’ve had to reconnect all my speakers. I didn’t really have any issues connecting 3 of my Play:1 speakers, but my Play:3 speaker won’t connect. I did a factory reset, the light flashes white & orange, but it never flashes green (as it should once connected). Anyone have any suggestions?

4 replies

Same with my Play 3. Forever flashing orange. I can add it with a cable connected but the app tells me it may not show up in my system, and it doesn’t. Sonos, please let us have the functioning app back while you fix this new one!! 

I have this issue as well. Previously set up as a stereo pair (for years). Lost one, my iPad controller tells me twice that it can’t connect to the PLAY:3’s WiFi, when I wire it with an Ethernet cable, it can’t be found, despite the controller telling me that it is found, and needs to be added to my system. 

I’ve not factory reset it, but I have logged out, and back in to the controller.

I’ll wait patiently for Sonos to figure this out, as I’m sure they will. 

So pleased to see it’s not only me having this issue. I’ve tried everything & although it said connected it acknowledged it wouldn’t show on my system. So frustrating as I’m now without a speaker in a room. Previously it had said I wasn’t connected to my local network, I was! Now it won’t let me do a reset at all, I just get a white light with the orange light flashing when I hold the button. Tried holding it until my finger lost blood supply but it never changed. Please sort this out Sonos.

New problem, saw on a previous comment advice to turn off router & back on, did that & I can now see the Play 3 but it says not registered, selected fix it but it does absolutely nothing! Held the on button down & it now works but not linked with other speakers & still showing as unregistered.