Changed router and broadband provided but can't connect speaker

  • 26 March 2024
  • 6 replies
  • 51 views

I’ve got one Sonos 5 speaker in my living room, and now that I’ve changed router and broadband provided I can’t connect. I’ve got a Linksys XPNMX56 (Velop) router, and I’ve tried connecting multiple times with no success - can anyone help? I’ve read the other articles connected to this set-up but can’t seem to find an answer why


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +17

Most routers, even when supplied by an ISP, allow you to change the SSID and password by yourself. 

Userlevel 7

Hi

I have to assume all your network equipment is provided by your ISP (Internet Service Provider). Unfortunately, ISP provided network hardware is configured for simple peer to peer connections. Think connecting a cell phone, computer or tablet to your network those are peer to peer connections.  Those devices readily connect to a new network just by providing the correct password for the SSID of the new network. 

By way of explanation the SSID (Service Set Identifier) is the name of your network. If you open your cell phone you can probably see other networks in addition to yours. What you see are the SSID’s (names) of those other networks. You can’t access them because you don’t know the password….unless someone was stupid and used “password” as the password.

Sonos connects to your network in a similar manner by locating the SSID and entering the correct password. However, Sonos is much more “chatty” than other devices. If possible you might ask your ISP to change the SSID and password of their newly installed equipment to the SSID and password of your old gear.  Assuming you haven’t factory reset your Sonos gear all components should reconnect. Don’t worry although reputable ISP’s may recycle the SSID; they don’t recycle the password.

I did answer the questions as best I could. It’s a sonos play 5, no the SSID and password are not the same,  the new router does support b/n/g and yes I have connected the speaker to the router with an ethernet cable, and it works but I need it to be able to connect wirelessly. 

I have read the first article and that is the process I’ve followed several times.

Userlevel 7
Badge +22

Since you didn’t answer the questions better help can’t be given but you can try these links.

https://support.sonos.com/en-us/article/connect-sonos-to-a-new-router-or-wi-fi-network

https://support.sonos.com/en-us/article/recommended-settings-for-using-sonos-on-wireless-networks

Hello, thanks for replying - it’s a Sonos Play 5, and I have no idea about the SSID, not the same password though. I’ve followed the instructions through the app several times putting in new network and new password and the speaker won’t connect. I’ve now got the speaker plugged in to the router with an ethernet cable, and it works, but that means it’s in the wrong room. I can’t connect wirelessly.

Did you set up the new router with the same SSID and password? Are the channels the same (b/g/n)? Have you wired a single Sonos to the new router with an ethernet cable? What Sonos speakers do you have?