Sonos Beam no longer sees TV Remote (or Tivo Remote)


Re: Diagnostic Confirmation No: 1927300542

I have a fairly new Sonos Beam that no longer responds to volume commands from my TV remote. I have tried with multiple TiVo remotes and the Samsung remote that came with the TV. The built-in Alexa has no problem understanding verbal commands to raise or lower the volume, and all remotes work fine if I disable the "external speaker" feature in my television set. Further, if I open the Sonos app and try to create a new remote control, it doesn't recognize that input either.

11 replies

Userlevel 2
Badge +5
Hi DKawa,
You said that the Beam "no longer responds..." am I correct in assuming at some point it was working?
There maybe another setting on your TV that needs to be tweaked. Many TV's when set to external speakers may assume that the volume will be controlled by other means such as an AV Receiver for example. It sounds like this may be the issue which would be why the Alex voice controls are working because it is an "external" volume control.
First thing to check is does your TV has an HDMI ARC port which is usually labeled ARC on the TV.
If so then ensure that you are using this connection and in the TV settings it needs to be switched to on. This allows the tv to control audio with external devices.
I’m having the same issue! Volume on beam not changing when using the TiVo or tv remote only works using the app.
Have you tried just reprogramming the Sonos with that particular remote?

https://support.sonos.com/s/article/3402
Yes and it won’t let me set it up. It’s like the IR “eye” is blind suddenly.
Curious. Can you be more specific about "won't let me set it up"? Is it failing with an error of some kind? Have you tried a power cycle of the Beam, and fresh batteries in the remote?
So I go into remote set up and when it asks me to hit the volume up button nothing happens. I used 2 tivo remotes and the Panasonic one that came with the tv. The tv “sees” my button press but the beam does not..
Most odd. I would recommend that you contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.
Hi I have this exact issue as well with my Sonos Beam. My TV remote was working fine with volume and then suddenly stopped working also. I tried a remote reset but that wouldn't recognise any input from the remote (the remote is working fine otherwise for other functions) The only thing I have done recently is setup google assistant (then went back to Alexa). Was there a fix worked out for this issue? Cheers
I cannot get my TiVo remote volume to work either. I have the new remote and it doesn’t work. I attached a picture of the new TiVo remote. I contacted my tv provider and had no answer either.

9250,

Just a suggestion, perhaps try power cycling the Beam and then toggle off/on the 'Use IR’ option in the Beams 'room settings' in the Sonos App and setup the TiVo remote control again to see if that fixes the issue.

I am assuming this new TiVo remote is infrared and not connecting to the TiVo box using Bluetooth?
9250,

Not sure if this YouTube video might be relevant to you, but maybe worth a look...

https://youtu.be/5xH8luJoXw4

Reply