Question

IFTTT - Error accessing the service


When I want to add IFTTT to Sonos I get the error message: Error accessing the service. It won't load the rooms.

What I already tried :
- Set IFTTT-Sonos on my android phone, also the same problem
- Disconnect Sonos and IFTTT and enable it again

On the webpage the https://ifttt.com/activity/service/sonos I can see the service is connected.

Can anyone help me?

29 replies

Did anyone work this out, I cant get IFTTT to see rooms or playlists. Just says 'Loading...'
Userlevel 1

Same problem here.  Setup a new applet at the weekend (Alexa->Sonos), eveything worked fine.  Logged into IFTTT to amend an applet today and the drop-down of Sonos rooms  just says “Loading...” and a big red banner at the top of the page says: “Error accessing the service”.  @Philiptome, when you say you’re reset the settings, I assume you mean re-entered your Sonos accont details into the IFTTT Sono service screen. Is that right and does this fix it for you (albeit temporarily)?

 

Userlevel 7
Badge +21

Either way, I'm not very excited that both the Sonos service and the IFTTT one and the Alexa one all rely on remote cloud services.

Um, Alexa requires the cloud to work for everything. There is no "local" solution for Alexa. (Lots for Sonos though).

Same for me, existing trigger won't reconnect and I can't set up a new trigger.

Edit: I have had to completely remove Sonos from my ifttt account and then relink Sonos account back to ifttt and it is now connecting to my Sonos.

Userlevel 1
Badge +1

Hi have this problem, I originally setup play Sonos when arriving home on ifttt, originally it was working. Now for some reason it has stopped, tried setting up applet play only if not arriving home late and wouldn’t work. Wasn’t allowing me to select play lists, stayed greyed out. I disconnected Sonos from ifttt and then reconnected, this then allowed me to select playlists but won’t work at all even though everything connected and selected fine.  Any suggestions please.

Userlevel 7
Badge +21
Big_Ken are you reasonably up-to-date on your Sonos system? The Sonos Cloud API (that IFTTT relies on) needs at least 9.something for Cloud support.
I have been having this same issue, pretty much any applet that manipulates what my system plays, is failing. When editing perviously working applets, like where to play or what room I see 'Loading...' and then a link below says:
"Select room. The group containing this room will pause playback. Sonos seems to be down right now. Try again "

I have reset the settings several times in the past few days. anyone have a solution?
Yep, 10.3.3 current version on iPad, iPhone and Samsung.
I am experiencing the same thing today. Was this resolved at all?
I'm also having this issue - I can't connect Sonos to IFTTT. Sonos system is up-to-date...

The Sonos connection to IFTTT stopped working last night and now IFTTT will not connect to the SONOS service.

When will this be fixed by Sonos or Is this something to do with the new upgrade?

Same here. IFTTT suddey can't connect to Sonos. It's been working perfectly before running routines, etc.

Yes, looks like it is “broken” again. IFTTT complained that connection to Sonos was lost and you had to reconnect to fix. This however doesnt work and cant see any rooms, playlist or favourites seems to be a Sonos connection issue. 

Userlevel 1
Badge +1

Yeah, same here. Since last night the service was still active in IFTTT, but applets failed. About an hour ago the service become inactive and does’t reconnect.

I visited my IFTTT app and found that my Sonos connection wasn't working. I deleted it and attempted to connect several times and received the same error as the poster, "Error accessing the service."

I am hoping for at least a confirmation from Sonos that they know that it isn't working right now.

 

the connection between google home through ifttt with the sonos is broken.  there was problem with the sonos service. 

how can I solve this ?

Yup, same here, down.   Seems down longer than usual.

Mine sprang into action a couple of days later, but just gone back into IFTTT and all the options have disappeared again. So it's not working again. Not sure if this is a Sonos problem or IFTTT.
Userlevel 1

Yeah screwed for me too.  I stupidly removed the service and tried to re-add rather than just editing the existing service and have wiped out all my Sonos Applets.  :rage:  FFFFFFFUUUUUUUUU

Finally just started working again.

Badge

This is happening to me also and can’t figure out how to resolve.

Userlevel 7
Badge +21
Your screenshot talks about Google? Don't do that, use the Sonos IFTTT support instead.

What exactly is the scenario you are trying?
Userlevel 1

Cool thanks for the heads-up.  Just re-wote all my Applets.

This is happening to me also and can’t figure out how to resolve.

I have found that playing an existing trigger often seems to unblock the thing and I can then add a new trigger.

Yes, reentered account details in to the IFTTT Sonos Service.   It did not really help.  I am finding that the service seems to come and go.  The service works some of the time, and other times I see errors (seen when looking at activity).  2 hours ago I see errors when triggering a play command (and I see error in activity).  While, I just now triggered an applet to start a play list, and it worked.  So it seems to me that this is a hit and mis service right now.

Reply