Question

workaround for 802.11ac

  • 1 September 2019
  • 5 replies
  • 143 views

Hi all. We have recently moved home and started with a new internet provider. However the router that they recommended and we purchased was a 802.11ac router. Which having read posts from the community already does not work. Is there anything that will rectify the problem, or is it a case of changing router / network provider?

thanks

alex

5 replies

Does your router really only have a 5GHz band and no 2.4GHz? If it has 2.4 as well there is no issue.

Or you could wire just one Sonos device to your router to trigger Sonos' 2.4GHz mesh network, SonosNet.
Out of the box every sensible AC router would support 2.4GHz. And unless the settings have been messed with it ought to offer legacy support for B/G devices at 2.4GHz in addition to the current N standard.
Userlevel 7
Badge +21
Check your 2.4 settings for Airtime Fairness and turn it off if present. That got my Sonos working on my new gear.
Badge +2
I would take a pragmatic approach and first connect a Sonos device to your router with a cable, see if all controls work. Next, remove the cable and reboot the Sonos device but keep it close to the router to see if it connects to the wifi network. If this works, you can move the Sonos device to its location you want it in your house. Most likely your router supports 2.4GHz and offers it 'seamlessly' (i.e. on the same ssid as the 5GHz) which may explain why your Sonos device does not connect to it. You can try to temporarly disable the 5 GHz wifi network on your router which will 'force' the Sonos device to connect to the 2.4GHz.
I'm not even sure that the OP has a real problem, as opposed to simply being concerned that the router could potentially be incompatible.

Reply