Wired and Wireless Together

  • 4 January 2019
  • 7 replies
  • 958 views

I've got two Connect:Amps and a Play:1. The two Connect:Amps are connected into a network switch with standard network cables, and the Play:1 needs to connect wirelessly as there are no network cables in the area.
When I go into Settings, Room Settings, select one of the Sonos speakers and select Advanced Room, I get the option to turn Wifi off on the speaker.
When I turn Wifi off on one of the Connect:Amps, everything continues to work fine. When I turn Wifi off on both of the Connect:Amps, the Play:1 drops out of the system and I can't get it back again until I re-enable Wifi on one of the Connect:Amps.
Is it possible to turn the Wifi off on both Connect:Amps, and have them just running via a wired network, and have the Play:1 connecting to my Wifi ? I presume something is going on with Sonos Net being set up from the Connect:Amp and when I turn this off, the Play:1 loses connectivity, but can I force the Play:1 to use Wifi rather than Sonos Net ?.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Hi FunkySi

From the Playing Now screen tap More in the lower right then > Settings > About My Sons System. You'll now see all your speakers. If you are in Boost mode "WM: 0" will appear at the bottom of each speaker description.

Essentially when you wired one of the Connect: Amps you were setting up in Boost mode. From there all you needed to do was add additional Sonos components via setup (i.e. Add a speaker or Sub). The second Connect:AMP nor the Play 1 were required to be wired.

At this junction assuming the Connect:Amps are in Boost mode just add the Play 1 as a speaker. However before you do you'll need to clear any Wi-Fi credentials from the Play: 1.

Follow the instructions in the link:https://support.sonos.com/s/article/3488?language=en_US

To be clear there are times when a second Sonos component may need to be wired if you are experiencing drops or just not able to reach a speaker.

Cheers!
Why would you turn WiFi off on the Connect:Amp?
Userlevel 7
Badge +21
Having the Connects wired puts your system in Boost mode, the Play 1 then joins them on their SonosNet WiFi. When you turn off the WiFi on both Connects you have also turned off the network connection the Play 1 was using leaving it isolated.

It might be possible to set the Play 1 up to use your home WiFi instead of the SonosNet from the Connects if you have the WiFi turned off in both, I'm guessing that would be a non-supported configuration and prone to "interesting" problems.

Unless you have a very good reason to turn off the WiFi on a Sonos device it is not a good idea to do that.
Thanks for the replies. I was trying to turn wireless off because I was getting drop outs on some of the speakers and felt that a wired connection would be faster and more stable than wireless. The Connect:Amps are literally on top of a network switch in a cupboard, so have limited wireless coverage but could easily have a wired connection. When I wired them in without turning off the Wifi, my network kept dropping which I was assuming was due to loops. Turned wireless off and the network stayed up.
When I just had a single Play:1, that was using my Wifi without issue as there was no need for Sonos Net, so I knew it could do it.
Provided a wired connection takes priority over Wifi and / or Sonos Net on a speaker, then I could probably get it all working. Does anyone know if that's the case ?
Wired is preferred over wireless if it's an available path. And as already noted a wireless player will connect to a wired player via the SonosNet dedicated mesh.

If you really want to force the system into 'mixed mode' with the Play:1 on your WiFi (not SonosNet) then go to Settings/Advanced Settings/Wireless Setup and enter the WiFi credentials.

If the system won't let you into Wireless Setup, temporarily re-enable the SonosNet radio (misleadingly named "WiFi") in Advanced Room settings on both Connect:Amps, make the changes, then disable the radios again afterwards. Note that after any change you should wait for 2-3 mins in case the Play:1 needs to flip over between operating modes.

In mixed mode the Play:1 will show WM:1 in About My Sonos System, and the wired players WM:0.
Userlevel 7
Badge +21
I'd look into your network to see why you are having loop issues, Sonos has a naughty hardware list but possibly you have a setting somewhere that is messing up the Spanning Tree Protocol, STP.

https://support.sonos.com/s/article/41?language=en_US
Thanks for all your advice. Managed to get it working as required now.