WiFi interference

  • 20 June 2017
  • 6 replies
  • 1638 views

Since adding a sub to my system I am experiencing problems with other devices (smart TV, laptops, phonesconnected to my network (both 2.4 and 5g connections. Is there a way to change the sonos wifi channel or other chance to reduce or eliminate the interference or do I have to move the subs location?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

In the app, you can change the SonosNet channel. It is in the Settings/Advanced Settings/SonosNet Channel. I believe that affects both 2.4 and 5 GHz channel usage.
In the app, you can change the SonosNet channel. It is in the Settings/Advanced Settings/SonosNet Channel. I believe that affects both 2.4 and 5 GHz channel usage.
2.4GHz only. 5GHz channel selection -- which applies to just PLAYBAR/PLAYBASE (plus satellites) -- is dynamic.

@jasonkuppig you'd need to describe your system in more detail. As a basic troubleshooting step you should restart all the devices on your network. You could simply have a duplicated IP address. If that doesn't fix things, submit a diagnostic and post the reference number.
Thanks for the clarification, ratty. Was never sure about that, until now!
Hey folks. This sounds like a similar problem to what I am having. (Didn't know if I should open a new thread, or just post here). I have a Playbar, Sub and recently added 2 play1's as rears in the living room. I have set the SonosNet channel to 11 and ensured that the router is not set to 11 (logged into the router wifi settings, and moved the 2.4 channel from AUTO to 6). But I am still experiencing very poor wifi in the living room. I used to have incredibly fast speed in this room until I installed the 1s. What can I do to fix this?
Hi. There is absolutely no way that that the P:1s are slowing down or weakening your wifi. You have taken sensible steps already. I suggest powering down the router and everything on network then power up router and every device one-by-one (everything not just Sonos). Make sure the wired device is not loxated too close to the router. If that doesn't help, run a system diagnostic and post the confirmation number back here for Sonos to pick up.
I was getting the impression reading through this thread, that PERHAPS some users who are experiencing WiFi issues here in this thread MAY not all be running their Sonos devices on SonosNet, but using their router WiFi instead... but either way, i was once told that if you do run your Sonos devices on SonosNet (i.e. with one Sonos speaker or device cabled directly to the router) that it was often best to go onto remove the routers WiFi credentials from within the Sonos App's Settings/Advanced Settings/Wireless Setup by following the 'reset' option procedure.

That then stops the Sonos devices jumping between SonosNet and the Routers WiFi when they are more or less on par with each other in terms of signal strength.

Obviously the Sonos App WiFi credentials should NOT be removed if you do not have a Sonos device cabled directly to the router... but in that case the SonosNet channel is slightly less relevant, though it’s still good to shift the channel away from the one(s) in use by the 2.4ghz local router channel(s)

There is of course the other things to bear in mind too, such as scanning the airwaves to make sure closeby neighbours are not using similar WiFi channels and moving devices so that there are less objects in the way ..and to move the speakers away from other WiFi reliant devices like printers, cordless phones etc.

The other thing that tends to cause huge issues are WiFi repeaters and extenders and powerline adapters with built in WiFi, that have been assigned the same SSID name and channel number ... if used I would opt to use a different SSID etc. There is a role for these, but they can also be a nuisance if not setup correctly.

Finally, If a Sonos device is cabled to the router, then don’t have it sat right next to the router... move it away at least 4 feet, or better still, even further, as far as its cable will reach.

Anyhow, I hope the above provides a bit more help for those having regular 'drop-out' issues with their speakers.