Question

weak wireless trouble

  • 13 April 2017
  • 3 replies
  • 690 views

I have the connect and connect amp along with a bridge and some play 1,3 and 5 speakers. I keep having drop off issues so I read to plug in one of my devices in to create a sonos network if you have weak wifi. what is the best device to use for this? does it help if I plug in more than 1 device?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +21
Drop offs may not b down to "weak wi-fi". Try a network reboot as follows:-

Switch off your Wi-Fi Router
Switch off ALL your Sonos kit
Switch off ALL devices connected to your Network
- Computers, Laptops, Tablets
- Smartphones, thick phones
- NAS

Switch on Router. Wait until it has re-connect to the internet
Switch on Sonos Bridge and/or Boost, Connect - Wait a minute or two for them to connect
Switch on your Sonos Plays and Playbar
Switch on all your other network devices

As for connecting other devices. As you already have a Bridge that will be wired to your router which means your Sonos system is already using SonosNet. If you have entered your wireless details into Sonos then it may use a combination of SonosNet and WiFi - You can check by going to "About My Sonos" and against each device if it has WM:0 it is connected by SonosNet and WM:1 it is WiFi.

After you try the reset let us know the result. You may need to investigate interference.
thank you for your advise and help. I did your recommendations and it still didn't work. however what I did do is reset the key code which allowed me to connect to the sonos wifi. that has worked with no issues so far.
Badge +1
This sounds like the problem I had with my system when I moved house. You've got a Bridge - that's definitely step one as Stuart says, although a Boost might help more.

It does help to have *any* device plugged in (because wire is better than air) and arguably, the more the merrier, but that probably won't make much difference here.

(By the way, top tip is that once you've got everything working, you can use those empty Ethernet ports to connect other devices to your home network via SonosNet).

The reason I think you've got the same issue I had though is that you cite drop-off, implying that initially you have a connection and then it goes.

I found that WiFi interference was the issue. I changed my router to Ch6 only and my Sonos system to Ch11 only (or vice versa). Do the latter via Settings > Advanced Settings > SonosNet Channel.

Now at the extent of their reach, your home network wifi and SonosNet won't overlap. I can't claim to know the science, but it worked for me!