Question

Very frustrating setup issues (App sees speaker but does not connect)

  • 12 September 2019
  • 4 replies
  • 158 views

I recently moved to a new country (China) from another (Macau). I had three Sonos Play:1 speakers set up with no problems in Macau. When I moved to China, I tried to set them up again. Only one speaker connected properly; the other two failed to connect. I have been sending emails back and forth to Sonos Support and they are stymied and told me to contact my local support office in Shanghai. Before I do this, I thought I would post the question here.

I did a factory reset on the speakers. I follow all the instructions during setup and the proper lights turn on when they are supposed to. My phone app sees my speaker and tells me the correct serial number that matches the one on the bottom of the speaker (the MAC address). I then go through the procedure of pairing, by pressing the buttons and waiting for the chime. I hear the chime and then...nothing. A minute later, I get the message that the speaker was not found (even though it found the speaker previously).

I then went through the alternative setup by plugging it into my router and again go through all the steps. The app recognizes the MAC address (I have tried this on both of my non-working speakers) and again asks if I want to set this speaker up. I go though the instructions, press the buttons, hear the chime, then...nothing. Exact same situation.

This is extremely frustrating. I have done numerous factory resets and have tried this over and over, plugging into every port in the back of the router, trying different button combinations, etc. It is always the same situation. Everything is fine up to the chime sound, then ..."Not connected"and it can't be seen, even though it does see it and recognizes the correct MAC address.

I thought it might have been my new home network but again, one of my three speakers set up with no problems. Lots of emails with Sonos but they have no idea. Does anyone have any ideas on what is going on here and how to fix this?

PS. Just to add, I have sent the diagnostic to Sonos on both speakers but they didn't find anything in it or gave me any suggestions due to the information in the report. I did this before and after my factory resets so there was data in there to send them.

4 replies

I have exactly the same issue with my new Ikea symfonisk speakers. One paired no problem the other has this issue. So frustrating.  

Ensure the routers WiFi is backward compatible with 802.11b/g/n wireless standard and also check the router does not block mDNS multicast traffic on the network.

Ensure the 2.4ghz WiFi SSID is different to the 5ghz SSID and don’t use non alpha-numeric characters in the name.

If the router supports ‘Airtime Fairness’ then it’s best to disable that feature

I am an IT networking specialist. I understand what you are saying, but having different SsIDs for 5 GHz and 2.4 GHz is not the issue. I have the same SsID for both. Yes router is compatible.  Not blocking DNS. Etc etc. 

So With no changes made to the wifi network, not even a reboot, I was able to configure the second speaker.  How?  I downloaded the android app and did it from my android tablet. 
why this worked: 

when I configured the first speaker I have ver 10.5 of the IOS Sonos controller app running on my iPhone with IOS 13.1.2.  That was a few day’s ago.  Today I updated my iPhone to IOS 13.2.  I didn’t think anything about It being the issue.  Until I did a what changed analysis.  
So the only Change was an IOS update.  
I suspect this update broke 10.5 functionality for adding devices.  
I informed SONOS Support on this finding. 

I wasn’t talking about DNS, I was referring to multicast (mDNS) traffic being allowed/broadcast across your network, as Sonos uses that for communication between devices and the WiFi SSID’S certainly do need to have separate names for both the 2.4ghz and 5ghz bands, as Sonos only communicates between players using the 2.4ghz band, unless they are being used in a ‘bonded’ HT setup. The 2.4ghz band also needs to support 802.11 b/g/n devices to work.

Both I and a good many others run iOS 13.2 with our controller devices and use various iPhone models and iPad... and iOS 13.2 is not causing any of us an issue with the latest Sonos update. I therefore don’t think the answer lies with iOS 13.2 compatibility in this instance.

I would personally investigate further the things mentioned, or perhaps use this LINK and go back to Sonos Customer Care to discuss those things with them. If you can get to level-2 Support, they maybe able to remote onto your network and try a few more things with you.

Reply