Question

Unable to Control Volume on Sonos Playbar with Sony XBR65X950G Remote


Replaced an existing TV with a new Sony TV and I'm trying to configure the Sony remote to control the volume on a Sonos Playbar. I followed the instructions on the support site (https://support.sonos.com/s/article/3402?language=en_US) but the Sonos doesn't seem to recognize when I press the volume button on the remote.

There are no obstructions to the IR sensor on the Playbar (the Playbar is oriented so that the IR sensor is in the upper right corner) and the remote works with the TV as expected. Any other options to troubleshoot/resolve the problem?

19 replies

How sure are you that the remote is IR? I'm looking at a Sony website, which isn't terribly clear, but seems to suggest that it has bluetooth connectivity, at least for a keyboard, which makes me wonder if the remote isn't bluetooth as well.
Hmmm, this webpage:

https://www.rtings.com/tv/reviews/sony/x950g#comparison_2591

seems to imply that the remote is both bluetooth and IR, when they say:

The remote requires direct line of sight to the TV, despite having the option to connect via Bluetooth, which is necessary for the voice commands.

Have you tried a new set of batteries?
Yes, I've tried a new set of batteries.

Verified with my Android cell phone camera (as suggested by the Sony web site) that the remote is not emitting IR signals and observed in the Android TV settings menu that the remote is connected by Bluetooth (apparently a new feature since it's a voice remote). Another Sony remote for an older generation Sony TV works fine.

Also read the TV documentation which implies IR capabilities but can't find any way to enable them, though I assume the remote is programmable and can support other devices like a receiver. Can't find any other documentation on the remote, I'll try contacting Sony support after the holiday.

Dave
I'd be interested in what you hear back from them....and for others who end up having the same issue. Might be something Sonos could drop into an FAQ, too.
I am having the exact same issue. Harmony 665 works just fine, but the "IR Blaster" portion built-in to Sony remote doesn't work for me (not sure if I can turn blue tooth off). When I called Sony they told me that the IRBlaster was only meant for cable boxes and that they didn't support soundbars. They said I should use the Arc features with HDMI, but Sonos Playbar doesn't have hdmi only optical.

If you guys figure this out please let me know.
Just got off the phone with Sony Support. The representative told me that the remote, RMF-TX600U, is Bluetooth only, no IR capability whatsoever. Very disappointing. Fortunately I was able to setup my DirecTV remote for volume control so I have a workable solution for the time being.

Dave
That's unfortunate, and frustrating to be sure. And a bit looney, in my opinion. On the other hand, I'm a huge fan of the Logitech Harmony multi-remote system, which I use to control my (admittedly dwindling) number of Home Theater devices.

But thanks for coming back and letting us know!
Hmm are you sure @randomparity ? I have the same problem, but can get the remote to pair when it "wakes up" after turning the TV off. I can temporarily control the volume on the soundbar but it quickly stops working. And then the problem you describe takes over. This is so strange, I have to control volume through the phone app and the TV with the Sony remote.

Do you have the RMF-TX600U Voice Remote Control?
Yes, that's the remote I have. (You can never be 100% sure what you hear from technical support ;-)

You should be able to confirm if the remote is controlling volume of the sound bar by observing the white LED in the upper right or lower left of your soundbar (depending on orientation). When you use an IR remote to change the volume you should see the LED light up briefly.
Yep, I noticed this and have gotten it to work (but only briefly, as mentioned). I’m not done giving up quite yet so will keep digging.
I fixed mine by turning off bluetooth in the tv settings. It works now!
I’m not sure why but hitting the “mute” button on the remote fixed this for me. Now the playbar recognizes the IR, blinks, and adjusts volume correctly.
I’m not sure why but hitting the “mute” button on the remote fixed this for me. Now the playbar recognizes the IR, blinks, and adjusts volume correctly.

I have the same TV and the same problem and these last 2 posts worked! I am not sure if I needed to or not but I turned off Bluetooth and then I hit the volume up when the Sonos app asked me too and nothing. then I hit mute like romanvt said and the light lit up on the Sonos Playbar! This is my first post and it is a thank you post. I love the sound of this system with the Playbar, two Play 1's and the sub and now that I can control it with my remote I am happy. thanks to both youhanna8 and romanvt.
Badge
I fixed mine by turning off bluetooth in the tv settings. It works now!
This worked for me. Thank you for the suggestion!
Only just got this tv and found that if you un-pair the remote in the menu it works the playbar. Means also that you don’t have to switch off Bluetooth on the tv. I think the only function you lose by doing this is the voice function from remote.
Turning Bluetooth off worked for me too - Thanks
I have the same tv, turning off Bluetooth fixed the issue
Any more details? Turned off Bluetooth. Then what? I’ve been fighting this for months since I got the tv. This is the closest I’ve come!! Help!
Any more details? Turned off Bluetooth. Then what? I’ve been fighting this for months since I got the tv. This is the closest I’ve come!! Help!
Fixed it. Had to re run the pair. So odd. Sony needs to run a fix to let Bluetooth be on and still emit ir

Reply