Answered

Two rooms, two routers, two Sonoses, not syncing!


I just added a second router (daisy-chained by LAN to main router) in a new room (Loft) and connected my new Beam to it. The Sonos app was already connected to the main router in main room (Living Room). When I am in the Loft, it connects to the beam but the app seems to be open to a new account with none of my old settings. Then I move to Living Room, and old Sonos account appears, with no recognition of the new Beam room. So it looks like I have two Sonos accounts and it jumps from one to the other when I walk from room to room. But does not sync. Any clues how to merge them?
icon

Best answer by ratty 7 January 2019, 15:41

Right now you have two Sonos 'households' (systems), because you set the Beam up separately on the second router.

If you reset the Beam and added it when attached to the primary router it would become part of the main household, and inherit all the settings/accounts therefrom. However the moment you move it back to the second router it will become detached again. Any changes made on the main household won't be reflected on the Beam, and vice versa.

Sonos devices and controllers must sit on the same subnet. They can't communicate between subnets. The Beam won't see or sync with the main household because you have the second router in between.

You really should simply configure the second router in 'bridge'/'access point' mode (many newer routers have this as a config option) then all your Sonos units will be able to communicate with one another.

View original

10 replies

Userlevel 6
Badge +21
Hi TimFielding

You need to turn off DHCP on the second router. Here's a link that may help with setup: https://www.wikihow.com/Connect-Two-Routers

Cheers!
Badge +1
check on which port your second router is connected to the primary - you should avoid using the WAN-port and configure the second router as Access Point (AP) with DHCP disabled in order to keep all devices connected on the same IP-segment
Out of interest, would an alternative workaround be to unplug and reset the Beam and plug it into the main router in the Living Room to get it set up, then take it into the Loft and plug it into the second router there? Would avoid having to configure the second router which I have not done before. Or would the problem persist?
Right now you have two Sonos 'households' (systems), because you set the Beam up separately on the second router.

If you reset the Beam and added it when attached to the primary router it would become part of the main household, and inherit all the settings/accounts therefrom. However the moment you move it back to the second router it will become detached again. Any changes made on the main household won't be reflected on the Beam, and vice versa.

Sonos devices and controllers must sit on the same subnet. They can't communicate between subnets. The Beam won't see or sync with the main household because you have the second router in between.

You really should simply configure the second router in 'bridge'/'access point' mode (many newer routers have this as a config option) then all your Sonos units will be able to communicate with one another.
So I followed the instructions and tried to configure the second router by changing the IP address to one similar to the first router's (changing the penultimate digit), and now I get an Error saying the router does not have a proper IP address. Now I cannot connect with the second router either, so I am bit stuck. Suggestions?
Disconnect the second router. Hook a PC to one of its LAN ports. Power up and reset the router to re-establish contact.

Then try this guide: https://www.cnet.com/how-to/how-to-turn-an-old-wi-fi-router-into-an-access-point/
I dug into the material a bit for the second router which is a Netgear N600, a few years old. It has no 'bridging mode' option but has instructions for setting the router up as a 'repeater' as opposed to access point of base station. It says I should copy over the Mac address of the main router and copy the channel, SSID and security settings. Not exactly a simple configuration exercise as it drops wireless connection as soon as I start reconfiguring it. So i am still a bit stuck
You don't want to set it up as a repeater. It would halve the bandwidth, and you already have an Ethernet cable to that location. Besides, Sonos won't support repeaters/extenders.

Any router can be configured as an access point. Just follow the directions in the CNET article. If you lack the confidence to do so, perhaps you have a friend who can assist.
got it. I'll try following the cnet piece, thanks. have an iMac with an ethernet port that I can hump into the other room
Thanks @ratty for the cnet article, this was helpful. Resolution achieved. What made the difference was unplugging the ethernet connection from the Internet port in Router 2 and putting it into one of the LAN ports. Took me a while to figure the Internet port is the WAN. Apparently this 'tells the router to stop thinking it's a router' and gets it to start behaving more like a bridge from Router 1. (what was confusing for me as a novice was that I thought the Internet port was an input and the LANs were output sockets, but by the looks of things they are two-way. Is that right? Ethernet. Duh) The reconfiguring was then relatively simple. The router rebooted automatically just like cnet said it would and then I opened up LAN Set Up in Advanced Set Up and changed the IP address to the same as Router 1 with the last digit changed, not the penultimate one. Then I turned off the DCHP and it's working as it should. Sonos re-adjusted smartly and I didn't even have to reset the Beam. So thanks everyone for your help.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings