Answered

TV+Beam+Sonos Amp+Surrounds

  • 1 April 2019
  • 9 replies
  • 340 views

Hello Sonos Peeps!

My setup is as follows:
Sony Bravia 65"
Beam connected to TV via HDMI ARC. Ethernet form beam connected to router
Yamaha in ceiling speakers for L+R Rears connected to Sonos Amp
Sonos Amp connected via Ethernet to router

Problem:

Beam works fine through TV but rear surrounds do not play from tv. If I use the volume buttons on the Sonos amp I can here the confirmation "blips" coming from the rear surrounds but it only turns up the beam. I feel like I'm missing a simple step with getting the audio from TV to go to Amp. Do I need to run HDMI from Amp to TV?
icon

Best answer by jaddriggers 2 April 2019, 00:13

Ok with all your suggestions I got it working!

1st issue:

Ethernet from beam to router was bad. Pulled out the network cable tester to confirm and then made a new cable

2nd issue:

Fire TV was set to optical out. Switched it to Dolby Digital over HDMI.


Thanks for everyone’s help!
View original

9 replies

Hmmm. Have you checked to be sure that the Beam is receiving a Dolby Digital signal? Looking at your setup, it looks like you're overly set up, if you're using a Sonos Amp to drive the surrounds....you really only need to connect the CONNECT:AMP with an ethernet cable along with the Beam, since both the Sonos Amp and the Beam have the 5Ghz antenna needed to communicate with each other. But being over connected is fine, nothing to worry about 🙂

And no, you don't need another HDMI cable. Your setup is fine.

When you open the controller app, and select ...More>Settings>Room Settings, what does it say for the room with the Beam? In most cases, it should be something like Living Room (+RS+LS), but it would be good to be sure of what it really says.

Next, while watching a movie, or something similar on the TV, go back in to ...More>Settings>About My Sonos System, and look under the area about the Beam for the line that says Audio In: and tell us what it says after that. If it says something like Stereo, then you'll probably need to look at the audio settings on the TV set, or the devices feeding the TV set. But let us know.
When I go into the room setting it says Family Room (+LS+RS) which I assume the (+LS+RS) are the left and right surrounds. Below is the about my system settings.

Associated ZP: 192.168.1.81

---------------------------------

Beam: Family Room

Version: 10.0 (build 48261220)

Hardware Version: 1.23.1.10-1

Series ID: A100

IP Address: 192.168.1.81

Audio In: Stereo

WM: 1

---------------------------------

Sonos Amp: Family Room (LS+RS)

Version: 10.0 (build 48262190)

Hardware Version: 1.24.1.12-1

Series ID: A100

IP Address: 192.168.1.100

Audio In:

WM: 2
Hi. This may or may not be related to your issue (I suspect it's unrelated), but there is one odd feature here. You say that you have two Sonos components wired to your router, but both the Beam and Amp are connecting wirelessly (indicated by WM:1 and WM:2). Any ideas why your Ethernet connections might not be working?

Leaving that aside, given that you are feeding the Beam a stereo signal, it is to be expected that you don't hear anything from the surrounds (as Bruce explained).
I’ve looked through my tv sounds settings and everything auto detects the external beam. No options to change. To me it’s the sounds from tv is only passing to beam, not to the beam and Sonos Amp/surrounds.
Don’t know why it’s still showing WM1/2. I’ve disabled WiFi on surrounds and it shows disabled but on the beam it says it’s unable to disable and to plugin a Ethernet cable. Next option would be to try a new Ethernet cable on the beam.
To follow up on John's other comments, note the line under the Beam that says:

Audio In: Stereo

That means that your TV is sending only a stereo signal to your Beam, so there would be little (or no) surround information being passed to the surrounds.

You may not be able to change the TV's settings, but what is sending the signal to the TV? i.e. what is it that you're watching? What is feeding the TV? That might be the cause of only stereo.

For instance, I have to go in to my satellite box, and set it up to send a Dolby Digital signal. If you're using a cable box, or satellite box, or some other system, you'd need to look at the audio settings for that.
Amazon Firetv is feeding the tv via HDMI. I’ll check those settings tonight. Thanks!
Hope you find that's the problem, because I think I'm out of ideas 🙂
Ok with all your suggestions I got it working!

1st issue:

Ethernet from beam to router was bad. Pulled out the network cable tester to confirm and then made a new cable

2nd issue:

Fire TV was set to optical out. Switched it to Dolby Digital over HDMI.


Thanks for everyone’s help!

Reply